LINUX.ORG.RU
ФорумAdmin

openwrt rb750 r2 dhcp and vlan

 , ,


0

1

Добрый день.

Никак не могу победить одну проблему - не проходит dhcp через wan порт выделенный из лан порта отдельным vlan и еще одним vlan тегированным. Если убрать тегированный vlan - то все работает... На другом маршрутизаторе с чипом ralink все работает - тут нет.. Что это? ограничение qca953x ? Или глюк? Собирал систему сам из ветки openwrt->main.

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0 eth1.1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1.2'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth1.2'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 1t'

Точнее ничего не работает (ни статика ни dhcp) когда на порту тегированный и не тегированный vlan добавлен..

sekil ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.