LINUX.ORG.RU

Здравствуйте. Помогите решить проблему с NetworkManager и Openwrt.

 , , , ,


0

1

Здравствуйте. Поставил на роутер от мэйзу (r3) openwrt, он не хотел менять свой мак из под граффона, сменил через конфиг, инет зарботал, но почему то ноутбуки на arch linux перестали подключаться через NetworkManager а через dhcpcd нормально идёт, смартфонам пофиг они и так и сяк подключаются. В чём проблема? Как исправить? cat /etc/config/network

  • config interface 'loopback'
  • option ifname 'lo'
  • option proto 'static'
  • option ipaddr '127.0.0.1'
  • option netmask '255.0.0.0'
  • config globals 'globals'
  • option ula_prefix 'fd04:323e:6bab::/48'
  • config interface 'lan'
  • option type 'bridge'
  • option ifname 'eth0.1'
  • option proto 'static'
  • option ipaddr '192.168.1.1'
  • option netmask '255.255.255.0'
  • option ip6assign '60'
  • option macaddr '28:10:7B:EC:90:08'
  • config device 'lan_dev'
  • option name 'eth0.1'
  • option macaddr '28:10:7B:EC:90:08'
  • config interface 'wan'
  • option ifname 'eth0.2'
  • option proto 'dhcp'
  • option macaddr '50:64:2B:C6:6B:B5'
  • config device 'wan_dev'
  • option name 'eth0.2'
  • option macaddr '28:10:7B:EC:90:08'
  • config interface 'wan6'
  • option ifname 'eth0.2'
  • option proto 'dhcpv6'
  • option reqaddress 'try'
  • option reqprefix 'auto'
  • option macaddr '50:64:2B:C6:6B:B6'
  • config switch
  • option name 'switch0'
  • option reset '1'
  • option enable_vlan '1'
  • config switch_vlan
  • option device 'switch0'
  • option vlan '1'
  • option ports '1 4 6t'
  • config switch_vlan
  • option device 'switch0'
  • option vlan '2'
  • option ports '0 6t' На вот этот мак 28:10:7B:EC:90:08 я менял

он не хотел менять свой мак из под графона

Графон (граффон) - умышленное искажение орфографической нормы, отражающее индивидуальные или диалектные нарушения нормы фонетической.

anonymous ()

Поробуй загрузи какой нибудь лайфовый арч. Если все ок - то ищи проблему в арче а не в роутере.

xaTa ★★★ ()
Ответ на: комментарий от xaTa

На 1 ноуте manjaro не подключается через nm, 2 ноутбук работает на чистом как слеза детсвенници arch linux тоже не подключается через nm.

MIISHA ()

Всем спасибо я всё сделал В конфиге NM добавил [main] dhcp=dhcpcd

MIISHA ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.