LINUX.ORG.RU
решено ФорумAdmin

OpenWRT dhcp client с раздачей на LAN порты

 ,


0

1


Всем привет.
Роутер TP-LINK TL-WR842N c 5 портами, 1 WAN, 2-5 LAN (R2)
Хочу получать интернет от такого же роутера с OpenWRT (R1) 192.168.22.0, что бы R2 был в той же подсети и с LAN портов транслировалась адресация из 192.168.22.0/24
R2 удалось сделать dhcp клиентом получает 192.168.22.205, но с LAN портов ничего вообще не получает ноут, ни айпишника не соответственно интернета.
Конфиг R1 /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.22.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
    option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wifiwan'
    option proto 'dhcp'

Конфиг R2 /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcp'^M

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'
подскажите в какую сторону смотреть?

Ты хочешь какую-то наркоманию, которая неизбежно приведет к проблемам. Делать две сети, с одинаковыми адресными пространствами это огромное поле из граблей (с гвоздями в рукоятке), и что-то мне подсказывает, что openwrt не приспособлен разркливать такое из коробки.
Либо делай нормальную маршрутизацию с разными сетями, либо бридж.

Khnazile ★★★★★ ()
Ответ на: комментарий от voltmod

делал их бриджом, т.е. просто в WAN добавил такой же bridge что и стоит на лане.
cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcp'^M

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

появляется интерфейс br-wan, но так же ноут не получает от локальных портов айпишник.

br-lan    Link encap:Ethernet  HWaddr 7C:8B:CA:4B:5A:FA
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br-wan    Link encap:Ethernet  HWaddr 7C:8B:CA:4B:5A:FB
          inet addr:192.168.22.205  Bcast:192.168.22.255  Mask:255.255.255.0
          inet6 addr: fe80::7e8b:caff:fe4b:5afb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:258 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:32029 (31.2 KiB)  TX bytes:41842 (40.8 KiB)

eth0      Link encap:Ethernet  HWaddr 7C:8B:CA:4B:5A:FA
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:5

eth1      Link encap:Ethernet  HWaddr 7C:8B:CA:4B:5A:FB
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:242 errors:0 dropped:0 overruns:0 frame:0
          TX packets:253 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:35921 (35.0 KiB)  TX bytes:40740 (39.7 KiB)
          Interrupt:4

forzasakh ()

Роутер TP-LINK TL-WR842N c 5 портами, 1 WAN, 2-5 LAN (R2)
Хочу получать интернет от такого же роутера с OpenWRT (R1) 192.168.22.0, что бы R2 был в той же подсети и с LAN портов транслировалась адресация из 192.168.22.0/24

Что ты хочешь на самом деле? Использовать R2 в качестве AP для расширения области покрытия? Объединяешь все порты в br, включаешь dhcp-client (для управления r2), отключаешь dhcp-server (r1 справится).

https://openwrt.org/docs/guide-user/network/wifi/dumbap - тут подробности

Kolins ()
Последнее исправление: Kolins (всего исправлений: 1)

разделение на WAN и LAN виртуальное и существует только в мозгах руот-алгоритма.
удали WAN в сетевых интерфейсах и пропиши аппаратный порт как один из LAN портов.
dhcp сервер отключи.
у тебя получится свитч с слишком умным процессором внутре.

pfg ★★★★★ ()
Последнее исправление: pfg (всего исправлений: 1)
Ответ на: комментарий от Kolins

Хочу что бы устройства которые подключены к R1 и R2 (а подключены они все пол ЛАНу что в R1 что в R2) были в одной локальной сети и ими можно было управлять, как минимум заходить на них.
По ссылке уже попробовал сделать, R2 отвалился))) но это всё пока локально проверяю на тестовой сборке.
Что я сделал:
отключил dhcp
закомментил wan
в lan добавил интерфейс который принадлежал wan'y (eth1)
добавил 0 порт в switch_vlan
Поулчилось вот так

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0 eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcp'^M

#config interface 'wan'
#        option ifname 'eth1'
#        option proto 'dhcp'
#        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'
И на этом я его больше не видел)

forzasakh ()
Ответ на: комментарий от forzasakh

option proto 'dhcp'^M

Что за ^M в конце?

Попробуйте все в аппаратный свитч запихнуть:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0 wlan0'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcp'

#config interface 'wan'
#        option ifname 'eth1'
#        option proto 'dhcp'
#        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'

#config switch_vlan
#        option device 'switch0'
#        option vlan '2'
#        option ports '0 6t'
Kolins ()
Последнее исправление: Kolins (всего исправлений: 1)
Ответ на: комментарий от forzasakh

добавил 0 порт в switch_vlan

Скорее всего, поэтому ты его больше и не видел. Могу предположить, что у тебя два интерфейса: один простой, и второй свитч с четырьмя портамм. Ты не можешь просто так всунуть первый во второй, он физически не является switchport’ом. OpenWRT не любит ошибок в конфигурации свитча. Объединять их в бридж можно.

anonymous ()
Ответ на: комментарий от Kolins

И так, дошли наконец руки, что бы всё потестить в свободном времени.
После двух неудачных попыток R2 превращался в кирпич, благополучно его восстанавливал, поставил OpenWRT 19.07.1
И для того что бы объединить WAN и LAN (т.е. что бы WAN стал просто дополнительным LAN портом) достаточно вот такого конфига
Конфиг R2 /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd94:b631:f468::/48'

#config interface 'wan'
#       option ifname 'eth1'
#       option proto 'dhcp'

#config interface 'wan6'
#       option ifname 'eth1'
#       option proto 'dhcpv6'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth1'
        option proto 'dhcp'
#       option ipaddr '192.168.1.1'
#       option netmask '255.255.255.0'
#       option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'
Т.е. по суди добавил интерфейс WAN'a в bridge для локальных портов
Спасибо за ссылку!

forzasakh ()