LINUX.ORG.RU

Pulseaudio порт по умолчанию

 


0

1

В настройках Pulseaudio в устройствах вывода есть селект «Port», где можно выбрать 2 значения: - Линейный выход (играют только колонки) - Аналоговые наушники (играют колонки и наушники, через фронтальный порт)

Мне нужно, чтоб было по-умолчанию выбрано второе значение. После перезагрузки всегда сбрасывается в первое.

Благодаря ответу из темы unix.stackexchange.com добавил строчку set-sink-port 0 analog-output-headphones в файл default.pa и даже всё заработало. Но после каждой третьей (или четвертой) перезагрузки перестает вообще работать звук. Помогает комментарий данной строчки и ребут.

Ошибка, когда пропадает звук: «No PulseAudio daemon running, or not running as session daemon.»

Напрягает, после каждого включения менять порт.

Здесь поможет только багрепорт разработчикам.

Вопрос знающим людям: с ALSA (или звуковым сервером JACK) можно делать сабж?

ZenitharChampion ★★★★★ ()

Помогает комментарий данной строчки и ребут

pusleaudio --kill; pulseaudio --start от юзера

Ну и логи посмотри почему оно так не играет. Или verbose в systemd сервис добавь, чтоб оно сразу максимум в логи срало.

entefeed ☆☆☆ ()
Ответ на: комментарий от entefeed

Спасибо за ответы! pulseaudio --start работает только после комментирования строчки. Вроде сейчас такая проблема не возникает. проблема возникала, когда я менял конфигурацию оборудования (видюхи менял) или заходил под другими учётными записями.

Удобства один фиг не хватает, чтоб указывать порт по умолчанию через интерфейс.

Gorrion ()
16 сентября 2016 г.

я эту проблему тоже сразу заметил, т.к. ничего накопать по теме не удалось просто выхожу в ждущий режим - настройки отстаются на своих местах )

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.