LINUX.ORG.RU

Настройка HDMI для Pulseaudio

 ,


0

1

День добрый. Тема избитая, неоднократно поднималась на форуме, однако все что я делаю неизменно приводит к тому что демон пульса просто не стартует.

Есть ноутбук с HD4000, на нем есть HDMI выход. Сейчас Pulseaudio видит ровно одно звуковое устройство и переключать звук с HDMI на Audio приходится во вкладке Configuration. Хочется иметь два устройства, а в идеале - возможность роутить часть звука через HDMI, часть - через колонки/наушники ноутбука. Подскажите как это сделать?

~  ᐅ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC275 Analog [ALC275 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
(последний вывод - это HDMI на док-станции, нам он не интересен)
~  ᐅ pulseaudio --version
pulseaudio 3.0

Я пробовал добавлять следующее:

load-module module-alsa-sink device=hw:0,3
load-module module-alsa-sink device=hw:0,0
в конец /etc/pulse/default.pa, но к результатам это не привело, демон не стартует


А в лог то, что он пишет?

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

В логи пишется, что не удалось инициализировать модуль module-alsa-sink

Мне кажется, но это мои домыслы и я могу быть не прав, что подобная конфигурация конфликтует с автоматической конфигурацией через udev. Я пробовал ее отключать, тогда пульса поднимается, но похоже output идет не через нее (в pavucontrol не видно к примеру проигрывающейся в хромиуме музыки)

xanf ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.