LINUX.ORG.RU

Black screen after BIOS loaded


0

1

Sorry for bad language, I'm writing from the fridge =)

I was trying to install Debian squeeze on my machine above lenny(on its partitions). I also had Windows7 on my pc. Installation wasn't successful and I made a mistake that killed Windows disk C partition =[

I tried to reinstall Windows but cd with installer wasn't found by pc, but not linux installer cd. After the long time trying to set up something I had grub in my MBR and couldn't boot from anywhere (cd, hdd, usb). And as a final thing I have a trouble: PC power on -> loading BIOS(it's all right) -> black screen with «_» blinking in left up corner.

I can't boot from anywhere and I don't know what to do. Help me please! Thanks.


Looks like you killed your MBR or partition table.
Had almost the same issue with my notebook not long ago.
Do you have SATA HDD? Try to remove it, boot from livecd and hot-plug it again.
Then check partitions and correct if needed. Also, try to re-install GRUB MBR if needed.

devl547 ★★★★★ ()

Загрузись с дискеты с GRUB, из консоли граба загрузи Дебиан (если он не потёрся), из Дебиана установи граб каким-нибудь grub-install.

gentoo_root ★★★★★ ()
Ответ на: комментарий от devl547

Нашел ноут с русской раскладкой =)

vurdalak и gentoo root меня не поняли. Я не могу загрузиться ни с одного устройства.

Had almost the same issue with my notebook not long ago.

У меня тоже проблема на ноутбуке- ASUS K50iN.

Do you have SATA HDD?

Да, у меня сата.

Меня беспокоит хот-плаг харда - не погорит ли?

Krems ()
Ответ на: комментарий от devl547

Спасибо, совет помог. Плагить не рискнул, ткнул в чужой асус(в общаге то) и там он прочитался - форматнул с лайвы - всеработает(ну правда кеды зависают при запуске, но это в другую тему=) ).

Krems ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.