LINUX.ORG.RU
ФорумAdmin

Спасите меня от iPXE!!!


0

1

нашел в сетке такое сообщение и у меня точно такая же проблема, выручайте!

First of all, Thank you very much for your excellent program which works fine on almost all my hardware.

I have found an incompatibility of your iPXE software with IBM X series server. There is BNX2 and UEFI I have disabled almost all ROMs and set boot from «Lecacy Only» + PXE.

Please note, the same config works fine with a ESXI VM and another IBM x-series Blade.

The iPXE program starts but then during running my script It displays the card has been initialized and then dhcp displays something like «connection timeout» (though I do not remember the message exactly) and then the curors starts to blink in many places of the screen moving very fast anb it looks like there are many about 20-30 cursors, the program does not respond at this time (may be except ctrl-alt-del if I remember correct)

If I remember correct shell and config does not see any net0, etc. everything seems blank. BUT after exiting from the shell manually it continues the script and DHCP already works, net appears, able to sanboot.

It is embedded script because running from grub4dos there is another different problem. And this IBM X3690 server boots fine by PXE protocol with a help of pxelinux.0 and grub4dos, but I need to setup iBFT (I prefer iBFT over iscsi kernel parameters)

So the only current solution I have found accidently is to call shell at the beginning of the script and then manually exit from shell, then it works fine. May be it is possible at least to automate enter and exit from shell as a fast workaround to avoid coming to remote server each time?

такая хрень была в свое время с etherboot, если dhcp раздавался с виндового сервера. в gpxe вроде это починили - может новая регрессия в ipxe?

dyasny ★★★★★ ()
Ответ на: комментарий от dyasny

MAC в вендовом DHCP сервере заблокирован

DHCP раздается от DNSMASQ, отфильтрованным firehol-ом

то, что запускается ipxe, а не «command not found» уже намекает на то, что ответ приходит от DNSMASQ

на других серверах аналогично работает нормально

потом пытался на проблемном сервере с помощью grub4dos в PXE режиме, так initrd не реагирует на параметр ip=dhcp,

ifconfig из busybox демонстрирует, что интерфейсы остаются несконфигурированными, причем lsmod показывает,

что bnx2 есть в списке.

подобная проблема описана:

http://grzybowski.waw.pl/dokuwiki/doku.php?id=iscsi

кстати у меня /sys/firmware/ibft отсутствует, так что такой фикс бы не помог

пришлось статически прописать конфиг в параметрах ядра eth0: ip=...,eth0

и то это чудо загрузилося внезапно (через 3 дня мучений)!

iBFT из UEFI BIOS тоже не ставилось, может быть есть альтернатива iPXE? мне бы grub4dos или pxelinux.0 было бы более чем достаточно

т.е. хотелось бы найти утилитку, которая вызывается из grub4dos устанавливает iBFT и возвращаяется обратно или грузит следующий grub4dos

sanyock ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.