LINUX.ORG.RU

не могу установить программу

 


0

1

Использую debian squeeze стабильную ветку. Очень хочу поиграться с программкой supercollider (это для программирования музыки). Установить deb-пакет или из сырцов с офф сайта не получается - в репозитории отсутствуют нужные зависимости(в т.ч. в unstable и testing). Однако этот пакет есть в sid unstable... Я добавляю в sources.list строчку:

deb http://ftp.uk.debian.org/debian/ sid main contrib unstable

и пытаюсь установить supercollider:

apt-get -t unstable install supercollider
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libarchive1 libqt4-sql-mysql libqt4-qt3support mysql-common libpulse-mainloop-glib0
  libgsf-1-common libqt4-sql libphonon4 libqt4-designer libmysqlclient16
  libmysqlclient18 libqt4-script libgsf-1-114 qt4-qtconfig
Для их удаления используйте 'apt-get autoremove'.
Будут установлены следующие дополнительные пакеты:
  binutils cmake cmake-data cpp-4.4 cpp-4.7 desktop-file-utils ecj fontconfig-config
  g++-4.4 gcc-4.4 gcc-4.4-base gcc-4.7 gcc-4.7-base gcj-4.7-base gcj-4.7-jdk
  gcj-4.7-jre gcj-4.7-jre-headless gcj-4.7-jre-lib gcj-jdk gcj-jre gcj-jre-headless
  gtk2-engines-pixbuf gvfs gvfs-common gvfs-daemons gvfs-libs jackd jackd2
  jackd2-firewire javascript-common libaacs0 libacl1 libarchive12 libattr1
  libbluetooth3 libbluray1 libboost-filesystem1.49.0 libboost-regex1.49.0
  libboost-system1.49.0 libboost-thread1.49.0 libc-bin libc-dev-bin libc6 libc6-dev
  libc6-i686 libconfig++9 libcwiid1 libdbus-1-3 libdbus-1-dev libecj-java libffado2
  libfontconfig1 libgail18 libgcc1 libgcj-bc libgcj-common libgcj13 libgcj13-awt
  libgcj13-dev libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgdu0 libgfortran3
  libglib2.0-0 libglibmm-2.4-1c2a libgmp10 libgnutls26 libgomp1 libgpg-error0
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2.0-0 libgtk2.0-bin
  libicu48 libiec61883-0 libitm1 libjack-jackd2-0 libjack-jackd2-dev libjbig0
  libjpeg8 libjs-jquery libjs-mathjax libjs-underscore liblzma5 libmpc2 libmpfr4
  libmysqlclient18 libnettle4 liborc-0.4-0 libp11-kit0 libpcre3 libqt4-dbus
  libqt4-designer libqt4-network libqt4-qt3support libqt4-script libqt4-sql
  libqt4-sql-mysql libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4
  libqtgui4 libqtwebkit4 libquadmath0 librsvg2-2 librsvg2-common libsamplerate0
  libscsynth1 libstdc++6 libstdc++6-4.4-dev libtiff4 libwmf0.2-7 libx11-6 libx11-dev
  libxml++2.6-2 libxmlrpc-core-c3 locales make multiarch-support mysql-common
  pkg-config qdbus qjackctl qt4-qtconfig supercollider-common supercollider-server
  wwwconfig-common
Предлагаемые пакеты:
  binutils-doc gcc-4.4-locales gcc-4.7-locales g++-4.4-multilib gcc-4.4-doc
  libstdc++6-4.4-dbg gcc-4.4-multilib libmudflap0-4.4-dev libgcc1-dbg libgomp1-dbg
  libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7 gcc-4.7-multilib
  libmudflap0-4.7-dev gcc-4.7-doc libitm1-dbg libquadmath0-dbg binutils-gold
  gcj-4.7-source libgcj13-dbg gvfs-backends jack-tools meterbridge apache2 httpd
  libbluray-bdj glibc-doc libgcj-doc libvisual-0.4-plugins gstreamer-codec-install
  gnome-codec-install gstreamer0.10-tools gstreamer0.10-plugins-base libqt4-dev
  librsvg2-bin libstdc++6-4.4-doc make-doc pulseaudio-utils subversion mysql-client
  postgresql-client
Рекомендуемые пакеты:
  libx11-doc
Пакеты, которые будут УДАЛЕНЫ:
  g++-4.3 gcc-4.3 gcj-4.4-base gcj-4.4-jdk gcj-4.4-jre gcj-4.4-jre-headless
  gcj-4.4-jre-lib libgcj10 libgcj10-awt libgcj10-dev libstdc++6-4.3-dev libxmlrpc-c3
  linux-headers-2.6-686 linux-headers-2.6.32-5-686
НОВЫЕ пакеты, которые будут установлены:
  cpp-4.7 desktop-file-utils gcc-4.7 gcc-4.7-base gcj-4.7-base gcj-4.7-jdk
  gcj-4.7-jre gcj-4.7-jre-headless gcj-4.7-jre-lib gvfs-common gvfs-daemons gvfs-libs
  jackd jackd2 jackd2-firewire javascript-common libaacs0 libarchive12 libbluetooth3
  libbluray1 libboost-filesystem1.49.0 libboost-regex1.49.0 libboost-system1.49.0
  libboost-thread1.49.0 libconfig++9 libcwiid1 libffado2 libgcj13 libgcj13-awt
  libgcj13-dev libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libglibmm-2.4-1c2a libgmp10
  libicu48 libiec61883-0 libitm1 libjbig0 libjs-jquery libjs-mathjax libjs-underscore
  liblzma5 libmpc2 libmysqlclient18 libnettle4 libp11-kit0 libqtdbus4 libqtwebkit4
  libquadmath0 libsamplerate0 libscsynth1 libxml++2.6-2 libxmlrpc-core-c3
  multiarch-support qdbus qjackctl supercollider supercollider-common
  supercollider-server wwwconfig-common
Пакеты, которые будут обновлены:
  binutils cmake cmake-data cpp-4.4 ecj fontconfig-config g++-4.4 gcc-4.4
  gcc-4.4-base gcj-jdk gcj-jre gcj-jre-headless gtk2-engines-pixbuf gvfs libacl1
  libattr1 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libdbus-1-3 libdbus-1-dev
  libecj-java libfontconfig1 libgail18 libgcc1 libgcj-bc libgcj-common libgdu0
  libgfortran3 libglib2.0-0 libgnutls26 libgomp1 libgpg-error0
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2.0-0 libgtk2.0-bin
  libjack-jackd2-0 libjack-jackd2-dev libjpeg8 libmpfr4 liborc-0.4-0 libpcre3
  libqt4-dbus libqt4-designer libqt4-network libqt4-qt3support libqt4-script
  libqt4-sql libqt4-sql-mysql libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4
  libqtgui4 librsvg2-2 librsvg2-common libstdc++6 libstdc++6-4.4-dev libtiff4
  libwmf0.2-7 libx11-6 libx11-dev locales make mysql-common pkg-config qt4-qtconfig
обновлено 70, установлено 60 новых пакетов, для удаления отмечено 14 пакетов, и 937 пакетов не обновлено.
Необходимо скачать 148 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 90,1 MB.
Хотите продолжить [Д/н]?

а если сказать aptitude, вместо apt-get, то еще хлеще:

aptitude install supercollider 
Следующие НОВЫЕ пакеты будут установлены:        
  desktop-file-utils{a} gcc-4.7-base{ab} gvfs-common{a} gvfs-daemons{a} 
  gvfs-libs{a} jackd{a} jackd2{a} jackd2-firewire{a} javascript-common{a} 
  libaacs0{a} libarchive12{a} libbluetooth3{a} libbluray1{a} 
  libboost-filesystem1.49.0{a} libboost-regex1.49.0{a} libboost-system1.49.0{a} 
  libboost-thread1.49.0{a} libconfig++9{a} libcwiid1{a} libffado2{a} 
  libglibmm-2.4-1c2a{a} libgmp10{a} libicu48{a} libiec61883-0{a} libjbig0{a} 
  libjs-jquery{a} libjs-mathjax{a} libjs-underscore{a} liblzma5{a} libnettle4{a} 
  libqtdbus4{a} libqtwebkit4{a} libsamplerate0{a} libscsynth1{a} libxml++2.6-2{a} 
  libxmlrpc-core-c3{a} multiarch-support{a} qdbus{a} qjackctl{a} supercollider 
  supercollider-common{a} supercollider-server{a} wwwconfig-common{a} 
Следующие пакеты будут УДАЛЕНЫ:
  libarchive1{u} libmysqlclient16{u} libqt4-designer{u} libqt4-qt3support{u} 
  libqt4-script{u} libqt4-sql{u} libqt4-sql-mysql{u} libxmlrpc-c3{u} 
  mysql-common{u} qt4-qtconfig{u} 
Следующие пакеты будут обновлены:
  cmake cmake-data cpp-4.4 fontconfig-config gcc-4.4 gcc-4.4-base{b} gvfs libacl1 
  libattr1 libc-bin libc-dev-bin libc6 libc6-dev libdbus-1-3 libfontconfig1 
  libgcc1{b} libgdu0 libglib2.0-0 libgomp1{b} libgpg-error0 
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libjack-jackd2-0 libjpeg8 
  libmpfr4 liborc-0.4-0 libpcre3 libqt4-dbus libqt4-network libqt4-xml libqtcore4 
  libqtgui4 libstdc++6{b} libtiff4 locales make pkg-config 
37 пакетов обновлено, 43 установлено новых, 10 пакетов отмечено для удаления, и 963 пакетов не обновлено.
Необходимо получить 76,0 MB архивов. После распаковки 86,0 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libstdc++6: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4 
  gcc-4.7-base: Ломает: gcj-4.4-base (< 4.4.6-9~) но установлен 4.4.5-2 
  libgfortran3: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-3.
  g++-4.4: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-3.
           Зависит: gcc-4.4 (= 4.4.5-8) но устанавливается 4.4.7-3.
  libgomp1: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4 
  libstdc++6-4.4-dev: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-3.
  libqt4-xmlpatterns: Зависит: libqt4-network (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
                      Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libc6-i686: ПредЗависит: libc6 (= 2.11.3-4) но устанавливается 2.13-38.
  libgcc1: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4 
  libqt4-webkit: Зависит: libqt4-network (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
                 Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
                 Зависит: libqtgui4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libjack-jackd2-dev: Зависит: libjack-jackd2-0 (= 1.9.6~dfsg.1-2) но устанавливается 1.9.8~dfsg.4+20120529git007cdc37-5.
  libdbus-1-dev: Зависит: libdbus-1-3 (= 1.2.24-4+squeeze1) но устанавливается 1.6.8-1.
  gcc-4.4-base: Конфликтует: gcj-4.4-base (< 4.4.6-9~) но установлен 4.4.5-2 
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                        
1)      bsh-gcj                                                                        
2)      build-essential                                                                
3)      ecj                                                                            
4)      ecj-gcj                                                                        
5)      g++                                                                            
6)      g++-4.3                                                                        
7)      g++-4.4                                                                        
8)      gcc-4.3                                                                        
9)      gcj-4.4-base                                                                   
10)     gcj-4.4-jdk                                                                    
11)     gcj-4.4-jre                                                                    
12)     gcj-4.4-jre-headless                                                           
13)     gcj-4.4-jre-lib                                                                
14)     gcj-jdk                                                                        
15)     gcj-jre                                                                        
16)     gcj-jre-headless                                                               
17)     gimp                                                                           
18)     kupfer                                                                         
19)     libantlr-java-gcj                                                              
20)     libavahi-client-dev                                                            
21)     libblas3gf                                                                     
22)     libboost-dev                                                                   
23)     libboost-signals-dev                                                           
24)     libboost-signals1.42-dev                                                       
25)     libboost-test-dev                                                              
26)     libboost-test1.42-dev                                                          
27)     libboost1.42-dev                                                               
28)     libc6-i686                                                                     
29)     libdb4.7-java-gcj                                                              
30)     libdbus-1-dev                                                                  
31)     libecj-java-gcj                                                                
32)     libgcj-bc                                                                      
33)     libgcj10                                                                       
34)     libgcj10-awt                                                                   
35)     libgcj10-dev                                                                   
36)     libgfortran3                                                                   
37)     libjack-jackd2-dev                                                             
38)     libjaxp1.3-java-gcj                                                            
39)     liblapack3gf                                                                   
40)     liblog4j1.2-java-gcj                                                           
41)     libqt4-webkit                                                                  
42)     libqt4-xmlpatterns                                                             
43)     libstdc++6-4.3-dev                                                             
44)     libstdc++6-4.4-dev                                                             
45)     libxalan2-java-gcj                                                             
46)     libxerces2-java-gcj                                                            
47)     linux-headers-2.6-686                                                          
48)     linux-headers-2.6.32-5-686                                                     
49)     python-gnome2                                                                  
50)     python-gtk2                                                                    
51)     python-keybinder                                                               
52)     python-numpy                                                                   
53)     python-wnck                                                                    

      Сохранить для следующих пакетов их текущие версии:                               
54)     supercollider [Не установлен]                                                  

      Оставить следующие зависимости неразрешёнными:                                   
55)     libantlr-java рекомендует libantlr-java-gcj                                    
56)     bsh рекомендует bsh-gcj                                                        
57)     libdb4.7-java рекомендует libdb4.7-java-gcj                                    
58)     dkms рекомендует linux-headers-2.6-686 | linux-headers-2.6-amd64 | linux-header
59)     dpkg-dev рекомендует build-essential                                           
60)     libgcj10 рекомендует gcj-4.4-jre-lib (>= 4.4.4-17)                             
61)     gimp-data рекомендует gimp                                                     
62)     libgimp2.0 рекомендует gimp                                                    
63)     liblog4j1.2-java рекомендует liblog4j1.2-java-gcj                              
64)     kupfer рекомендует python-gnome2                                               
65)     kupfer рекомендует python-wnck                                                 
66)     linux-image-2.6.32-5-686 рекомендует libc6-i686                                
67)     libxalan2-java рекомендует libxalan2-java-gcj                                  
68)     libxerces2-java рекомендует libxerces2-java-gcj                                
69)     libc6 рекомендует libc6-i686                                                   


Принять данное решение? [Y/n/q/?] 
При этом происходит много странного.

Во-первых он пытается обновить то, чего обновлять не нужно.

Во-вторых меня смущает:

Следующие пакеты устанавливались автоматически и больше не требуются:
  libarchive1 libqt4-sql-mysql libqt4-qt3support mysql-common libpulse-mainloop-glib0
  libgsf-1-common libqt4-sql libphonon4 libqt4-designer libmysqlclient16
  libmysqlclient18 libqt4-script libgsf-1-114 qt4-qtconfig
Для их удаления используйте 'apt-get autoremove'.
Если дать комманду apt-get autoremove, то ничего не удаляется. А если попытаться удалить эти пакеты вручную, то пишет:
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-core : Рекомендует: libgl1-mesa-dri (>= 7.10.2-4) но 7.7.1-5 будет установлен
                     Ломает: libgl1-mesa-dri (< 7.10.2-4) но 7.7.1-5 будет установлен

В общем бардак полный. При этом система безупречно работает уже пол года, очень не хочу все поломать...

Со дня на день должен выйти Wheezy, для него пакет есть? Можно попробовать обновиться и в новую систему поставить программу.

olibjerd ★★★★★ ()
Ответ на: комментарий от olibjerd

Со дня на день должен выйти Wheezy, для него пакет есть? Можно попробовать обновиться и в новую систему поставить программу.

Да есть, даже чуть поновее версия. Если не получится решить проблему, то буду ждать wheezy... Но опять же, там supercollider похоже будет в нестабильной ветке.

arte-at-marte ()
Ответ на: комментарий от AITap

Поставьте приоритет пакетам из sid меньше 500, и они не будут ставиться вместо пакетов из squeeze.

после этого

aptitude/apt-get install supercollider
ругается на неудовлетворенные зависимости.

А если

aptitude/apt-get -t unstable install supercollider
то картина точно такая же...

arte-at-marte ()

Попробовал собрать supercollider из Wheezy, но не получилось, пишет, что не найден libicu, хотя он установлен. К тому же у него в Build-Depends указан gcc-4.6, который есть только в Wheezy, и собирать его для Squeeze будет крайне муторно. В общем, лучше подождать Wheezy.

eugeno ★★★★★ ()
Ответ на: комментарий от olibjerd

Со дня на день должен выйти Wheezy

Не должен, ещё 212 багов осталось закрыть, это как минимум на месяц.

eugeno ★★★★★ ()

Принять данное решение? [Y/n/q/?]

С aptitude бывает если ответить n, то он предлагает другой вариант, бывает что более приемлимый.

firestarter ★★★☆ ()

По моему опыту, проще перейти на wheezy, чем заниматься бекпортированием.

i-rinat ★★★★★ ()
Ответ на: комментарий от firestarter

С aptitude бывает если ответить n, то он предлагает другой вариант, бывает что более приемлимый.

В данном случае все решения, которые он предлагает приводят к «сломаным» зависимостям. Я уже однажды согласился на один из «приемлемых» вариантов, которые предложил мне aptitude... После этого началось такое, что я решил, что быстрее и надежней будет переустановить систему...

arte-at-marte ()
Ответ на: комментарий от arte-at-marte

Я обычно использую aptitude, подобное у меня возникало только когда я подключал репы от другой версии дистра (чаще будущей версии, чтобы поставить новую версию какого нибудь ПО).

firestarter ★★★☆ ()
Ответ на: комментарий от i-rinat

По моему опыту, проще перейти на wheezy, чем заниматься бекпортированием.

Supercollider есть в «стабильной» веткe в ubuntu. Проще уж туда сразу. Но, блин, не хватает какой-нибудь программы в debian - ставишь убунту. Потом она появляется в debian, а убунта уже начинает раздражать из-за своих внутренностей - ставишь дебиан... Для меня это будет уже пятая итерация... ~~"

arte-at-marte ()

Замути виртуалку с нужной осью.

ziemin ★★ ()
Ответ на: комментарий от arte-at-marte

Но, блин, не хватает какой-нибудь программы в debian - ставишь убунту.

Ставь wheezy.

i-rinat ★★★★★ ()

Использую debian squeeze стабильную ветку. Очень хочу поиграться с программкой supercollider (это для программирования музыки). Установить deb-пакет или из сырцов с офф сайта не получается - в репозитории отсутствуют нужные зависимости(в т.ч. в unstable и testing). Однако этот пакет есть в sid unstable... Я добавляю в sources.list строчку:

Pinning из нестабильных веток в стабильные - очень и очень плохая идея. Я тут методично народ так делать отговариваю. Единственное правильное решение - бэкпорт.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

я вот читаю, как делаются бэкпорты... шаблонные инструкции не проходят, а чтобы сделать это как то иначе, нужно понять, что такое бэкпорты, но это у меня как раз и не получается... это когда ставятся все необходимые библиотеки, но не делаются текущими? речь о библиотеках т.к. для установки supercollider'а так же нужно бэкпортить целую кучу библиотек.

это вообще полностью корректно, брать сырцы пакетов из sid и пересобирать их для squeeze?

и в какой момент устанавливается, что программе нужна библиотека именно такой то версии (ну т.е. не та, которая по умолчанию)? при пересборке?

arte-at-marte ()
Ответ на: комментарий от arte-at-marte

Самое простое - берешь исходник supercollide из unstable, там уже есть каталог debian, подправить, если надо, debian/control (занизить версии в зависимостях), debian/rules, debian/compat и т. д., попробовать пересобрать.

Когда библиотеки просто нет в stable, то это самая простая ситуация. Надо, да, собрать еще и эту библиотеку под stable (тоже взять дебиановские исходники).

Если библиотеки в stable есть, то надо установить нужные -dev.

Проблемка будет, если со всеми имеющимися библиотеками не собирается. Это может быть, если API поменялось. Тогда возможны разные варианты: патчить пакет, чтобы собирался, компилировать новую версию библиотеки вместе со старой и т. д.

Далее я все автоматом складываю в свой локальный репозиторий для моих бэкпортов и ставлю оттуда.

Я посмотрел на зависимости этого supercollide. По-моему, они совершенно не такие страшные. Где ты считаетшь, что серьезная проблема?

Для сервера все библиотеки есть в stable

supercollider-server: jackd, libc6, libfftw3-3, libgcc1, libscsynth1, libsndfile1, libstdc++6, libunwind7, libx11-6

Для supercollider все есть. libsclang1 собирается из тех же исходников supercollider, libscsynth1 - тоже из этих исходников. Где-то там в глубине зависимостей есть libicu48 - ее собрать надо, так как в stable нет, но у нее звисимости тоже простые.

supercollider: libc6, libcwiid1, libgcc1, libsclang1, libstdc++6, supercollider-common, supercollider-server

Для supercollider-common вообще нет зависимостей.

В общем, посидеть придется, но мне кажется, что сильных проблем быть не должно

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)
Ответ на: комментарий от arte-at-marte

и в какой момент устанавливается, что программе нужна библиотека именно такой то версии (ну т.е. не та, которая по умолчанию)? при пересборке?

Это устанавливает сопровождающий. Чаще всего он берет версии из текущего релиза, но это не означает, что более старые не подойдут. Просто он уже не пробует с более старыми. Я обычно просто тупо занижаю версию, если планку подняли выше текущего stable. И те несколько пакетов, которые я бекпортил, вполне себе собираются.

Да, ну и выясняется, что она уже не та (если на самом деле не та) в апстриме. Они там говорят, типа: «Для пакета нужна самая свежая версия библиотеки. У вас stable? Тогда идите в жопу - нас не волнует то, что программу собрать смогут только пользователи самых нестабильных дистрибутивов и ее меньше людей увидит» :) гыгы

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.