LINUX.ORG.RU
решено ФорумAdmin

Ошибка при обновлении Debian


0

1

Был Debian lenny решил обновить до Debian 6 по причине обновления bash

во время aptitude dist-upgrade завис ssh клиент и выкинуло,по новой aptitude dist-upgrade выдало ошибку:

# aptitude dist-upgrade The following NEW packages will be installed: apache2.2-bin{a} consolekit{a} db4.8-util{a} dbconfig-common{a} dmsetup{a} dosfstools{a} fuse-utils{a} gcc-4.4{a} gettext-base{a} grub-pc{a} gvfs{a} hdparm{a} javascript-common{a} libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a} libasound2{a} libatasmart4{a} libbind9-60{a} libbsd0{a} libcanberra-gtk-module{a} libcanberra-gtk0{a} libcanberra0{a} libck-connector0{a} libclamav6{a} libdirectfb-1.2-9{a} libdns69{a} libeggdbus-1-0{a} libevent-1.4-2{a} libfile-copy-recursive-perl{a} libfuse2{a} libgcr0{a} libgdu0{a} libgp11-0{a} libgssapi-krb5-2{a} libgtkhtml3.14-19{a} libgudev-1.0-0{a} libisc62{a} libisccc60{a} libisccfg62{a} libjasper1{a} libjs-mootools{a} libk5crypto3{a} libkrb5-3{a} libkrb5support0{a} libltdl7{a} liblua5.1-0{a} liblwres60{a} libnfnetlink0{a} libnl1{a} libntfs-3g75{a} libntfs10{a} libogg0{a} libonig2{a} libpam-ck-connector{a} libpangomm-1.4-1{a} libparted0debian1{a} libpciaccess0{a} libpolkit-agent-1-0{a} libpolkit-backend-1-0{a} libpolkit-gobject-1-0{a} libqdbm14{a} libsgutils2-2{a} libtalloc2{a} libtdb1{a} libvorbis0a{a} libvorbisfile3{a} libxcb-aux0{a} libxcb-event1{a} mtools{a} ntfs-3g{a} ntfsprogs{a} os-prober{a} php5-suhosin{a} policykit-1{a} policykit-1-gnome{a} python2.6{a} python2.6-minimal{a} tsconf{a} udisks{a} wwwconfig-common{a} The following packages will be upgraded: apache2 apache2-mpm-prefork apache2.2-common bind9 bind9-host bind9utils clamav clamav-base clamav-daemon clamav-freshclam clamav-milter cpp-4.3 db4.6-util dhcp3-common dnsutils dovecot-common dovecot-imapd dovecot-pop3d esound-clients gcc gcc-4.3 gcc-4.3-base gnome-keyring grub grub-common hal info iptables libapache-mod-security libapache2-mod-php5 libapache2-mod-rpaf libaprutil1 libauthen-pam-perl libberkeleydb-perl libbonoboui2-0 libbonoboui2-common libcrypt-ssleay-perl libcups2 libcurl3 libdevmapper1.02.1 libdigest-sha1-perl libdirectfb-extra libedit2 libesd0 libgail-common libgail18 libglade2-0 libgnome-keyring0 libgnome2-0 libgnome2-common libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeui-0 libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgomp1 libgtk2.0-0 libgtk2.0-bin libgtkmm-2.4-1c2a libhtml-parser-perl libio-pty-perl libkeyutils1 libkrb53 libnautilus-extension1 libnet-dns-perl libnet-ssleay-perl libnetaddr-ip-perl libnotify1 libpq5 librsvg2-2 librsvg2-common libsmbclient libsocket6-perl libstartup-notification0 libts-0.0-0 libwbclient0 libwnck22 lvm2 memcached mod-security-common mysql-admin mysql-gui-tools-common mysql-query-browser nmap notification-daemon openssh-client openssh-server php5 php5-cgi php5-cli php5-common php5-curl php5-gd php5-mcrypt php5-memcache php5-mysql php5-xcache phpmyadmin postgrey python python-minimal python2.5 python2.5-minimal quota radeontool sasl2-bin shared-mime-info update-inetd The following partially installed packages will be configured: linux-base linux-image-2.6-amd64 linux-image-2.6.26-2-amd64 linux-image-2.6.32-5-amd64 sysv-rc The following packages are RECOMMENDED but will NOT be installed: openssh-blacklist-extra xauth 111 packages upgraded, 80 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/96.6 MB of archives. After unpacking 100 MB will be used. Do you want to continue? [Y/n/?] y debconf: DbDriver «config»: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable Setting up sysv-rc (2.88dsf-13.1+squeeze1) ... debconf: DbDriver «config»: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable dpkg: error processing sysv-rc (--configure): subprocess installed post-installation script returned error exit status 1 configured to not write apport reports Errors were encountered while processing: sysv-rc E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover: Setting up sysv-rc (2.88dsf-13.1+squeeze1) ... debconf: DbDriver «config»: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable dpkg: error processing sysv-rc (--configure): subprocess installed post-installation script returned error exit status 1 Setting up linux-base (2.6.32-48squeeze6) ... debconf: DbDriver «config»: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable dpkg: error processing linux-base (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of linux-image-2.6.32-5-amd64: linux-image-2.6.32-5-amd64 depends on linux-base (>= 2.6.32-31); however: Package linux-base is not configured yet. dpkg: error processing linux-image-2.6.32-5-amd64 (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-image-2.6-amd64: linux-image-2.6-amd64 depends on linux-image-2.6.32-5-amd64; however: Package linux-image-2.6.32-5-amd64 is not configured yet. dpkg: error processing linux-image-2.6-amd64 (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: sysv-rc linux-base linux-image-2.6.32-5-amd64 linux-image-2.6-amd64

подскажите как решить проблему. Спасибо.


1. Осиль тег code
2. Читать написанное не пробовал? Он тебе на чистейшем английском сказал:

/var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Прибей процесс, оставшийся от прошлой ssh сессии (killall aptitude (man killall)) и запускай снова.

redgremlin ★★★★★ ()
Последнее исправление: redgremlin (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.