LINUX.ORG.RU

[debian][aptitude][upgrade] как правильно? с stable на sid


0

1

aptitude full-upgrade

Чтение списков пакетов...
Построение дерева зависимостей...
Чтение информации о состоянии...
Чтение информации о расширенных состояниях...
Инициализация состояний пакетов...
Чтение описаний задач...
Следующие НОВЫЕ пакеты будут установлены:
  console-setup-linux{ab} firmware-linux-free{a} gcc-4.6-base{a} 
  grub-pc-bin{a} grub2-common{a} libboost-iostreams1.46.1{a} 
  libcryptsetup1{a} libdb5.1{a} libfuse2{a} libgcrypt11{a} libgpg-error0{a} 
  libpipeline1{a} libssl1.0.0{a} libusb-1.0-0{a} 
  linux-image-2.6.39-2-amd64{a} multiarch-support{a} 
Следующие пакеты будут обновлены:
  acpi acpi-support-base acpid apt apt-utils aptitude base-files 
  bsdmainutils bsdutils busybox console-setup cpio cron cryptsetup debconf 
  debconf-i18n debianutils dmsetup dpkg e2fslibs e2fsprogs eject 
  gcc-4.4-base gnupg gpgv grep groff-base grub-common grub-pc hostname 
  initramfs-tools initscripts insserv installation-report iproute iptables 
  iputils-ping isc-dhcp-client isc-dhcp-common kbd keyboard-configuration 
  klibc-utils libacl1 libattr1 libblkid1 libboost-iostreams1.42.0 libc-bin 
  libc6 libcomerr2 libdb4.8 libdevmapper1.02.1 libept1 libfreetype6 libgcc1 
  libklibc liblocale-gettext-perl libncurses5 libncursesw5 libnewt0.52 
  libpam-modules libpam-runtime libpam0g libpcap0.8 libpci3 libreadline6 
  libselinux1 libsepol1 libsigc++-2.0-0c2a libslang2 libsqlite3-0 libss2 
  libssl0.9.8 libstdc++6 libtext-charwidth-perl libtext-iconv-perl libudev0 
  libusb-0.1-4 libuuid-perl libuuid1 libxapian22 linux-base 
  linux-image-2.6-amd64 locales login lsb-base man-db module-init-tools 
  mount ncurses-base ncurses-bin net-tools netcat-traditional passwd 
  pciutils perl-base procps readline-common rsyslog sed sensible-utils 
  sysv-rc sysvinit sysvinit-utils tar tasksel tasksel-data tzdata ucf udev 
  usbutils util-linux wget whiptail xkb-data 
115 пакетов обновлено, 16 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 41,3 MB/87,5 MB архивов. После распаковки 123 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  console-setup-linux: Конфликтует: console-terminus но установлен 4.30-2 
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     console-terminus       



Принять данное решение? [Y/n/q/?]
Зачем НОВЫЕ?
libusb-1.0-0{a} libusb-0.1-4
linux-image-2.6.39-2-amd64{a} linux-image-2.6-amd64
gcc-4.6-base{a} gcc-4.4-base
Привет слоты?


Я делал так:

apt-get install apt aptitude dpkg
apt-get dist-upgrade

neocrust ★★★★★ ()
Ответ на: комментарий от neocrust

Правда я переходил со стейбла на тестинг.

Всё заработало.

neocrust ★★★★★ ()
Ответ на: комментарий от tn1

Так а куда от них деваться-то. Ядро вон новое (из-за linux-image-2.6-amd64), да библиотеки некоторые — это разве много?

SoulThreads ()
Ответ на: комментарий от SoulThreads
$ aptitude why gcc-4.4-base
i   libstdc++6 Зависит gcc-4.4-base (= 4.4.5-8)
tn1 ()
Ответ на: комментарий от tn1

http://manual.aptosid.com/ru/sys-admin-apt-ru.htm#apt-upgrade

...

Для поиска и получения информации о пакетах вы по-прежнему можете использовать все, что вам нравится, но операции по установке, удалению и 'dist-upgrade' осуществляйте только с использованием 'apt-get'!

Пакетные менеджеры, типа adept, aptitude, synaptic и kpackage (при комплексном выборе пакетов), смешивают даже такие быстро изменяющиеся ссылки как в sid и ссылки внешних репозиториев,весьма сомнительного качества ( мы не используем и не рекомендуем таковые, но они вполне вероятно могут присутствовать на пользовательских системах), что почти наверняка приведет к аварийным сбоям системы в дальнейшем.

...

Bod ★★★★ ()
Ответ на: комментарий от Bod

Ясно. aptitude full-upgrade эдентичен(в выводе) apt-get dist-upgrade. А это
libusb-1.0-0{a} libusb-0.1-4
linux-image-2.6.39-2-amd64{a} linux-image-2.6-amd64
gcc-4.6-base{a} gcc-4.4-base
крутит мне яйца. Может можно обновить(без новых)?

tn1 ()
Ответ на: комментарий от tn1

В ответ на «Принять данное решение? [Y/n/q/?]» введите "-имяпакета" и посмотрите, что из этого получится.

AITap ★★★★★ ()
Ответ на: комментарий от tn1

Да я не пойму, в чём проблема? В твоей системе нет никаких конфликтов. После дистапгрейда не выносится половина системы, как это бывает. Остаются лишние пакеты? Так обновись, а затем почистишь лишнее. Я обновляюсь при помощи apt, а затем при помощи synaptic и deborphan вычищаю лишнее (мне так легче и нагляднее). Проблем за несколько лет по вине системы не было.

Bod ★★★★ ()
Ответ на: комментарий от AITap

aptitude full-upgrade
Принять данное решение? [Y/n/q/?] -gcc-4.4-base

Следующие пакеты имеют неудовлетворённые зависимости:
  console-setup-linux: Конфликтует: console-terminus но установлен 4.30-2 
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     console-terminus       



Принять данное решение? [Y/n/q/?]

tn1 ()
Ответ на: комментарий от Bod

> Так обновись, а затем почистишь лишнее.
думаешь apt-get autoremove их удалит?

tn1 ()
Ответ на: комментарий от Bod

Да. В руководстве aptosid категорически рекомендуется обновляться в dist-upgrade и только в текстовом режиме с убитыми иксами (init 3).

Т.е., очерёдность примерно такая:
# apt-get update
# init 3
# apt-get dist-upgrade

Bod ★★★★ ()

А почему вы не хотите из sid'а подтянуть новое ядро?

leave ★★★★★ ()
Ответ на: комментарий от tn1

> думаешь apt-get autoremove их удалит?

Не факт. Но я написал, какими двумя инструментами я пользуюсь. Если не любишь синаптик, можешь вначале apt-get autoremove, а затем gtkorphan вычистить остатки (но со вторым очень осторожно - смотри что удаляешь).

Но синаптик нормально отображает автоудаляемые пакеты и позволяет их вычистить.

Bod ★★★★ ()
Ответ на: комментарий от leave

Ты про

linux-image-2.6.39-2-amd64{a} linux-image-2.6-amd64

? Пусть будет одно.(зачем плодить сущности)

tn1 ()
Ответ на: комментарий от Bod

> убитыми иксами (init 3).
их нет.

Т.е., очерёдность примерно такая:

ок, вечерком попробую.

tn1 ()
Ответ на: комментарий от tn1

Дык это не два ядра. Второе - просто метапакет.

Bod ★★★★ ()
Ответ на: комментарий от tn1

>> убитыми иксами (init 3).

их нет.


Так ты что, решил сервер до сида обновить? Хм.

Bod ★★★★ ()
Ответ на: комментарий от Bod

> Не факт. Но я написал, какими двумя инструментами я пользуюсь. Если не любишь синаптик, можешь вначале apt-get autoremove, а затем gtkorphan вычистить остатки (но со вторым очень осторожно - смотри что удаляешь).
ок, порулю deborphan`ом

tn1 ()
Ответ на: комментарий от Bod

> Так ты что, решил сервер до сида обновить? Хм.
ССЗБизмом не страбаю. установил на ноутбук без X.(решил сразу на 1.10 пересесть)

tn1 ()
Ответ на: комментарий от tn1

Странно, как вы дебианом пользовались и не знали про них. Даже завидую немного )

leave ★★★★★ ()
Ответ на: комментарий от tn1

А если сделать aptitude -R safe-upgrade, тоже предложит поставить новые?

Как видите, отказ от установки gcc-4.4-base не привёл к конфликту зависимостей. От установки остальных пакетов отказывайтесь аналогично.

AITap ★★★★★ ()
Ответ на: комментарий от leave

> Странно, как вы дебианом пользовались и не знали про них. Даже завидую немного )
Вчера установил.

tn1 ()
Ответ на: комментарий от AITap

> От установки остальных пакетов отказывайтесь аналогично.
Все пакеты перечилсять? вдруг пропущу один/два

А если сделать aptitude -R safe-upgrade, тоже предложит поставить новые?

да.

tn1 ()
Ответ на: комментарий от tn1

Да, все. Первый символ - "-", а потом перечесление пакетов через пробел.

Список можно получить при помощи, например, perl -ne 'chomp; print $_ while s/{[^}]+}//g' (на входе - список пакетов с комментариями вида {ab} в несколько строчек, а на выходе - список пакетов в одну строчку).

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.