LINUX.ORG.RU

Как ставить wine в ubuntu 11.04


0

1

Доброго времени суток, пытаюсь поставить wine в ubuntu 11.04. Нагуглил инструкцию

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.3

После последней команды выдаёт мне следующее:

sudo apt-get install wine1.3
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine1.3 : Зависит: libmpg123-0 (>= 1.6.2) но он не может быть установлен
           Зависит: libopenal1 но он не может быть установлен
           Рекомендует: gnome-exe-thumbnailer но он не может быть установлен или
                                   kdebase-runtime но он не может быть установлен
           Рекомендует: ttf-droid но он не может быть установлен
           Рекомендует: ttf-umefont но он не может быть установлен
           Рекомендует: winbind но он не может быть установлен
E: Сломанные пакеты
Пытался поставить один из пакетов что он просит: libmpg123-0:
sudo apt-get install libmpg123-0
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакет libmpg123-0 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета libmpg123-0 не найден кандидат на установку
Я так понял что wine1.3 это новая, ещё не совсем стабильная версия, пытался поставить старую, стабильную версию 1.2:
sudo apt-get install wine
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine : Зависит: wine1.3 но он не будет установлен
Ничего не понимаю, чего он всё хочет? Как установить этот wine? Куда копать? :(

★★★★★

Чем wine не из PPA не устраивает?

AITap ★★★★★ ()

Так же, как и в предыдущих версиях.
Меня очень удивляет, на форумах про убунту почему-то постоянно дают советы по вводу команд в терминал...
Есть же — «Источники приложений», «Менеджер пакетов Synaptic», Менеджер обновлений и пр. штучки, там же мышкой всё.
Может тогда сразу на <неубунта>???

amorpher ★★★★★ ()

Попробуй поставить вайн из официального репозитория.

В /etc/apt/mirrorlist.d/ должен быть файл с путями репозитория, который ты добавил. (как-то типа ubuntu-wine и будет называться) удали его или закоментируй в нем все строки.

потом

apt-get update

apt-get install wine

Или просто попробуй apt-get -t main install wine

Убуну и дебьянов уже давно не видел так что могу говорить что-то не так.

ag_dm ()
Ответ на: комментарий от ag_dm

закоментировал репы с вайном, сделал update, попытался установить и он мне выдал ту же самую ошибку что и с самого начала, когда ещё ppa не добавлял:

sudo apt-get install wine
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакет wine недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета wine не найден кандидат на установку

Пичаль :(

xterro ★★★★★ ()
Ответ на: комментарий от xterro

я сча посмотрел. wine похоже в репозитории universe. надо как-то проверить подключен ли он у тебя.

вообще в /etc/apt/sources.list должна быть строчка типа

deb http://bla-bla-bla natty main multiverse restricted universe

где http: //bla-bla-bla - адрес репозитория, natty - версия убунты, main multiverse restricted universe - это типа разные репозитории для официальных пакетов, пакетов с закрытым кодом и тд.

так вот надо посмотреть все ли четыре этих репозитория указаны.

ag_dm ()
Ответ на: комментарий от ag_dm

О, дописал типы репозитариев и оно заработало, сразу вайн нашёлся с туевой хучей зависимостей и начал устанавливаться, спасибо :)

xterro ★★★★★ ()

Кстати wine 1.3 и в стандартных репах есть.

LongLiveUbuntu ★★★★★ ()

Открою вам маленький секрет, версий wine на самом деле больше, чем wine 1.0, 1.1, 1.2 и 1.3.

Помимо мажорной версии 1.3 есть еще минорные выпуски 1.3.26, 26 - версия минорного релиза. Минорный выпускается в процессе разработки и накопления достаточно существенных изменений в коде wine. На текущий момент 26 - самый свежий минорный релиз. После стабилизации кода и внесения достаточно крупных изменений в код по сравнению с мажорным релизом (1.3) может измениться его индекс и быть вупущен релиз 1.4, затем после внесения в него изменений будет выпущена версия 1.4.1. В случае внесения крупных изменений в код wine, затрагивающих большие подсистемы может измениться значение первого числа, вместо 1.4 к примеру выпущен 2.0 релиз. Так было при переходе с версии wine 0.98 на wine 1.0, затем wine 1.1.

Если у вас не получается поставить wine из ppa можете попробовать скачать deb пакеты wine и затем разбираться с требуемыми зависимостями и скачать их deb пакеты, затем выполнить deb -i * в директории со скачанными deb пакетами со всеми требуемыми зависимостями.

http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/pool/main/w/wine1.3/

kostik87 ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

зачем другой, если этот - официальный от девелоперов wine

xtraeft ★★☆☆ ()
Ответ на: комментарий от xterro

В настройках источников обновлений было две галки. Вообще, кажется они автоматически ставятся, если выбран регион Россия, или если перед установкой была поставлена галка установки несвободных дополнений. Но вы просто включили их напрямую, в конфиге apt.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Понял. Дружелюбие дистрибутива просто показательно. Я вот даже не включая мозг все эти репозитарии включаю, новичку же убунту я никогда не даю.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Дружелюбие дистрибутива просто показательно.
Пока не ясно, какой регион был выбран xterro при установке, и ставил ли он галку установки несвободных (в данном контексте - патентоопасных; WINE, к слову, тоже относится к таковым и потому не был доступен) дополнений в мастере установки, ирония не уместна. К слову, если бы xterro ставил WINE через Ubuntu Software Center, нужные репозиторий было бы предложено включить автоматически.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Регион установил - Екатеринбург, а вот про галки, то нас колько помню, я там все галки поснимал, чтобы напоминание об уведомлени не вылазило, но про доп. репы там не помню, надо глянуть )

xterro ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.