LINUX.ORG.RU

Arch. Нужна помщь с pacman.


1

1
[kei@kei-laptop ~]$ sudo pacman -Syu
:: Синхронизируются базы данных пакетов...
 core                                                                   37,4K   30,4K/s 00:00:01 [#########################################################] 100%
 extra                                                                 470,9K   19,7K/s 00:00:24 [#########################################################] 100%
community                                                             430,3K   14,5K/s 00:00:30 [#########################################################] 100%
:: Эти пакеты будут обновлены в первую очередь :
    pacman
:: Хотите прервать текущую операцию
:: и обновить эти пакеты сейчас? [Y/n] y

разрешение зависимостей...
проверка на взаимную несовместимость...
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: package-query: требует pacman<3.5

Такие дела. Если обновлять только пакман, происходит то же. Что делать, чтоб обновился пакман?


Сначала обнови yaourt (и package-query, как следствие) — тогда нормально поставится. Или pacman -Sd pacman, но тогда yaourt отвалится.

И да, пакман же все пишет русским языком, что тут может быть непонятно?

madgnu ★★★★★ ()
Ответ на: комментарий от guilder
[kei@kei-laptop ~]$ sudo pacman -Syy
Пароль: 
:: Синхронизируются базы данных пакетов...
 core                                                                   37,4K   22,1K/s 00:00:02 [#########################################################] 100%
 extra                                                                 470,9K   18,6K/s 00:00:25 [#########################################################] 100%
 community                                                             430,3K   17,6K/s 00:00:24 [#########################################################] 100%
[kei@kei-laptop ~]$ sudo pacman -Syu
:: Синхронизируются базы данных пакетов...
 core                                                                   37,4K    9,5K/s 00:00:04 [#########################################################] 100%
 extra                                                                 470,9K   19,8K/s 00:00:24 [#########################################################] 100%
 community                                                             430,3K   11,6K/s 00:00:37 [#########################################################] 100%
:: Эти пакеты будут обновлены в первую очередь :
    pacman
:: Хотите прервать текущую операцию
:: и обновить эти пакеты сейчас? [Y/n] y

разрешение зависимостей...
проверка на взаимную несовместимость...
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: package-query: требует pacman<3.5
[kei@kei-laptop ~]$
kei ()
Ответ на: комментарий от kei

Добавь в конец /etc/pacman.conf строчки:

[archlinuxfr]

Server = http://repo.archlinux.fr/$arch

И сделай pacman -Syyu.

Или сначала pacman -Sd pacman, потом обновляй yaourt и package-query ручками из AUR или репы выше.

anonymous ()
Ответ на: комментарий от kei

>:: Хотите прервать текущую операцию

:: и обновить эти пакеты сейчас? [Y/n] y

жмакай там n,и оно норм должно всё вставать,во всяком случае сам вчера так сделал

TheFallenAngel ★★ ()
Ответ на: комментарий от madgnu

Выполнил # pacman -Sd pacman, таки обновился и yaourt как и должно было быть отвалился. Не знал, что package-query относится к нему, спасибо.

kei ()
Ответ на: комментарий от madgnu

Значит мне пора вылезти из криокамеры. Два дня назад ещё не.

Dark_SavanT ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.