LINUX.ORG.RU

Manjaro 0.88 (Arch) проблема с обновлением.

 


0

1

Здравствуйте. У меня проблема с Manjaro. Вчера решил обновить, и согласился с обновлением pacman, потом затребовалось обновление полторы сотни пакетов, которое так и не завершается. В консоли пишет что нужно поменять 2 файла и не справляется с этим а в графической утилите, пишет что версия pacman установленная новей чем та что у неё... Разумеется можно всё снести и переставить, но ктоб знал как не хочется. Можно ли как то починить?

Вот что пишет в консоли:

[manjaro@fox909-home ~]$ sudo pacman -Syyu [sudo] password for manjaro: :: Синхронизируются базы данных пакетов... core 116,0 KiB 210K/s 00:01 [######################] 100% extra 1591,5 KiB 367K/s 00:04 [######################] 100% community 2,0 MiB 233K/s 00:09 [######################] 100% multilib 108,9 KiB 205K/s 00:01 [######################] 100% :: Запускается полное обновление системы... :: Заменить foomatic-filters на extra/cups-filters? [Y/n] y предупреждение: pamac: установленная версия (0.9.1-1) новее, чем в extra (0.9.0-2) :: Заменить sysvinit-tools на core/procps-ng? [Y/n] y разрешение зависимостей...\n проверка на взаимную несовместимость...\n ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости) :: pamac: требует pyalpm=0.6.2.1 [manjaro@fox909-home ~]$

А вот что пишет если из графического интерфейса обновляться:

pamac: local (0.9.1-1) is newer than extra (0.9.0-2)

Помогите по возможности. С уважением, Fox909.


Удали pamac. Обновись. Поставь pamac.

anonymous ()
Ответ на: комментарий от anonymous

Почему так вышло? Потому что разрабы pamac любят мужчин и привязались к конкретной версии библиотеки (pyalpm), которая внезапно (вот те на) обновилась.

baverman ★★★ ()
Ответ на: комментарий от ephecaff

Попробуй.

И что это изменит? Зависимость то от старой версии останется.

baverman ★★★ ()

Сделай даунгрейд пакмана, даунгрейд этот библиотеки, и попробуй обновиться. И просто подожди, пока этот невероятно ненужный фронтенд обновится вслед за библиотекой.

Dantix ★★ ()
Ответ на: комментарий от Dantix

Спасибо. Я себе что-то так и представляю :) А как сделать то? В пакетнике отметить старую версию? А текущую удалить? Или я не совсем верно себе «понижение версии» представляю?

Fox909 ()
Ответ на: комментарий от Fox909

Что значит удали? А без него разве обновиться?!

Pamac - это то же самое говно, что и apper. Сноси его к чертям и обновляй систему из консоли.

sergio1204 ★★ ()
Ответ на: комментарий от Dantix

УРА! Получилось! Сделал насколько понял (там всё по буржуйски). Нашёл файлик с более низким номером, в том месте куда буржуи послали :) И в ту строчку вставил, что на сайте. И вот оно - свершилось! Заобнавлялось всё, завертелось и не ругается :)

Спасибо ОГРОМНОЕ!

С уважением, Fox909.

Fox909 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.