LINUX.ORG.RU

При обновлении системы в Pacman все пакеты старше чем установленые

 ,


0

1

Привет всем! Проблема на днях случилась, при обновлении системы выдает список пакетов судя по которым у меня установлены новее чем те которые предлагают, как это исправить, чтобы были актуальные версии пакетов?

[sergey@Manjaro ~]$ sudo pacman -Syu
[sudo] password for sergey: 
:: Синхронизируются базы данных пакетов...
 core не устарел
 extra                   1774,6 KiB   439K/s 00:04 [----------------------] 100%
 community                  2,3 MiB   377K/s 00:06 [----------------------] 100%
 archlinuxfr не устарел
:: Запускается полное обновление системы...
предупреждение: faenza-icon-theme: установленная версия (1.3.1-4) новее, чем в community (1.3.1-3)
предупреждение: garcon: установленная версия (0.3.0-1) новее, чем в extra (0.2.1-1)
предупреждение: gparted: установленная версия (0.19.1-1.1) новее, чем в extra (0.19.1-1)
предупреждение: libxfce4ui: установленная версия (4.11.1-1) новее, чем в extra (4.10.0-2)
предупреждение: libxfce4util: установленная версия (4.11.0-1) новее, чем в extra (4.10.1-2)
предупреждение: os-prober: установленная версия (1.63-1) новее, чем в community (1.58-1)
предупреждение: pyalpm: установленная версия (0.6.2.2-2) новее, чем в extra (0.6.2-2)
предупреждение: thunar: установленная версия (1.6.3-2) новее, чем в extra (1.6.3-1)
предупреждение: xfce4-appfinder: установленная версия (4.11.0-2) новее, чем в extra (4.10.1-1)
предупреждение: xfce4-panel: установленная версия (4.11.1-1) новее, чем в extra (4.10.1-1)
предупреждение: xfce4-power-manager: установленная версия (1.3.2-2) новее, чем в extra (1.2.0.212.g75107db-1)
предупреждение: xfce4-session: установленная версия (4.11.0-1) новее, чем в extra (4.10.1-3)
предупреждение: xfce4-settings: установленная версия (4.11.3-1) новее, чем в extra (4.10.1-1)
предупреждение: xfdesktop: установленная версия (4.11.7-1) новее, чем в extra (4.10.2-2)
предупреждение: xfwm4: установленная версия (4.11.2-1) новее, чем в extra (4.10.1-1)
разрешение зависимостей...\n
проверка на взаимную несовместимость...\n
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: catalyst-utils: требует xorg-server<1.16.0
[sergey@Manjaro ~]$ 

привет lorcode

anonymous ()
Ответ на: комментарий от NightFobos

Когда открыта форма добавления сообщения в тему прочитай внимательно весь текст, что есть в этой форме.

kostik87 ★★★★★ ()

pacman -Syuua разрешит даунгрейд

Dantix ★★ ()
Ответ на: комментарий от NightFobos

поправил, на будущее лучше все-таки сначала читать и пользоваться кнопкой предпросмотра )

leave ★★★★★ ()
Последнее исправление: leave (всего исправлений: 1)
Ответ на: комментарий от kostik87
[sergey@Manjaro ~]$ sudo pacman -Syu
[sudo] password for sergey: 
:: Синхронизируются базы данных пакетов...
 core не устарел
 extra                   1774,6 KiB   439K/s 00:04 [----------------------] 100%
 community                  2,3 MiB   377K/s 00:06 [----------------------] 100%
 archlinuxfr не устарел
:: Запускается полное обновление системы...
предупреждение: faenza-icon-theme: установленная версия (1.3.1-4) новее, чем в community (1.3.1-3)
предупреждение: garcon: установленная версия (0.3.0-1) новее, чем в extra (0.2.1-1)
предупреждение: gparted: установленная версия (0.19.1-1.1) новее, чем в extra (0.19.1-1)
предупреждение: libxfce4ui: установленная версия (4.11.1-1) новее, чем в extra (4.10.0-2)
предупреждение: libxfce4util: установленная версия (4.11.0-1) новее, чем в extra (4.10.1-2)
предупреждение: os-prober: установленная версия (1.63-1) новее, чем в community (1.58-1)
предупреждение: pyalpm: установленная версия (0.6.2.2-2) новее, чем в extra (0.6.2-2)
предупреждение: thunar: установленная версия (1.6.3-2) новее, чем в extra (1.6.3-1)
предупреждение: xfce4-appfinder: установленная версия (4.11.0-2) новее, чем в extra (4.10.1-1)
предупреждение: xfce4-panel: установленная версия (4.11.1-1) новее, чем в extra (4.10.1-1)
предупреждение: xfce4-power-manager: установленная версия (1.3.2-2) новее, чем в extra (1.2.0.212.g75107db-1)
предупреждение: xfce4-session: установленная версия (4.11.0-1) новее, чем в extra (4.10.1-3)
предупреждение: xfce4-settings: установленная версия (4.11.3-1) новее, чем в extra (4.10.1-1)
предупреждение: xfdesktop: установленная версия (4.11.7-1) новее, чем в extra (4.10.2-2)
предупреждение: xfwm4: установленная версия (4.11.2-1) новее, чем в extra (4.10.1-1)
разрешение зависимостей...\n
проверка на взаимную несовместимость...\n
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: catalyst-utils: требует xorg-server<1.16.0
[sergey@Manjaro ~]$]
NightFobos ()
Ответ на: комментарий от Dantix

Пишет вот что

[sergey@Manjaro ~]$ sudo pacman -Syuua
[sudo] password for sergey: 
pacman: неверный ключ — «a»
[sergey@Manjaro ~]$ 

NightFobos ()
Ответ на: комментарий от NightFobos

Ну и зачем дублировать вводные данные? Просто прежде чем выполнить какое-либо действие прочитайте информацию на экране и подумайте всё ли вы делаете правильно.

kostik87 ★★★★★ ()
Ответ на: комментарий от NightFobos

М.б. зеркало умерло? У меня один раз такое было, помогла смена зеркало на обновляемое.

MLP_Fan ★★ ()
Ответ на: комментарий от NightFobos

Серверов в mirrorliste много, может быть некоторые еще со старыми пакетами?

NightFobos ()

1. Ознакомьтесь с тем, как нужно оформлять сообщения www.linux.org.ru/wiki/en/Lorcode

2. Ставили Arch Linux или Chakra/Manjaroo/ArchBang?

3. Опубликуйте сюда http://pastbein.com содержимое /etc/pacman.conf и /etc/pacman.d/mirrorlist.

4. Когда последний раз обновлялись?

5. Зачем вам нужен Arch Linux?

emerge ()
Ответ на: комментарий от NightFobos

В /etc/pacman.d/mirrorlist должен быть 1 сервер и 1-2 зеркала. Сервер нужно ставить на первое место.

некоторые еще со старыми пакетами?

Вы понимаете вообще принцип работы mirrorlist?

Используется только 1 сервер, который находится на 1 месте.

emerge ()
Ответ на: комментарий от emerge

Пока учусь, у меня GNU/linux Manjaro. Нравится своей простотой и скоростью работы, а так же интересно что-нибудь чинить в нем)).Pacman и Pamac ломались ХЗ сколько раз. Чинил. А сейчас вот новая поломка. Обьясните пожалуйста, не совсем тупой пойму. И да я не школьник(шутка про типичного арчевода)

NightFobos ()

Проблема на днях случилась, при обновлении системы выдает список пакетов судя по которым у меня установлены новее чем те которые предлагают, как это исправить, чтобы были актуальные версии пакетов?

Положи машину времени на место.

Как вариант через

pacman -U /var/cache/pacman/pkg/*название пакета*
откатить проблемные пакеты. Грепаешь в данном каталоге нужный пакет, выбираешь версию и вставляешь полное название файла (с расширениями) в команду.

najlus ★★★★★ ()
Ответ на: комментарий от NightFobos

Эх, Вы!
Я негативно отношусь к сборкам на Arch'е (даже ArchBang), не говоря уже о Manjaroo.

/etc/pacman.conf сильно изменён у этих дистрибутивов. Версии пакетов отличаются от Arch Linux. Получаете вы их не с официальных серверов.

ArchBang - cамый адекватный дистрибутив на Arch Linux.

Возможно, что вы поставили /etc/pacman.conf от оригинального Arch Linux. Сложно сказать из-за чего конкретно это случилось.

1. Проверьте pacman.conf.
2. Выполните pacman -Syuua (с правами «root»).
3. Прочитайте Arch Wiki, чтобы понять то, как устроен дистрибутив.

emerge ()
Ответ на: комментарий от NightFobos

Кстати, удалите закомментированные зеркала (зеркала, перед которыми есть «#»).
Оставьте только 1 сервер и 1 зеркало.

emerge ()
Ответ на: комментарий от NightFobos

Тот сервер, который ближе к Вам территориально.

P.S. Оставьте данные, по которым я смогу в Вами связаться и помочь: мессенджеры, джаббер, МайкрософтоСкайп.

emerge ()
Ответ на: комментарий от emerge

Действительно, ну точно, в этом проблема и была!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.