LINUX.ORG.RU

Что-то сломалось в manjaro после обновления или как я попал в страну чудес.

 , ,


0

1

Начну издалека...

Пролог

Обновил систему (на борту manjaro plasma) и после перезагрузки обнаружил, что обвалились ядра. Актуальное на тот момент 510,а вместе с ним 58 и 414 перешли в режим «кернел не обнаружен, пожалуйста,переустанови себе там что-нибудь....» - так отвечал мне grub. Но вот резервный кернел 419, один из четырех, чудом запустился. Тем не менее, в системе перестала работать добрая половина пакетов и утилит (в том числе и утилита по работе с ядрами - ни удалить, ни установить, а так же навернулся pacman и еще куча всего).

Глава 1.

С помощью chroot через live-usb пытался скинуть и заново накатить ядра, но вместо этого как-то случайно починил саму утилиту в штатном дистрибутиве. Ладно... Снова запустился через выжившее 419-ое и зашел в графическую оболочку «ядра». Действительно, починилось. Там акуратно поудалял и переустановил, все, что поддалось, оставил пару резервных lts 414 и 419, а для работы еще накатил свежее 513 и запустился с него.

Глава 2.

Сижу, чешу репу...

510 кернел (актуальный на момент аварии) значится установленным и не удаляетя вообще. В grub не отображается.

58 кернел через систему вообще не отслеживается, но отображается в grub (не запускается)

...прикладываю вывод с mhwd-kernel -li

Currently running: 5.13.1-3-MANJARO (linux513)
The following kernels are installed in your system:
ошибка: не удалось открыть файл /var/lib/pacman/local/lib32-libva-mesa-driver-21.1.4-1/desc: Нет такого файла или каталога
* linux414
* linux419
* linux510
* linux512
* linux513
* linux54
ошибка: не удалось открыть файл /var/lib/pacman/local/lib32-libva-mesa-driver-21.1.4-1/desc: Нет такого файла или каталога

Далее ввожу sudo pacman -R linux510

проверка зависимостей...
ошибка: не удалось открыть файл /var/lib/pacman/local/lib32-libva-mesa-driver-21.1.4-1/desc: Нет такого файла или каталога
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: removing linux510 breaks dependency 'linux510' required by linux-latest

Окей, отложил на потом, решил, что какой-то мусор остался... В консоли ввожу команду pacman -Syyuu и чудо! - заработало!!! Все неработающие ранее пакеты вновь работают.

Глава 3.

Через несколько дней значок pacman в уведомлениях сообщает о каких-то потребностях. Захожу в графическую версию - там куча обновлений по пакетам. Пытаюсь запустить, а ниче не работает. «Неверный или поврежденный пакет», говорит.

Полез в терминал: sudo pacman -Syyuu

:: Обновление баз данных пакетов...
core 168,7 KiB 329 KiB/s >00:01 [#######################################################################################] 100%
extra 1905,5 KiB 4,85 MiB/s >00:00 [#######################################################################################] 100%
community 6,6 MiB 8,52 MiB/s >00:01 [#######################################################################################] 100%
multilib 177,6 KiB 1889 KiB/s >00:00 [#######################################################################################] 100%
:: Запускается полное обновление системы...
ошибка: не удалось открыть файл /var/lib/pacman/local/lib32-libva-mesa-driver-21.1.4-1/desc: Нет такого файла или каталога
разрешение зависимостей...
проверка конфликтов...
предупреждение: не удалось загрузить все метаданные для пакета lib32-libva-mesa-driver-21.1.4-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет)

Эпилог.

Репа все еще чешется. требуется пояснительная бригада что бы разобраться вот с этим чудом

/var/lib/pacman/local/lib32-libva-mesa-driver-21.1.4-1/desc

и его починкой