LINUX.ORG.RU

Проблема с wi-fi адаптером


0

1

Решил настроить карту вай-фая на ноутбуке от небезызвестной тайваньской MSI. Карточка там стоит Ralink, а если точнее rt2860. В репозитариях были только драйвера для других карт этой компании, и я погуглив нашел исходники драйверов. Как там писалось в мануале включил WPA и последовал другим советам. Все прекрасно ставится, после modprobe никаких проблем. Но обещаный интерфейс не появляется. Не знаю, что сделал не так, поэтому сейчас это пишу. Есть какие нибудь идеи, как заставить это работать?


Телепаты просто не обращают внимание на то что ниже.
Забыл так же сказать, что у меня новенький Дебиан.
В /etc/modules положил, чтобы не мучиться.

Проверяю, на месте ли модуль, но в душе не смекаю что это на второй стоке.
# lsmod|grep rt2
rt2860sta 402694 0
crc_ccitt 1039 1 rt2860sta


Вывод modinfo, вроде бы тоже все в порядке:
# modinfo rt2860sta
filename: /lib/modules/2.6.32-5-686/kernel/drivers/staging/rt2860/rt2860sta.ko
version: 2.1.0.0
alias: rt3090sta
license: GPL
description: RT2860/RT3090 Wireless Lan Linux Driver
author: Jett Chen <jett_chen@ralinktech.com>
firmware: rt3090.bin
firmware: rt2860.bin
srcversion: F232F5C4809640F6463A6F1
alias: pci:v00001814d00003092sv*sd*bc*sc*i*
alias: pci:v00001814d00003091sv*sd*bc*sc*i*
alias: pci:v00001814d00003090sv*sd*bc*sc*i*
alias: pci:v00001432d00007768sv*sd*bc*sc*i*
alias: pci:v00001432d00007748sv*sd*bc*sc*i*
alias: pci:v00001432d00007738sv*sd*bc*sc*i*
alias: pci:v00001432d00007727sv*sd*bc*sc*i*
alias: pci:v00001432d00007758sv*sd*bc*sc*i*
alias: pci:v00001432d00007728sv*sd*bc*sc*i*
alias: pci:v00001432d00007708sv*sd*bc*sc*i*
alias: pci:v00001A3Bd00001059sv*sd*bc*sc*i*
alias: pci:v00001814d00000781sv*sd*bc*sc*i*
alias: pci:v00001814d00000701sv*sd*bc*sc*i*
alias: pci:v00001814d00000681sv*sd*bc*sc*i*
alias: pci:v00001814d00000601sv*sd*bc*sc*i*
depends: crc-ccitt
staging: Y
vermagic: 2.6.32-5-686 SMP mod_unload modversions 686
parm: mac:rt28xx: wireless mac addr (charp)
parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)

Вывод ifconfig не выкладываю, просто стоит на слово поверить, что там нет интерфейсов ra0, как обещали, или wlan0, как обычно.

Ах да, in b4 в Гугле меня забанили, не ругайте зря, господа и дамы.

Ответ на: комментарий от madgnu

>ifconfig wlan0 up
Сразу все и заработало, ага. Говорю же, что нет их.

wlan0: ERROR while getting interface flags: Нет такого устройства
ra0: ERROR while getting interface flags: Нет такого устройства

maitre ()

>Вывод ifconfig не выкладываю, просто стоит на слово поверить

А вот фиг тебе, не поверю. Показывай пруф!

после modprobe никаких проблем.


Всмысле все начинает работать? Тогда засунь модуль в автозагрузку.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

>А вот фиг тебе, не поверю. Показывай пруф!

Хорошо, мой бдительный друг.
# ifconfig -a
eth0 Link encap:Ethernet HWaddr ~~~~~~~~~~~~~~~~~
inet addr:~~~~~~~~~ Bcast:10.208.127.255 Mask:255.255.252.0
inet6 addr: ~~~~~~~~~~~~~~~~~~~~~ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17966 errors:0 dropped:0 overruns:0 frame:0
TX packets:6113 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4510802 (4.3 MiB) TX bytes:1170158 (1.1 MiB)
Interrupt:26 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Всмысле все начинает работать? Тогда засунь модуль в автозагрузку.


Хотя цитировать себя и дурной тон, но вы вынуждаете: >В /etc/modules положил, чтобы не мучиться.

maitre ()
Ответ на: комментарий от maitre

>Хотя цитировать себя и дурной тон, но вы вынуждаете: >В /etc/modules положил, чтобы не мучиться.

Просто не помню, как оно там в дебиане.

Я так понял, что когда подгружаешь его руками - все работает? (раз ты не опроверг это мое высказывание)

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

>Я так понял, что когда подгружаешь его руками - все работает? (раз ты не опроверг это мое высказывание)

Модуль - да, подцепляется и пишет, что рабоет как нужно. Но интерфейса нет. Я уже писал в предыдущих постах, что происходит, когда я пытаюсь поднять его.

maitre ()
Ответ на: комментарий от maitre

Что-то я тупить начинаю, видимо, спать пора. Да и не оформлено у тебя как надо в первом посте, к тому же.

Тогда не знаю, все, что в голову пришло на ночь глядя - озвучил =)

Zhbert ★★★★★ ()

Меня смущают две вещи. Во-первых:

maitre

description: RT2860/RT3090 Wireless Lan Linux Driver author: Jett Chen <jett_chen@ralinktech.com>
firmware: rt3090.bin
firmware: rt2860.bin

И во-вторых:

maitre

wlan0: ERROR while getting interface flags: Нет такого устройства
ra0: ERROR while getting interface flags: Нет такого устройства

rt2860 и rt3090 - это как бэ разные вещи. В rt3090, например, ещё и BT встроен. А ещё rt2860 - это b/g only, а rt3xxx - это n. То есть у них драйвера разные (проверено на rt3060). Кстати, при использовании последних версий драйвера с сайта RaLink не нужно устанавливать firmware.
В общем, думаю, нужно вычистить всё, что касается этого девайса, из системы; переустановить драйвер с сайта RaLink (соответствующий чипу; firmware не требуется); сделать modprobe (в соответствие названию модуля); в системе должно появиться устройство ra0 (и никакое другое).
Как-то так.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

А ещё перед сборкой драйвера необходимо подправить конфиг (к сожалению, под рукой сейчас нет исходников, поэтому подробнее сказать путь к нему не могу) в зависимости от того, как необходимо управлять устройством: NM / wpa_supplicant / etc.

carasin ★★★★★ ()
Ответ на: комментарий от vitruss

Ну можно и не грепать, все равно можно посмотреть что видет система из сетевых контроллеров.

dgeliko ★★ ()

Решение найдено

Всем спасибо за дельные советы, но проблема была в отсутсвии драйверов к устойству /dev/brain. Я ориентировался на прилагаемые к ноуту диски с ПО, а не на само оборудование. Разобрал ноут, прочитал, что карточка от atheros.

maitre ()
Ответ на: Решение найдено от maitre

Прикольно. Ну тогда ath9k либо ath5k, в зависимости от серии чипсета. Если функционал недостаточный - пиши и я скажу как поставить проприетарный драйвер.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.