LINUX.ORG.RU

TP-link TL-WN727N v4 - не заводится сеть

 


1

1

Имеется адаптер TP-link TL-WN727N который всё никак не удаётся заставить работать.

Вроде делаю всё по мануалу :

Качаю https://d86o2zu8ugzlg.cloudfront.net/mediatek-craft/drivers/mt7610u_wifi_sta_...

Ставлю пакеты

apt-get install build-essential fakeroot dpkg-dev

apt-get install build-essential fakeroot dpkg-dev

правлю в /os/linux/config.mk строки

# Support Wpa_Supplicant

HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Manger

HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

c «n» на «y»

собираю

make

make install

гружу модуль

insmod /lib/modules/3.7.10-antix.5-486-smp/kernel/drivers/net/wireless/mt7650u_sta.ko

а в результате - хрен :(

ifconfig wlan up
wlan: ERROR while getting interface flags: No such device
ifconfig ra0 up
ra0: ERROR while getting interface flags: No such device

iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
eth1      no wireless extensions.
eth2      no wireless extensions.

lsusb
Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp.

modinfo mt7650u_sta
filename:       /lib/modules/3.7.10-antix.5-486-smp/kernel/drivers/net/wireless/mt7650u_sta.ko
version:        3.0.0.2
description:    RT2870 Wireless Lan Linux Driver
author:         Paul Lin <paul_lin@ralinktech.com>
license:        GPL
srcversion:     D1E588C2E22F986426962F9
alias:          usb:v0E8Dp7650d*dc*dsc*dp*icFFisc02ipFFin*
alias:          usb:v0E8Dp7630d*dc*dsc*dp*icFFisc02ipFFin*
alias:          usb:v0E8Dp7610d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp7610d*dc*dsc*dp*ic*isc*ip*in*
depends:
vermagic:       3.7.10-antix.5-486-smp SMP mod_unload modversions 486
parm:           mac:rt28xx: wireless mac addr (charp)

dmesg|grep 7601
[    7.063203] usb 1-1: New USB device found, idVendor=148f, idProduct=7601

Ответ на: комментарий от Ygor

А дистрибутив то какой может в репах есть?

Antix 13.2 (не самый новый, я в курсе, но переезжать влом).

Драйвера сходу скомпилировались и свисток заработал (в config.mk «y"уже были проставлены, так что править ничего не пришлось). На медленном огне в аду надо прожарить того, кто с той страницы выпилил ссылку на исходники драйвера (все мануалы на неё ссылались). Если бы она мне сразу попалась, я бы не полез искать дальше и не попал бы на 7610 *facepalm*

Blacksmith ()

Раньше я пользовался драйвером с сайта Медиатека. Но теперь его удалили, ссылаясь на то, что в ядре Linux 4.2 появился драйвер для этого устройства (не тот самый). А для других чипов Wi-Fi драйверы по-прежнему можно скачать.

Теперь я пользуюсь драйвером с сайта TP-LINK: http://www.tp-linkru.com/download/TL-WN727N.html#Driver Там то же самое, только почему-то растащено по четырём директориям. Поэтому дописать «HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y» нужно не один, а четыре раза (если не пять). Всё работает, пользуюсь. Странно только что в предыдущем используемом мной драйвере был один ko-файл, а теперь - четыре. Ах да, там ещё и make install поломан, пришлось копировать *.ko в нужную директорию, а затем выполнять «depmod -a».

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.