LINUX.ORG.RU

[CentOS] проблемы с обновлением


0

0

Всем добрый день. Достался мне серв на обслугу с сабжем, версия 5.? (хз какая, но какая-то пятая) была. Т.к. раньше RPM-based дистры не щупал практически, а CentOS вообще в глаза увидел первый раз, то решил поглядеть в сети команды по обновлению сервера, т.к. его никто не трогал год и все могло хорошо устареть. Наткнулся на мануал по апдейту:

yum clean all 
yum update glibc\* 
yum update yum\* rpm\* python\* 
yum clean all 
yum update 
Сделал все как указано, на последней команде выдает такое:
--> Running transaction check
---> Package fipscheck.i386 0:1.2.0-1.el5 set to be updated
---> Package libpurple.i386 0:2.6.6-2.el5_4 set to be updated
---> Package xorg-x11-drv-qxl.i386 0:0.0.12-1.2.el5 set to be updated
--> Processing Conflict: autofs conflicts cyrus-sasl-lib < 2.1.22-5.el5_4.3
--> Finished Dependency Resolution
1:autofs-5.0.1-0.rc2.143.el5.i386 from base has depsolving problems
  --> autofs conflicts with cyrus-sasl-lib
Error: autofs conflicts with cyrus-sasl-lib
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

package-cleanup в системе не вижу. Подскажите кто сталкивался, чего делать то? с yum не работал никогда.
На сервере крутится ораклуша с иксами и самописное (не мной) приложение для оракла, к которому исподников и установочного пакета не имею.

[root@server ~]# cat /etc/redhat-release 
CentOS release 5.5 (Final)
Выдает такое

Ответ на: комментарий от Deleted

А то что этот сервант лупится в инет напрямую и там дырок наверняка черти сколько в софте обнаружено это тоже во внимание не принимать?

dgeliko ★★ ()

>package-cleanup в системе не вижу

Так очевидно же,

The program package-cleanup is found in the yum-utils package.


Поставь@запусти.

nnz ★★★★ ()
Ответ на: комментарий от no-dashi

autofs используешь? Если нет - rpm -e autofs, апдейт, yum install autofs

Сделал как ты сказал, теперь после скачивания обновлений выползает такое:

Transaction Check Error:
  ................куча однотипных сообщений подобных ниже..........
  file /usr/share/locale/vi/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
  file /usr/share/locale/zh_CN/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
  file /usr/share/locale/zh_TW/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386

Error Summary
-------------
Куда теперь копать?

dgeliko ★★ ()
Ответ на: комментарий от no-dashi

>yum update sendmail httpd php openssl openssh kernel<enter>, не получается сделать полное обновление роботом - приложи руки.
Хотелось бы полное и роботом =)

dgeliko ★★ ()
Ответ на: комментарий от dgeliko

да нет, не троллить

мифические дыры в сервисах если хочется закрыть, то желательно обновлять пакеты по очереди, а конфликтные (что впринципе не очень хорошо), форсить

но это довольно рискованное занятие, учиться юзать неизвестный тебе менеджер пакетов на боевом сервере

Deleted ()
Ответ на: комментарий от Deleted

я думаю что в RHEL-based дистрах все до меня починено и изучено, в данном случае надо только понять чего хочет yum и почему он не заменяет старые пакеты, а видит конфликты с новыми версиями.

dgeliko ★★ ()
Ответ на: комментарий от no-dashi

Подозреваю, что в сторону yum upgrade вместо yum update? :-)

пробывал =)
Вот что выдает на апгрейд после списка обновляемых пакетов:

Install       4 Package(s)
Upgrade     122 Package(s)

Total size: 144 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
после этого опять кучу подобных сообщений:
file /usr/share/locale/ur/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
  file /usr/share/locale/vi/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
  file /usr/share/locale/zh_CN/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
  file /usr/share/locale/zh_TW/LC_MESSAGES/system-config-securitylevel.mo from install of system-config-securitylevel-1.6.29.1-5.el5.i386 conflicts with file from package system-config-securitylevel-tui-1.6.29.1-2.1.el5.i386
Пробывал сделать
yum-complete-transaction 
Выдает кучу собщений такого типа:
firstboot-1.4.27.8-1.el5.centos.i386 from base has depsolving problems
  --> Missing Dependency: system-config-display is needed by package firstboot-1.4.27.8-1.el5.centos.i386 (base)
firstboot-1.4.27.8-1.el5.centos.i386 from base has depsolving problems
  --> Missing Dependency: system-config-soundcard is needed by package firstboot-1.4.27.8-1.el5.centos.i386 (base)
system-config-services-0.9.4-5.el5.noarch from base has depsolving problems
  --> Missing Dependency: usermode-gtk is needed by package system-config-services-0.9.4-5.el5.noarch (base)
И в конце:
Total size: 145 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
authconfig is needed by authconfig-gtk-5.3.21-6.el5.i386
usermode-gtk is needed by authconfig-gtk-5.3.21-6.el5.i386
usermode is needed by system-config-date-1.8.12-4.el5.centos.noarch
pm-utils is needed by hal-0.5.8.1-59.el5.i386
usermode is needed by system-config-securitylevel-1.6.29.1-5.el5.i386
control-center is needed by gnome-session-2.16.0-7.el5.centos.i386
gnome-volume-manager is needed by gnome-session-2.16.0-7.el5.centos.i386
system-config-display is needed by firstboot-1.4.27.8-1.el5.centos.i386
system-config-keyboard is needed by firstboot-1.4.27.8-1.el5.centos.i386
system-config-soundcard is needed by firstboot-1.4.27.8-1.el5.centos.i386
system-config-users is needed by firstboot-1.4.27.8-1.el5.centos.i386
usermode is needed by system-config-services-0.9.4-5.el5.noarch
usermode-gtk is needed by system-config-services-0.9.4-5.el5.noarch
authconfig is needed by firstboot-tui-1.4.27.8-1.el5.centos.i386
usermode is needed by firstboot-tui-1.4.27.8-1.el5.centos.i386
usermode is needed by system-config-language-1.1.18-3.el5.noarch
usermode is needed by system-config-network-tui-1.3.99.18-1.el5.noarch
usermode is needed by pirut-1.3.28-17.el5.centos.noarch
usermode is needed by system-config-lvm-1.1.5-4.el5.noarch
portmap is needed by nfs-utils-1.0.9-44.el5.i386
usermode is needed by system-config-samba-1.2.41-5.el5.noarch
Not removing old transaction files

dgeliko ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.