LINUX.ORG.RU

librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed) !!!


0

0

Здравствуйте!

Выскочила ошибка, с которой не знаю как бороться. А без исправления не могу обновляться!
librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (updates)
librpm.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (updates)

Как обойти проблему? Подскажите, пожалуйста...

Вот вывод yum:

--> Finished Dependency Resolution
abrt-1.0.3-1.fc12.i686 from installed has depsolving problems
--> Missing Dependency: librpm.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed)
abrt-1.0.3-1.fc12.i686 from installed has depsolving problems
--> Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed)
Error: Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed)
Error: Missing Dependency: librpm.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed) !!!

Добавлю: использую Федору 12.

kotfantazer ()
Ответ на: librpmio.so.0 is needed by package abrt-1.0.3-1.fc12.i686 (installed) !!! от kotfantazer

Странно это. librpmio.so.0 librpm.so.0 входят в пакет rpm-libs. То есть впечатление таково, что этот пакет не установлен. Но дело в том, что он требуется для rpm и yum (следовательно, обязан быть в нормальной Федоре), так что возможно повреждена база RPM. Так что сначала посмотри вывод rpm -q rpm-libs, потом либо sudo yum install rpm-libs, либо sudo rpm --rebuilddb

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Вы правы. rpm-libs стоит и проблемы, судя по всему, с базой.

Я выполнил sudo rpm --rebuilddb
После чего при обновлении получил:

PyKDE4 >= 4.3.95 is needed by package kdebase-workspace-python-applet-4.3.95-1.fc13.i686 (rawhide)

Вот вывод юма:

--> Finished Dependency Resolution
kdebase-workspace-python-applet-4.3.95-1.fc13.i686 from rawhide has depsolving problems
--> Missing Dependency: PyKDE4 >= 4.3.95 is needed by package kdebase-workspace-python-applet-4.3.95-1.fc13.i686 (rawhide)
Error: Missing Dependency: PyKDE4 >= 4.3.95 is needed by package kdebase-workspace-python-applet-4.3.95-1.fc13.i686 (rawhide)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

kotfantazer ()
Ответ на: комментарий от kotfantazer

> Вы правы

Давай на «ты», ОК? :)

kdebase-workspace-python-applet-4.3.95-1.fc13.i686 from rawhide


kdebase-workspace-python-applet был установлен из rawhide, который сейчас у тебя отключен. Вариантов два: либо сказать
sudo yum --enablerepo=rawhide update
, либо сказать
sudo yum downgrade kdebase-workspace-python-applet

Первый вариант — обновление всей системы до rawhide, второй — откат kdebase-workspace-python-applet до текущей версии в стабильной ветке. На случай, если ты не в курсе: fedora rawhide — это ветвь для разработчиков fedora, в которой собираются пакеты следующей версии дистрибутива. Из этого следует, что пакеты в rawhide свежее, но существуют шансы получить кучу багов. То есть в отсутствие веских причин лучше до rawhide не обновляться, посему остается downgrade. Если все-таки kdebase-workspace-python-applet из rawhide принципиален, можно попытаться обновить до rawhide только то, что нужно ему:
sudo yum --enablerepo=rawhide update PyKDE4

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Да уж... Бажную систему получать не хочу! Федора и так не особо стабильная))

Выбрал второй вариант, получил:

yum downgrade kdebase-workspace-python-applet
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
Only Upgrade available on package: kdebase-workspace-python-applet-4.3.2-1.fc12.i686
Nothing to do

То есть остается только апгрейд?

Как бы узнать, кому понадобился этот пакет? :)) Может быть какой проге, которую сдуру руками ставил... Ты не знаешь?

kotfantazer ()
Ответ на: комментарий от kotfantazer

> То есть остается только апгрейд?

Что-то подобное у меня когда-то было, как-то вылечил без особых разрушений :) yum repolist покажи на всякий случай

Как бы узнать, кому понадобился этот пакет?


rpm -q --whatrequires kdebase-workspace-python-applet
либо (предпочтительнее)
rpm -q --whatrequires $(rpm -q --provides kdebase-workspace-python-applet)
либо
rpm -e --test kdebase-workspace-python-applet

Последняя команда означает «протестировать удаление пакета». Она молча отработает, если kdebase-workspace-python-applet никому не нужен, либо выдаст кучу ругани с перечислением того, кому этот пакет нужен

dexpl ★★★★★ ()
Ответ на: комментарий от kotfantazer

Вдогонку к предыдущему: если под «руками» имелась в виду установка помимо rpm/yum (т. е. из исходников, к примеру), то только вспоминать, что ставил. Или рискнуть удалить kdebase-workspace-python-applet и посмотреть, что «отвалится» (я сам бы так сделал в последнюю очередь)

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

yum repolist
Loaded plugins: presto, refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled: 17
fedora Fedora 12 - i386 enabled: 15 366
rawhide Fedora - Rawhide - Developmental packages for the next Fedora release enabled: 16 104
rpmfusion-free RPM Fusion for Fedora 12 - Free enabled: 383
rpmfusion-free-updates RPM Fusion for Fedora 12 - Free - Updates enabled: 336
rpmfusion-nonfree RPM Fusion for Fedora 12 - Nonfree enabled: 124
rpmfusion-nonfree-updates RPM Fusion for Fedora 12 - Nonfree - Updates enabled: 156
updates Fedora 12 - i386 - Updates enabled: 3 740
updates-testing Fedora 12 - i386 - Test Updates enabled: 999
virtualbox Fedora 12 - i386 - VirtualBox enabled: 4
repolist: 37 229
[root@localhost kotfantazer]#

kotfantazer ()
Ответ на: комментарий от dexpl

Я ставил из официальных сборок. rpm, но не федоровские.
Из исходников ничего не ставил.

***
rpm -q --whatrequires $(rpm -q --provides kdebase-workspace-python-applet)
ни один из пакетов не требует plasma-scriptengine-python
ни один из пакетов не требует =
ни один из пакетов не требует 4.3.2-1.fc12
ни один из пакетов не требует kdebase-workspace-python-applet
ни один из пакетов не требует =
ни один из пакетов не требует 4.3.2-1.fc12
ни один из пакетов не требует kdebase-workspace-python-applet(x86-32)
ни один из пакетов не требует =
ни один из пакетов не требует 4.3.2-1.fc12

***
rpm -e --test kdebase-workspace-python-applet
Ничего не выдала.

kotfantazer ()
Ответ на: комментарий от kotfantazer

> rpm -e --test kdebase-workspace-python-applet

Ничего не выдала


Т. е., его можно спокойно удалять

yum repolist

...

rawhide Fedora - Rawhide - Developmental packages for the next Fedora release enabled: 16 104

...

updates-testing Fedora 12 - i386 - Test Updates enabled: 999


Вот это я бы отключил, во избежание. Собственно, вся нынешняя проблема похожа на один из тех самых багов с rawhide, о которых я говорил

dexpl ★★★★★ ()

>Выскочила ошибка, с которой не знаю как бороться.

Откуда она выскочила? Вы что-то мудрите во второй теме.

Изложите суть вопроса,

konstantinjch ()
Ответ на: комментарий от kotfantazer

> т.е. sudo yum --disablerepo=rawhide

Нет. --disablerepo=rawhide запретит использование однократно. Для перманентного эффекта нужно заменить
enabled=1
на
enabled=0
в /etc/yum.repos.d/fedora-rawhide.repo. Для отключения updates-testing нужно аналогично исправить /etc/yum.repos.d/fedora-updates-testing.repo

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Спасибо тебе за помощь! Пока все работает! :)

updates-testing - это обновления для теста? Глюкавые то есть?

kotfantazer ()
Ответ на: комментарий от kotfantazer

> Спасибо тебе за помощь

На здоровье, если что, обращайся :)

updates-testing - это обновления для теста? Глюкавые то есть?


Ну, можно сказать и так. При обновлении какого-либо пакета из дистрибутива новый пакет помещается сначала в updates-testing, потом (после некоторого времени тестирования, поиска и устранения ошибок) — в updates. Т. е., в тестинге глюков потенциально больше

dexpl ★★★★★ ()
Ответ на: комментарий от kotfantazer

> Не поможешь мне вылечит на HDA-INTEL звук?

Я бы с радостью, но, боюсь, звук в Федоре не совсем по моей части. Навскидку решения нету, надо подумать. Если что-нить надумаю, отпишу в ту тему

dexpl ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.