LINUX.ORG.RU
ФорумAdmin

Установка пакета git-svn


0

1

Всем доброго времени суток!

Подскажите, что не так!?

# yum install git-svn
Loaded plugins: rhnplugin, security
Repository EPEL5x64 is listed more than once in the configuration
This system is not registered with ULN.
ULN support will be disabled.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git-svn.x86_64 0:1.8.2.1-1.el5 set to be updated
--> Processing Dependency: perl(Git::SVN::Utils) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Ra) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Prompt) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Migration) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Log) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Fetcher) for package: git-svn
--> Processing Dependency: perl(Git::SVN::Editor) for package: git-svn
--> Processing Dependency: perl(Git::SVN) for package: git-svn
--> Running transaction check
---> Package perl-Git-SVN.x86_64 0:1.8.2.1-1.el5 set to be updated
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git-SVN
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git-SVN
--> Processing Dependency: perl(SVN::Core) for package: perl-Git-SVN
--> Processing Dependency: perl(SVN::Client) for package: perl-Git-SVN
--> Finished Dependency Resolution
perl-Git-SVN-1.8.2.1-1.el5.x86_64 from EPEL5x64 has depsolving problems
  --> Missing Dependency: perl(SVN::Core) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
perl-Git-SVN-1.8.2.1-1.el5.x86_64 from EPEL5x64 has depsolving problems
  --> Missing Dependency: perl(SVN::Delta) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
perl-Git-SVN-1.8.2.1-1.el5.x86_64 from EPEL5x64 has depsolving problems
  --> Missing Dependency: perl(SVN::Ra) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
perl-Git-SVN-1.8.2.1-1.el5.x86_64 from EPEL5x64 has depsolving problems
  --> Missing Dependency: perl(SVN::Client) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
Error: Missing Dependency: perl(SVN::Core) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
Error: Missing Dependency: perl(SVN::Delta) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
Error: Missing Dependency: perl(SVN::Ra) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
Error: Missing Dependency: perl(SVN::Client) is needed by package perl-Git-SVN-1.8.2.1-1.el5.x86_64 (EPEL5x64)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

# echo "app-vcs/git subversion" >> /etc/portage/package.use 
# emerge -av1 git
qnikst ★★★★★ ()
Ответ на: комментарий от qnikst

ммм...

# echo "app-vcs/git subversion" >> /etc/portage/package.use
-bash: /etc/portage/package.use: No such file or directory
Mister87 ()
Ответ на: комментарий от Mister87

чорт.. думал оценят.. это для другого дистра.

У тебя обновленный дистр? если нет, то лучше бы обновить весь, и потом уже доставлять конкретные программы (имхо).

qnikst ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.