LINUX.ORG.RU

debian 11 (q4os) после установки nvidia 340xx не хочет качать wine32,жалуясь якобы на сломанные пакеты,хоть все они исправны

 , , ,


0

1

вот выхлоп: Следующие пакеты имеют неудовлетворённые зависимости: libasound2-plugins:i386 : Зависит: libavcodec58:i386 (>= 7:4.2) Зависит: libjack-jackd2-0:i386 (>= 1.9.10+20150825) но он не может быть установлен или libjack-0.125:i386 libicu67:i386 : Зависит: libstdc++6:i386 (>= 5.2) но он не будет установлен libpoppler-glib8:i386 : Зависит: libstdc++6:i386 (>= 5.2) но он не будет установлен libpoppler102:i386 : Зависит: libstdc++6:i386 (>= 5.2) но он не будет установлен libsane1:i386 : Зависит: libstdc++6:i386 (>= 5.2) но он не будет установлен E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

synaptic тож ничего с этим сделать не может

что дел???

Как правильно копировать вывод терминала

И ты 32-битную архитектуру подключил? Проверь

sudo dpkg --print-foreign-architectures

и если нет i386 , то добавь

sudo dpkg --add-architecture i386
sudo apt update
Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)

хоть все они исправны

Неубедительно.

у вас зафиксированы сломанные пакеты.

что дел???

Побыстрее проскочить фазу отрицания, расфиксировать сломанные пакеты и починить.

t184256 ★★★★★ ()
Ответ на: комментарий от hamsterxp

Ладно, давай проверим всё полностью:

cd /tmp
echo '# uname -a' > info.txt
uname -a >> info.txt
echo '# lsb_release -a' >> info.txt
lsb_release -a >> info.txt
echo '# cat /etc/apt/sources.list' >> info.txt
cat /etc/apt/sources.list >> info.txt
echo '# cat /etc/apt/sources.list' >> info.txt
cat /etc/apt/sources.list >> info.txt
echo '# cat /etc/apt/sources.list.d/*' >> info.txt
cat /etc/apt/sources.list.d/* >> info.txt

и выложи его куда-нибудь, как и:

sudo -i
cd /tmp
echo '# LANG=C apt install -s libasound2-plugins:i386' > noinstall.txt
LANG=C apt install -s libasound2-plugins:i386 >> noinstall.txt
echo '# LANG=C apt install -s libavcodec58:i386' >> noinstall.txt
LANG=C apt install -s libavcodec58:i386 >> noinstall.txt
echo '# LANG=C apt install -s libicu67:i386' >> noinstall.txt
LANG=C apt install -s libicu67:i386 >> noinstall.txt
echo '# LANG=C apt install -s libjack-0.125:i386' >> noinstall.txt
LANG=C apt install -s libjack-0.125:i386 >> noinstall.txt
echo '# LANG=C apt install -s libjack-jackd2-0:i386' >> noinstall.txt
LANG=C apt install -s libjack-jackd2-0:i386 >> noinstall.txt
echo '# LANG=C apt install -s libpoppler-glib8:i386' >> noinstall.txt
LANG=C apt install -s libpoppler-glib8:i386 >> noinstall.txt
echo '# LANG=C apt install -s libpoppler102:i386' >> noinstall.txt
LANG=C apt install -s libpoppler102:i386 >> noinstall.txt
echo '# LANG=C apt install -s libsane1:i386' >> noinstall.txt
LANG=C apt install -s libsane1:i386 >> noinstall.txt
echo '# LANG=C apt install -s libstdc++6:i386' >> noinstall.txt
LANG=C apt install -s libstdc++6:i386 >> noinstall.txt
chmod 444 noinstall.txt

Нужные файлы в /tmp будут, если это не очевидно.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid
cantlh@can-systemproductname:/tmp$ uname -a >> info.txt
cantlh@can-systemproductname:/tmp$ echo '# lsb_release -a' >> info.txt
cantlh@can-systemproductname:/tmp$ lsb_release -a >> info.txt
No LSB modules are available.
cantlh@can-systemproductname:/tmp$ echo '# cat /etc/apt/sources.list' >> info.txt
cantlh@can-systemproductname:/tmp$ cat /etc/apt/sources.list >> info.txt
cantlh@can-systemproductname:/tmp$ echo '# cat /etc/apt/sources.list' >> info.txt
cantlh@can-systemproductname:/tmp$ cat /etc/apt/sources.list >> info.txt
cantlh@can-systemproductname:/tmp$ echo '# cat /etc/apt/sources.list.d/*' >> info.txt
cantlh@can-systemproductname:/tmp$ cat /etc/apt/sources.list.d/* >> info.txt
cantlh@can-systemproductname:/tmp$ sudo -i
[sudo] пароль для cantlh:
root@can-systemproductname:~# sudo -i
root@can-systemproductname:~# cd /tmp
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libasound2-plugins:i386' > noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libasound2-plugins:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libavcodec58:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libavcodec58:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libicu67:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libicu67:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libjack-0.125:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libjack-0.125:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Package 'libjack-0.125:i386' has no installation candidate
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libjack-jackd2-0:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libjack-jackd2-0:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libpoppler-glib8:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libpoppler-glib8:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libpoppler102:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libpoppler102:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libsane1:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libsane1:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Unable to correct problems, you have held broken packages.
root@can-systemproductname:/tmp# echo '# LANG=C apt install -s libstdc++6:i386' >> noinstall.txt
root@can-systemproductname:/tmp# LANG=C apt install -s libstdc++6:i386 >> noinstall.txt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
hamsterxp ()
Последнее исправление: hamsterxp (всего исправлений: 4)

sources.list.d и preferences.d потыкать надо, особенно последнее, что там с приоритетами

One ★★★★★ ()
Ответ на: комментарий от hamsterxp

тебя просили выложить получившиеся два файла (если ты по командам не можешь понять, какие именно - то всё совсем печально)

firkax ★★ ()
Последнее исправление: firkax (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

Я думаю можно столько проверок не делать. Ибо вся ругань упирается в libstdc++6:i386, его и надо изучать. Скорее всего там версии не совпадают из-за конфликта репозиториев.

firkax ★★ ()
Последнее исправление: firkax (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

Ну зачем так прямо то. Если он сам не догадался распознать редирект в командах, то зачем дальше провоцировать бездумные действия?

firkax ★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Нет, он не среди прочих. Он единственный, кто «не будет установлен». Остальные просто зависят от него и ругань на отсутствующие зависимости вполне логичная.

firkax ★★ ()
Ответ на: комментарий от firkax

Есть лимит на длину сообщения. И такие как ТС то разметку не сделают, то скопировать из терминала не умеют, а если и копируют, то не всё.

Да, днище. Причем полное. Но у иных такие вопросы и не возникают.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)
Ответ на: комментарий от hamsterxp

У тебя не совсем debian 11, а смесь из debian 11 и debian unstable (будущее 12-13). Закомментируй первые три строчки (со словом sid) в /etc/apt/sources.list, потом сделай

apt-get update
, потом
apt-get install libstdc++6:i386
И покажи что он выдаст.

firkax ★★ ()
Ответ на: комментарий от hamsterxp

Устроит, теперь я могу это читать.

Выполни ещё LANG=C apt list --installed > packages.txt и выложи и его тоже. Теперь файл packages.txt появится не в /tmp, а там, где ты запустишь эту команду.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от einhander

Как мне это надоело…

Вот объясни мне, @hamsterxp , почему такие новички как ты постоянно лезут туда, куда и опытные не рискуют?!!

Сперва ты поставил малопопулярный форк Debian, что уже риск. Все эти Antix, Peppermint, Pop!OS и прочие имеют одну фишку — к ним не всегда подходят рецепты от материнских дистрибутивов. А чтобы понять, как нужно делать, нужны знания, которых у тебя нет!

Но ты не ограничился этим! Потом ты ещё подрубил репозитории от Sid. Смесь веток на Debian-based рискованная штука, и если ты не умеешь регулировать приоритеты пакетов, лучше не лезть.

Короче, ты сделал всё, что мог, чтобы твой Linux не работал. У меня один вопрос — ЗАЧЕМ??!!!

Vsevolod-linuxoid ★★★★★ ()

Обезьяна с гранатой. И они любят «гранаты не той системы».

andytux ★★★ ()
Ответ на: комментарий от firkax
Пароль:
root@can-systemproductname:/home/cantlh# apt-get install libstdc++6:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 apt : Зависит: libapt-pkg6.0 (>= 2.3.13) но он не будет установлен
       Зависит: libstdc++6 (>= 11) но он не может быть установлен
 libstdc++6:i386 : Зависит: gcc-11-base:i386 (= 11.2.0-12) но он не будет установлен
 libxml2 : Зависит: libicu67 (>= 67.1-1~) но он не будет установлен
 q4os-desktop : Зависит: tdelibs14-trinity но он не будет установлен
                Зависит: tdebase-trinity-bin но он не будет установлен
                Зависит: tdesudo-trinity но он не будет установлен
                Зависит: tde-style-q4oststyle02-trinity но он не будет установлен
                Зависит: twin-trinity но он не будет установлен
                Зависит: network-manager-tde но он не будет установлен
                Зависит: q4os-desktop-trinity но он не будет установлен или
                                q4os-desktop-plasma но он не будет установлен
                Зависит: xserver-xorg но он не будет установлен
                Зависит: udisks2
                Рекомендует: fwmr-ext но он не может быть установлен
                Рекомендует: pulseaudio
                Рекомендует: unattended-upgrades но он не будет установлен
                Рекомендует: libgl1-mesa-dri но он не будет установлен
                Рекомендует: xserver-xorg-input-all но он не будет установлен
                Рекомендует: xserver-xorg-video-all но он не будет установлен
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.
hamsterxp ()
Ответ на: комментарий от Vsevolod-linuxoid

а что? В стоковых репах нету пакета nvidia-340xx - его выкинули,остался ток в sid вот я и подключил этот реп,т.к я не готов мучатся с noveau.С ним даже скроллинг страницы лагает,как и видео в 720p 60fps на youtube

hamsterxp ()
Ответ на: комментарий от hamsterxp

А то, что нужно было ставить дистрибутив, в котором есть 3 нужных компонента:

  • Драйвер nVidia нужной тебе версии
  • Ядро Linux нужной тебе версии, не все совместимы
  • Xorg нужной тебе версии, тоже не все совместимы

А ты организовал Франкенштейна. Я и не уверен, что его получится вернуть в норму, пакетная система при смешивании веток без выставления приоритетов ломается в хлам.

Самый простой способ получить нормальный и рабочий Linux в твоем случае, насколько я знаю — это поставить https://old-releases.ubuntu.com/releases/18.04.1/ubuntu-18.04.1-desktop-amd64.iso , там ядро 4.15 и LTS линейка Xorg, его обновить, потом поставить драйвер из репозиориев.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от hamsterxp

debian 11 (q4os) после установки nvidia 340xx не хочет качать wine32,жалуясь якобы на сломанные пакеты,хоть все они исправны (комментарий) — дай мне список пакетов, посмотрю.

Хотя скорее всего, уже поздно что-либо восстанавливать. Ты превратил систему в хлам. Поставь что я тебе сказал и ради бога, не трогай репозитории! Там есть Snap Store, если свежего ПО захочется.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

а если я поставлю q4os основанную на 10 дэбчике,и посавлю стандартные репы,и поставлю 340хх всё будет гуд или опять превращу системы в груду металлолома?

прост не хочу качать 18,04 т.к там даже с 340 в гаррисе через вайн на карте gm construct не 100 фпс как тут,а от силы 30

hamsterxp ()
Ответ на: комментарий от hamsterxp

Поставь Windows 10.

На твоем железе можно нормально настроить и заставить Linux работать. Но у тебя явно не хватит на это навыков.

В теории можно поставить сам Debian 10, чистый, и нормально его настроить, и это будет проще, чем бороться с глюками форков, что ты предлагаешь.

Я смогу такое сделать, вероятно. Ты — нет. У тебя даже проблемы с выкладыванием в интернет текстовых файлов, черт возьми!

Я бы ещё попробовал Ubuntu 16.04 с расширенной поддержкой… или CentOS 7… или ещё какой-нибудь старый Linux, у которого не истекла поддержка… тут надо пробовать.

И зачем ты запускаешь такое ПО через Wine? У всех игр от Valve на движках от Valve есть нативные версии.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

я знаю,но гаррис не нашёл,а если и находил,то всё стояло неподвижно

hamsterxp ()
Ответ на: комментарий от Vsevolod-linuxoid

Самый простой способ получить нормальный и рабочий Linux в твоем случае, насколько я знаю — это поставить https://old-releases.ubuntu.com

Там есть Snap Store,

Очень плохие советы.

firkax ★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Хотя скорее всего, уже поздно что-либо восстанавливать. Ты превратил систему в хлам.

Ничё не поздно, apt-get dist-upgrade (после прописывания правильных реп) всё исправит по идее. Но лучше его не вводить если можно обойтись без него, а скорее всего - можно.

firkax ★★ ()
Ответ на: комментарий от firkax

Я уже пробовал так тут одному помочь. Убрать неправильные репы, выставить правильным приоритет 1001, обновить… не сработало. apt умеет апгрейдить, а вот даунгрейд у него не очень работает.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Он только установил что-то вместе с nvidia-legacy, там почти ничего не успело сломаться. Надо откатить эти пакеты, а nvidia-legacy возможно от buster подойдёт через dkms.

apt-show-versions поможет выявить список на исправление

firkax ★★ ()
Последнее исправление: firkax (всего исправлений: 1)
Ответ на: комментарий от hamsterxp

Сделай

apt-get install apt-show-versions

(надеюсь установится)

потом

apt-show-versions | grep -F "version in archive"
firkax ★★ ()
Ответ на: комментарий от hamsterxp

nouveau
С ним даже скроллинг страницы лагает,как и видео в 720p 60fps на youtube

Лютый бред. Почему у меня все работает в разных дистрибутивах с древней видеокартой?

Gonzo ★★★★★ ()
Последнее исправление: Gonzo (всего исправлений: 1)
Ответ на: комментарий от firkax

Это одного пакета, и то мейнтейнеры на даунгрейд не закладываются, зависит чисто от удачи.

Почитай про гарантии даунгрейда через мажорную версию, по крайней мере пять лет назад там было UNSUPPORTED.

t184256 ★★★★★ ()
Ответ на: комментарий от t184256

Вобщем если не пугаться страшилок то скорее всего всё получится.

firkax ★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.