LINUX.ORG.RU

Во время установки Wine сломались пакеты.

 , ,


0

1

Хотел установить Wine. Пошел на Оф.Сайт и сделал все по инструкции для Ubuntu последней версии.

При установке Wine APT сообщил о нехватке wine-stable_6.0.2_impish-1_amd64 который при установке сообщил о нехватке libc6_2.34-0ubuntu3_amd64.

При его установке в подсказке APT предложил --auto-deconfigure и сказал, что это может повредить зависимости fakeroot.

Я подумал прокатит… Поставил пакет с этим ключем. Но теперь пакеты не ставятся. Сломаны зависимости этого fakeroot

Попытался сделать так:

sudo apt install -f

Но получил ошибку:

Следующие пакеты имеют неудовлетворённые зависимости:
libc-bin : 
Зависит: libc6 (< 2.32) но 2.34-0ubuntu3 уже установлен

libc6 :
Ломает: fakeroot (< 1.25.3-1.1ubuntu2~)
Ломает: fakeroot:i386 (< 1.25.3-1.1ubuntu2~)
Ломает: locales (< 2.34) но 2.31-0ubuntu9.2 уже установлен
Рекомендует: libnss-nis но он не может быть установлен
Рекомендует: libnss-nisplus но он не может быть установлен

libc6-dbg : 
Зависит: libc6 (= 2.31-0ubuntu9.2) но 2.34-0ubuntu3 уже установлен

wine-stable :
Зависит: wine-stable-i386 (= 6.0.2~impish-1)
Зависит: wine-stable-amd64 (= 6.0.2~impish-1) но он не установлен

E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.

E: Невозможно исправить зависимости

Что мне с этим делать?

Что мне с этим делать?

не лезть своими шаловливыми рученками в репозитории, ты же самый умный и не стал устанавливать wine из штатной репы, прописал левую и получил закономерный результат

anonymous ()
Ответ на: комментарий от PhysShell

Вот результат sudo dpkg –configure -a: https://pastecode.io/s/2wfvrh8h

Да, тег должен быть Ubuntu, а так же Debian. Одно на другом базируется… Но для конкретики выставил Mint, т.к. не чистой убунтой пользуюсь.

Насчет aptitude - думал Apt, apt-get это обертки для aptitude…

devel-plotnikov ()
Ответ на: комментарий от James_Holden

Жаль. Но не думаю, что так всегда будет. Прогресс не стоит на месте. Ядра становятся лучше, интерфейсы, подсистемы, драйвера. Рано или поздно дойдет и до пакетов я думаю.

devel-plotnikov ()
Ответ на: комментарий от devel-plotnikov

Так уже дошло давно, но не в deb-based. Конкретно вот это просто обречено.

А так есть системы с нормальным управлением пакетами, например NixOS, где таких проблем по определению возникать не может. Ну или Gentoo хотя бы.

James_Holden ()
Ответ на: комментарий от Grapow

[ РЕШЕНО ]

Забыл на пол часа о проблеме. Во время работы понадобился npm. Пытаюсь поставить через apt, но он напомнил мне про проблему.

По рекомендации PhysShell решил воспользоваться aptitude для установки npm. Эта чудо утилита сама исправила все проблемы с пакетами и поставила npm. Проверяю APT - работает без ошибок.

Так что теперь аптом пользоваться не буду. Спасибо PhysShell!

devel-plotnikov ()
Ответ на: Re: [ РЕШЕНО ] от anonymous

Нет спасибо. Хотел fedora, да перехотел. Я столько проблем из коробки даже на ubuntu based дистрибутивах не видел. Mint поставил потому что из коробки крыса4. До этого юзал Linux Lite с крысой, но решил минт вспомнить, ибо он из коробки достаточно юзабильный. Минимум ковыряний. Именно это я искал в федьке + стабильность поболее. Но я был разочарован. Хотя обзоры говорят об обратном, что более стабильного и оптимизированного из коробки не щупали. Видимо конфигурация моего пк не подошла.. хотя это очень сомнительно.

devel-plotnikov ()

mint

сделал все по инструкции для Ubuntu последней версии

А разве для "мяты" и "бубунты" версии с сайта одинаковы? Даже если так, надо было брать для LTS-версии.

Korchevatel ★★★★★ ()
Ответ на: комментарий от devel-plotnikov

Как-то, во времена васянского минта 17.х, меня один товарищ за него агитировал, аж удержу не было. На основном то моём компьютере стоял Scientific Linux7.x + epel + nux-dextop. Ну я и решил на одном из своих ноутбуков попробовать. Установил это васянское чудо без пролем и с XFCE тоже, ибо к «цитрамону» я отношусь предвзято.

Прожило, это васянское чудо, месяца 2-3 наверное. Потом обновилось до следующей подверсии, при обновлении. Ну вроде всё ладно, но я решил на нём одну програмку из ppa ubuntu lts, на тот момент актуальную, установить. Установил. Заработала нормально вроде, но при повторном запуске встала раком. Ну я прибил её конфиги и перезапустил, заработало. Но при повторном запуске опять встала раком. Я попытался исправить ситуацию. Но после того настал абзатс… Это васянское чудо - стало вообще работать через раз и криво аж жуть.

Я удивлся, ибо у брата ubuntu lts стояла, так на ней работала эта програмка и жалоб не было. Хотя он простой пользователь и нуб в системах.

Итог: васянского минта долой, на его место текущую fedora на тот момент, и всё стало чудненько работать и ни одного глюка.

Выводы сам сделаешь? Я сделал и васянский минт == табу для меня. Раз и навсегда. Хотя кто-то его работой доволен, но я очень придирчивый к мелочам.

anonymous ()