LINUX.ORG.RU

apt сломался

 


0

1

ставил приложение, скачалось, установилось, в процессе конфигурирования (dpkg) обратило внимание на то, что java не той версии, вылетело с ошибкой и заблокировалось, не удалялось, удалил вручную из /var/lib/dpkg/status, начал пробовать другие версии java, в результате экспериментов возникли не решённые зависимости, для решения которых apt решил удалить кучу пакетов, а те в свою очередь зависимости от них, вобщем более 100 пакетов удалилось (в т.ч. libreoffice и wine), попытался поставить обратно, большинство поставилось, но некоторые не установились, например те же libreoffice и wine, apt-get update, apt-get -f install ничего не дают, вот результат попыток установить libreoffice, забегая вперёд скажу, что в результате пакеты, на зависимость от которых ссылается apt, установлены «самые новые версии»
как это можно починить?


# apt install libreoffice-writer
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
libreoffice-writer : Зависит: libreoffice-base-core (= 1:4.2.8-0ubuntu5.5) но он не будет установлен
Зависит: libreoffice-core (= 1:4.2.8-0ubuntu5.5) но он не будет установлен
Рекомендует: libreoffice-math но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

# apt install libreoffice-base-core
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
libreoffice-base-core : Зависит: libreoffice-core (= 1:4.2.8-0ubuntu5.5) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

# apt install libreoffice-core
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
libgbm1 : Зависит: libgl1-mesa-dri
libreoffice-core : Зависит: libreoffice-common (> 1:4.2.8) но он не будет установлен
Зависит: ure (>= 4.2~) но он не будет установлен
Зависит: libboost-date-time1.54.0 но он не будет установлен
Зависит: libclucene-contribs1 (>= 2.3.3.4) но он не будет установлен
Зависит: libclucene-core1 (>= 2.3.3.4) но он не будет установлен
Зависит: libcmis-0.4-4 (>= 0.4.0) но он не будет установлен
Зависит: libglu1-mesa но он не будет установлен или
libglu1
Зависит: libharfbuzz-icu0 (>= 0.9.18) но он не будет установлен
Зависит: libhunspell-1.3-0 но он не будет установлен
Зависит: libicu52 (>= 52~m1-1~) но он не будет установлен
Зависит: libmythes-1.2-0 но он не будет установлен
Зависит: libstdc++6 (>= 4.6) но он не будет установлен
Зависит: uno-libs3 (>= 4.2.0~rc1) но он не будет установлен
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.


# apt install libreoffice-common ure libboost-date-time1.54.0 libclucene-contribs1 libclucene-core1 libcmis-0.4-4 libglu1-mesa libharfbuzz-icu0 libhunspell-1.3-0 libicu52 libmythes-1.2-0 libstdc++6 uno-libs3
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлена самая новая версия libclucene-contribs1.
Уже установлена самая новая версия libclucene-core1.
Уже установлена самая новая версия libcmis-0.4-4.
Уже установлена самая новая версия libglu1-mesa.
Уже установлена самая новая версия libmythes-1.2-0.
Уже установлена самая новая версия libboost-date-time1.54.0.
Уже установлена самая новая версия libharfbuzz-icu0.
Уже установлена самая новая версия libhunspell-1.3-0.
Уже установлена самая новая версия libicu52.
Уже установлена самая новая версия libreoffice-common.
Уже установлена самая новая версия uno-libs3.
Уже установлена самая новая версия ure.
Уже установлена самая новая версия libstdc++6.
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


удалил вручную из /var/lib/dpkg/status Зачем ты это сделал? как это можно починить?

Ты уверен, что всё правильно удалил из status? Я вот нет. По хорошем нужно вернуться к состоянию перед правкой статус и тогда можно о чём-то говорить.

Не знаю чем помочь, переустанови систему.

И потом НИКОГДА РУКАМИ НЕ ПРАВЬ ФАЙЛЫ пакетного менеджера и делай бэкапы.

А по поводу твоей проблемы с версией java, что-то мне подсказывает, что она из-за того, что ты смешал репозитории от разных версий дистрибутива или вообще от разных дистрибутивов, например Debian и Ubuntu.

А так делать нельзя.

anonymous ()
Ответ на: комментарий от andytux

Там полный бред написан. Особенно про ppa faudio. Разработчики wine опакетили эту либу и написали как её установить, она идёт в комплекте с сайта winehq.

anonymous ()
Ответ на: комментарий от anonymous

Ты уверен, что всё правильно удалил из status? Я вот нет. По хорошем нужно вернуться к состоянию перед правкой статус и тогда можно о чём-то говорить.

не уверен, но после правки статуса хотя бы удалось удалить сломанный пакет

MaR ()
Ответ на: комментарий от MaR

Мда… Попробуй установить нужные пакеты из кеша апта (в смысле, зависимости). Я не помню нужную команду. Если не получится, то проще переустановить систему, чем пытаться его вылечить. Можно еще попытаться подсунуть ему нужные пакеты, скачав их, с помощью dpkg. Но здесь тоже нет гарантий.

anti_win ★★ ()

удалил вручную из /var/lib/dpkg/status

Ну вот нахрена лезть шаловливыми ручками в системные базы и что-то там редактировать? Это не «apt сломался», это «я сломал apt».

Я бы посоветовал попробовать восстановить этот файл из /var/backups - но вы с тех пор уже понаустанавливали всякого.

Попытаться привести систему в работоспособное состояние можно, восстановив что возможно из резервных копий и приведя версии всех пакетов к единому консистентному состоянию из основного репозитория, но это будет долго, и всё равно наверняка останется куча «хвостов». Действительно, проще переустановить.

На будущее: не лезьте в такого рода базы. И прочитайте man dpkg.

Rootlexx ★★★ ()
Последнее исправление: Rootlexx (всего исправлений: 1)
Ответ на: комментарий от Rootlexx

Ну вот нахрена лезть шаловливыми ручками в системные базы и что-то там редактировать? Это не «apt сломался», это «я сломал apt».

ну что это я его сломал это да, но в базу dpkg я полез когда уже удалилась куча пакетов, часть установил заново, а часть отказывалась устанавливаться, как описано вначале

MaR ()