LINUX.ORG.RU

Обновил я тут ubuntu и сломал APT

 ,


0

1

Всем привет!

Обновил я тут бубунту с 17.10 до 18.04.

$ sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libasan4-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libatomic1-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libcilkrts5-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libgcc1-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libgomp1-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libstdc++6-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
 libubsan0-armhf-cross : Зависит: libc6-armhf-cross (>= 2.27) но 2.24-9ubuntu1cross1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Лады, запускаю то что просят:

$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libapparmor-perl libbind9-140 libboost-filesystem1.62.0 libboost-filesystem1.65.1 libboost-iostreams1.62.0 libboost-random1.62.0 libboost-regex1.62.0 libboost-system1.62.0 libboost-system1.65.1 libboost-thread1.62.0 libcapnp-0.5.3
  libcapnp-0.6.1 libdbus-glib-1-2 libdns162 libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libegl-mesa0 libegl1 libegl1-mesa libgbm1 libgdbm3 libgl1-mesa-dri libglapi-mesa libglvnd0 libisc160 libisccc140 libisccfg140
  libisl15 libllvm5.0 libllvm7 liblwres141 libmirclient9 libmircommon7 libmircore1 libmirprotobuf3 libmpfr4 libntfs-3g872 libpoppler68 libprotobuf-lite10 libruby2.3 libtesseract-data libtesseract3 libtxc-dxtn-s2tc libunistring0
  libwayland-egl1-mesa libwayland-server0 libx11-xcb1 libxcb-dri2-0 libxcb-dri3-0 libxcb-present0 libxcb-sync1 libxcb-xfixes0 libxshmfence1 php7.1-imap php7.1-ldap ruby2.3 ruby2.3-dev tcpd tesseract-ocr-equ
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libc6-armhf-cross libc6-dev-armhf-cross
Следующие пакеты будут обновлены:
  libc6-armhf-cross libc6-dev-armhf-cross
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 10 пакетов.
Необходимо скачать 0 B/2 904 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 234383 файла и каталога.)
Подготовка к распаковке …/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb …
Распаковывается libc6-dev-armhf-cross (2.27-3ubuntu1cross1.1) на замену (2.24-9ubuntu1cross1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 не удалось открыть «/usr/arm-linux-gnueabihf/lib/Mcrt1.o.dpkg-new»: No such file or directory
Подготовка к распаковке …/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb …
Распаковывается libc6-armhf-cross (2.27-3ubuntu1cross1.1) на замену (2.24-9ubuntu1cross1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 не удалось открыть «/usr/arm-linux-gnueabihf/lib/ld-2.27.so.dpkg-new»: No such file or directory
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

И что делать?!

★★★

apt dist-upgrade делал?

anonymous ()

/usr/arm-linux-gnueabihf/lib/ld-2.27.so.dpkg-new

ну тут явно кто-то ошибся в путях.
варианта 3
1. подождать когда исправят пакет
2. ищешь в /var/lib/dpkg/info/libc6-armhf-cross.* этот путь и исправляешь на правильный и apt -f install
3. создаёшь /usr/arm-linux-gnueabihf/lib/, кладёшь туда ld-2.27.so из пакета как ld-2.27.so.dpkg-new и после установки всё это удаляешь

bass ★★★★★ ()
Последнее исправление: bass (всего исправлений: 2)
Ответ на: комментарий от bass

Короче, помогло так:

# apt-get remove *-armhf-cross libc6-armhf-cross  gcc-7-arm-linux-gnueabihf gcc-arm-linux-gnueabihf

Ну и по новой установил пакеты

AntonyRF ★★★ ()
Ответ на: комментарий от bass

ну тут явно кто-то ошибся в путях.

Там сам dpkg так переименовывает. Когда изменения есть, сравнивает, потом сообщает. Если норм, то старый удаляет, а этот переименовывает в этот. Короче, муть там.

turtle_bazon ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.