LINUX.ORG.RU

Убунта. Установить отладочные данные для старой версии пакета

 ,


0

1

Что за беспорядок в убунте?

mittorn@mittorn-shield:~$ sudo apt-get install xserver-xorg-core-dbg
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xserver-xorg-core-dbg : Зависит: xserver-xorg-core (= 2:1.15.1-0ubuntu2.11)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты

Как это исправить? Куда копать

★★★★★

Ну для начала глянь

apt-cache policy xserver-xorg-core-dbg xserver-xorg-core
Может, там действительно по версиям расхождение.

tiandrey ★★★★★ ()
Ответ на: комментарий от tiandrey

там есть расхождение. Но мне нужны отладочные данные от установленной версии. если обновить иксы - сломается поворот тачскрина

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Если нужная версия есть в репозитории, то просто устанавливай эту версию:

sudo apt-get install xserver-xorg-core-dbg=<версия xserver-xorg-core>

tiandrey ★★★★★ ()

Ладно, добавил костыль для тачскрина. теперь при повороте скриптом задаётся матрица преобразования

mittorn ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.