LINUX.ORG.RU

Remmina на Tails

 ,


0

1

При попытке установить реммину на tails 3.8 выбивает ошибку

root@amnesia:~# sudo apt install remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но 0.7.3-2 будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. root@amnesia:~#

Ответ на: комментарий от anonymous

пробовал, просит этот libssh 0.8.0 версии, пробую sudo apt install libssh-4* пишет - root@amnesia:~# sudo apt install libssh-4* Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Заметьте, выбирается «libssh-4» для glob «libssh-4*» Уже установлен пакет libssh-4 самой новой версии (0.7.3-2). обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 147 пакетов не обновлено.

mazura999qw ()
Ответ на: комментарий от dpood

всё то же самое, не понимаю как установить этот libssh нужный, все время ставит «но 0.7.3-2 будет установлен»

root@amnesia:~# apt-get install remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но 0.7.3-2 будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

mazura999qw ()
Ответ на: комментарий от anonymous

все разобрался. все копирует. просто не там прописал опцию. но все же вопрос в другом, в реммине есть множество плюсов, например сразу к 2-3-4 удаленкам подключаться, и переключаться между ними, тут же тупо одно окно

mazura999qw ()
Ответ на: комментарий от mazura999qw

remmina для подключения к rdp использует freerdp.

Почему у тебя вообще возникает проблема не понятна, видимо, ты подключил репозитории от другого дистрибутива, другой версии дистрибутива.

anonymous ()
Ответ на: комментарий от anonymous

debian, все вроде делаю как надо, но он выдает ошибку, писал выше. раньше была такая же проблема, но решилась сама спустя какое то время, теперь вообще ни по каким командам не ставит, все время пишет зависимость от libssh 0.8.0 - его можно как то установить на тайлс?

mazura999qw ()
Ответ на: комментарий от dpood

root@amnesia:~# apt-get -t stretch-backports install Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 252 пакетов не обновлено. root@amnesia:~# sudo apt install remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но 0.7.3-2 будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. root@amnesia:~#

mazura999qw ()
Ответ на: комментарий от dpood

не логично же что неделю назад реммина прекрасно ставилась по sudo apt install -t stretch-backports remmina remmina-plugin-rdp remmina-plugin-secret

а сейчас опять та же ошибка что и раньше только теперь и по этой команде

mazura999qw ()
Ответ на: комментарий от dpood

root@amnesia:~# apt install -t stretch-backports libssh-4 Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Будут установлены следующие дополнительные пакеты: libssh-dev libssl-dev Предлагаемые пакеты: libssh-doc Рекомендуемые пакеты: libssl-doc Пакеты, которые будут УДАЛЕНЫ: libssl1.0-dev НОВЫЕ пакеты, которые будут установлены: libssl-dev Пакеты, которые будут обновлены: libssh-4 libssh-dev обновлено 2, установлено 1 новых пакетов, для удаления отмечено 1 пакетов, и 250 пакетов не обновлено. Необходимо скачать 1 987 kБ архивов. После данной операции, объём занятого дискового пространства уменьшится на 280 kB. Хотите продолжить? [Д/н] д Пол:1 tor+http://vwakviie2ienjx6t.onion/debian stretch-backports/main amd64 libssh-dev amd64 0.8.1-1~bpo9+1 [227 kB] Пол:2 tor+http://vwakviie2ienjx6t.onion/debian stretch-backports/main amd64 libssh-4 amd64 0.8.1-1~bpo9+1 [185 kB] Пол:3 tor+http://vwakviie2ienjx6t.onion/debian stretch/main amd64 libssl-dev amd64 1.1.0f-3+deb9u2 [1 575 kB] Получено 1 987 kБ за 7с (270 kБ/c) (Чтение базы данных … на данный момент установлено 139240 файлов и каталогов.) Подготовка к распаковке …/libssh-dev_0.8.1-1~bpo9+1_amd64.deb … Распаковывается libssh-dev (0.8.1-1~bpo9+1) на замену (0.7.3-2) … Подготовка к распаковке …/libssh-4_0.8.1-1~bpo9+1_amd64.deb … Распаковывается libssh-4:amd64 (0.8.1-1~bpo9+1) на замену (0.7.3-2) … (Чтение базы данных … на данный момент установлено 139238 файлов и каталогов.) Удаляется libssl1.0-dev:amd64 (1.0.2l-2+deb9u3) … Выбор ранее не выбранного пакета libssl-dev:amd64. (Чтение базы данных … на данный момент установлено 139153 файла и каталога.) Подготовка к распаковке …/libssl-dev_1.1.0f-3+deb9u2_amd64.deb … Распаковывается libssl-dev:amd64 (1.1.0f-3+deb9u2) … Настраивается пакет libssl-dev:amd64 (1.1.0f-3+deb9u2) … Обрабатываются триггеры для libc-bin (2.24-11+deb9u3) … Настраивается пакет libssh-4:amd64 (0.8.1-1~bpo9+1) … Настраивается пакет libssh-dev (0.8.1-1~bpo9+1) … Обрабатываются триггеры для libc-bin (2.24-11+deb9u3) … root@amnesia:~# sudo apt install remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

mazura999qw ()
Ответ на: комментарий от dpood

извини что туплю(

мля то же самое что за бред

root@amnesia:~# apt install -t stretch-backports remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

mazura999qw ()
Ответ на: комментарий от dpood

root@amnesia:~# apt-cache policy libssh-4 libssh-4: Установлен: 0.8.1-1~bpo9+1 Кандидат: 0.8.1-1~bpo9+1 Таблица версий: 0.8.1-1 -10 -10 tor+http://vwakviie2ienjx6t.onion/debian sid/main amd64 Packages *** 0.8.1-1~bpo9+1 100 100 tor+http://vwakviie2ienjx6t.onion/debian stretch-backports/main amd64 Packages 100 /var/lib/dpkg/status 0.7.3-2 990 990 tor+http://vwakviie2ienjx6t.onion/debian stretch/main amd64 Packages

root@amnesia:~# apt install -t stretch-backports remmina remmina-plugin-rdp Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

# /etc/apt/sources.list

deb tor+http://vwakviie2ienjx6t.onion/debian/ stretch main contrib deb tor+http://sgvtcaew4bxjd7ln.onion/ stretch/updates main contrib deb tor+http://vwakviie2ienjx6t.onion/debian stretch-backports main contrib non-free

mazura999qw ()
Ответ на: комментарий от mazura999qw

debian, все вроде делаю как надо

Какой Debian, Debian 7, Debian 8, Debian 9?

Если бы на основе Debian Stretch, то проблем с зависимостями не было бы.

Покажи sources.list.

anonymous ()