LINUX.ORG.RU

Конфликт пакетов

 , ,


1

1

Конфликтуют nodejs и nodejs-lts-boron, подскажите, как исправить.


pacaur -Syu                                                                       ~
:: Обновление баз данных пакетов...
 antergos не устарел
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
:: Запускается полное обновление системы...
:: Заменить cargo на community/rust? [Y/n] Y
предупреждение: pepper-flash: установленная версия (1:26.0.0.137-1) новее, чем в extra (26.0.0.151-1)
разрешение зависимостей...
проверка конфликтов...
:: nodejs и nodejs-lts-boron конфликтуют. Удалить nodejs-lts-boron? [y/N] y
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: slap: удаление nodejs-lts-boron ломает зависимость 'nodejs-lts-boron'
:: Запускается обновление AUR...
:: cargo не существует в AUR -- пропускаем
 нечего выполнять


Всё дело в PKGBUILD пакета slap, а именно в жёсткой зависимости от nodejs-lts-boron. Либо пересобери slap, отредактировав PKGBUILD, либо сноси его, либо сноси nodejs.

HTaeD ★★★★ ()