LINUX.ORG.RU

Проблема с обновлением Arch

 ,


0

1

Здравствуйте!

При запуске обновления выдаёт:

# pacman -Syu
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
:: Запускается полное обновление системы...
:: Заменить attica-qt5 на extra/attica? [Y/n] y
:: Заменить compositeproto на extra/xorgproto? [Y/n] n
:: Заменить damageproto на extra/xorgproto? [Y/n] n
:: Заменить fixesproto на extra/xorgproto? [Y/n] n
:: Заменить fontsproto на extra/xorgproto? [Y/n] n
:: Заменить inputproto на extra/xorgproto? [Y/n] n
:: Заменить kbproto на extra/xorgproto? [Y/n] n
:: Заменить randrproto на extra/xorgproto? [Y/n] n
:: Заменить recordproto на extra/xorgproto? [Y/n] n
:: Заменить renderproto на extra/xorgproto? [Y/n] n
:: Заменить scrnsaverproto на extra/xorgproto? [Y/n] n
:: Заменить videoproto на extra/xorgproto? [Y/n] n
:: Заменить wxpython на community/python2-wxpython3? [Y/n] n
:: Заменить xextproto на extra/xorgproto? [Y/n] n
:: Заменить xf86vidmodeproto на extra/xorgproto? [Y/n] n
:: Заменить xineramaproto на extra/xorgproto? [Y/n] n
:: Заменить xproto на extra/xorgproto? [Y/n] n
разрешение зависимостей...
проверка конфликтов...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: ffmpeg2.8: установка libvpx (1.7.0-1) ломает зависимость 'libvpx.so=4-64'
:: ffmpeg2.8: установка x265 (2.7-1) ломает зависимость 'libx265.so=146-64'

Подскажите, что делать в такой ситуации?

Ответ на: комментарий от alexferman

Пробовал соглашаться на замену при первом запуске pacman -Syu, но конфликтов вылезло немного побольше:

# pacman -Syu
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
:: Запускается полное обновление системы...
:: Заменить attica-qt5 на extra/attica? [Y/n] y
:: Заменить compositeproto на extra/xorgproto? [Y/n] y
:: Заменить damageproto на extra/xorgproto? [Y/n] y
:: Заменить fixesproto на extra/xorgproto? [Y/n] y
:: Заменить fontsproto на extra/xorgproto? [Y/n] y
:: Заменить inputproto на extra/xorgproto? [Y/n] y
:: Заменить kbproto на extra/xorgproto? [Y/n] y
:: Заменить randrproto на extra/xorgproto? [Y/n] y
:: Заменить recordproto на extra/xorgproto? [Y/n] y
:: Заменить renderproto на extra/xorgproto? [Y/n] y
:: Заменить scrnsaverproto на extra/xorgproto? [Y/n] y
:: Заменить videoproto на extra/xorgproto? [Y/n] y
:: Заменить wxpython на community/python2-wxpython3? [Y/n] y
:: Заменить xextproto на extra/xorgproto? [Y/n] y
:: Заменить xf86vidmodeproto на extra/xorgproto? [Y/n] y
:: Заменить xineramaproto на extra/xorgproto? [Y/n] y
:: Заменить xproto на extra/xorgproto? [Y/n] y
разрешение зависимостей...
проверка конфликтов...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: ffmpeg2.8: установка libvpx (1.7.0-1) ломает зависимость 'libvpx.so=4-64'
:: ffmpeg2.8: установка x265 (2.7-1) ломает зависимость 'libx265.so=146-64'
:: libxfont: удаление fontsproto ломает зависимость 'fontsproto>=2.1.3'

Поэтому отказался от замены почти всех предлагаемых пакетов. Не помогло.

g3nt00user ()