LINUX.ORG.RU

установка skype

 ,


1

2

ядро 3.10.17-gentoo x86_64

emerge net-im/skype

Calculating dependencies... done!
[ebuild   R    ] virtual/libintl-0-r1  ABI_X86="32*" 
[ebuild   R    ] dev-libs/expat-2.1.0-r4  ABI_X86="32*" 
[ebuild   R    ] app-arch/bzip2-1.0.6-r6  ABI_X86="32*" 
[ebuild   R    ] virtual/libiconv-0-r2  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libffi-3.0.13-r1  ABI_X86="32*" 
...
[ebuild  N    ~] net-im/skype-4.3.0.37-r5  USE="pulseaudio -apulse -pax_kernel (-selinux)" 
[blocks B      ] x11-libs/libXinerama[abi_x86_32(-)] ("x11-libs/libXinerama[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXau[abi_x86_32(-)] ("x11-libs/libXau[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXi[abi_x86_32(-)] ("x11-libs/libXi[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXScrnSaver[abi_x86_32(-)] ("x11-libs/libXScrnSaver[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXrandr[abi_x86_32(-)] ("x11-libs/libXrandr[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking x11-libs/libXrender-0.9.8, x11-libs/libXtst-1.2.2, x11-libs/libXau-1.0.8, x11-libs/libXScrnSaver-1.2.2-r1, x11-libs/libSM-1.2.2-r1, x11-proto/inputproto-2.3.1, x11-proto/randrproto-1.4.0-r1, x11-proto/kbproto-1.0.6-r1, x11-libs/libICE-1.0.9, dev-libs/libpthread-stubs-0.3-r1, media-libs/fontconfig-2.11.1-r2, x11-proto/scrnsaverproto-1.2.2-r1, x11-libs/libXv-1.0.10, x11-libs/libXext-1.3.3, x11-libs/libXi-1.7.4, x11-proto/xf86bigfontproto-1.2.0-r1, x11-proto/fixesproto-5.0-r1, x11-libs/libXinerama-1.1.3, x11-libs/libXfixes-5.0.1, x11-proto/renderproto-0.11.1-r1, x11-proto/recordproto-1.14.2-r1, x11-libs/libXdmcp-1.1.1-r1, x11-proto/xproto-7.0.27, x11-proto/xcb-proto-1.11, x11-libs/libXcursor-1.1.14, x11-libs/libxcb-1.11-r1, x11-proto/xineramaproto-1.2.1-r1, x11-libs/libXrandr-1.4.2, x11-proto/xextproto-7.3.0, x11-libs/libX11-1.6.2, x11-proto/videoproto-2.3.2)
[blocks B      ] x11-libs/libXext[abi_x86_32(-)] ("x11-libs/libXext[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libSM[abi_x86_32(-)] ("x11-libs/libSM[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXrender[abi_x86_32(-)] ("x11-libs/libXrender[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXtst[abi_x86_32(-)] ("x11-libs/libXtst[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libxcb[abi_x86_32(-)] ("x11-libs/libxcb[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libICE[abi_x86_32(-)] ("x11-libs/libICE[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libX11[abi_x86_32(-)] ("x11-libs/libX11[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] media-libs/freetype[abi_x86_32(-)] ("media-libs/freetype[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXfixes[abi_x86_32(-)] ("x11-libs/libXfixes[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXv[abi_x86_32(-)] ("x11-libs/libXv[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] media-libs/fontconfig[abi_x86_32(-)] ("media-libs/fontconfig[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXcursor[abi_x86_32(-)] ("x11-libs/libXcursor[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)
[blocks B      ] x11-libs/libXdmcp[abi_x86_32(-)] ("x11-libs/libXdmcp[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

хорошо, скачал скайп с офф сайта хочу запустить

./skype
./skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory

ldd skype
	linux-gate.so.1 (0xffffe000)
	libXv.so.1 => /usr/lib32/libXv.so.1 (0xf5487000)
	libXss.so.1 => /usr/lib32/libXss.so.1 (0xf5483000)
	librt.so.1 => /lib32/librt.so.1 (0xf547a000)
	libdl.so.2 => /lib32/libdl.so.2 (0xf5475000)
	libX11.so.6 => /usr/lib32/libX11.so.6 (0xf533e000)
	libXext.so.6 => /usr/lib32/libXext.so.6 (0xf532c000)
	libQtDBus.so.4 => not found
	libQtWebKit.so.4 => not found
	libQtXml.so.4 => not found
	libQtGui.so.4 => not found
	libQtNetwork.so.4 => not found
	libQtCore.so.4 => not found
	libpthread.so.0 => /lib32/libpthread.so.0 (0xf5311000)
	libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/32/libstdc++.so.6 (0xf5227000)
	libm.so.6 => /lib32/libm.so.6 (0xf51e0000)
	libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.4/32/libgcc_s.so.1 (0xf51c5000)
	libc.so.6 => /lib32/libc.so.6 (0xf5028000)
	/lib/ld-linux.so.2 (0xf54ac000)
	libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf5005000)
	libXau.so.6 => /usr/lib32/libXau.so.6 (0xf5001000)
	libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf4ff9000)

каким образом быстрее ?! ) Установить недостающие библиотеки, либо избавиться от блоков.


У меня не гента, но, я накидал либ и сказал скаюпу где из искать. Получилось быстрее.

deep-purple ★★★★★ ()

Новости не читай - на форум пиши

https://www.gentoo.org/support/news-items/2015-03-28-true-multilib.html

Для Ъ:

In case of issues, blockers especially, users are recommended
to manually uninstall any emul-linux-x86 packages that may have been
installed on their systems. This will aid the Package Manager
in choosing the correct dependency resolution path. If using Portage,
this can be done using the following command:

    $ emerge -C 'app-emulation/emul-linux-x86*'

В твоём выхлопе eselect news эта новость наверняка есть. Только ты её не читал, да...

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от Pinkbyte

хмм, удалил emul завелось вот так. USE=«abi_x86_32» emerge skype смотрим что дальше, запустится ли?!

yaxon ()

скайпу нужны 32 битные либы, enjoy your crap

Zlogene ()
Ответ на: комментарий от Pinkbyte

Скажите пожалуйста.... для установки skype на другой машине требуется

[ebuild   R    ] dev-libs/libxml2-2.9.2-r1:2::gentoo  USE="ipv6 python readline -debug -examples -icu* -lzma -static-libs {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
без -icu*
а хромиум требует icu
Как разрулить ситуацию?!
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.2-r1:2/2::gentoo, installed) pulled in by
    dev-libs/libxml2:=[icu] required by (www-client/chromium-43.0.2357.65:0/0::gentoo, installed)
                       ^^^                                                                                                           
    dev-libs/libxml2:2/2=[icu] required by (www-client/chromium-43.0.2357.65:0/0::gentoo, installed)
                          ^^^                                                                                                           

  (dev-libs/libxml2-2.9.2-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
                       ^^^^^                                                                                                                                                                                                                                                                                   
    >=dev-libs/libxml2-2.9.1-r4:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/gst-plugins-base-0.10.36-r2:0.10/0.10::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                     
    >=dev-libs/libxml2-2.9.1-r4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/gstreamer-0.10.36-r2:0.10/0.10::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                            


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Как собственно маскировать пакет ? Не разу не маскировал )

yaxon ()
Ответ на: комментарий от yaxon

Удали генту, ты не прошёл её испытательный срок

anonymous ()
Ответ на: комментарий от Pinkbyte

В итоге через пару недель будет тред, а-ля «как резолвить конфликт с emul-linux-x86». Со знанием дистров не рождаются, но можно же хотя бы FAQ почитать.

anonymous ()
Ответ на: комментарий от anonymous

Знание тонкостей, которые присущи только этому дистрибутиву, очевидно

anonymous ()
Ответ на: комментарий от Pinkbyte

Но ты же уже понял, что речь здесь идёт вовсе не о знаниях. Он даже никаких усилий не прикладывает, чтобы их получить. Зачем тратить на него время?

anonymous ()
Ответ на: комментарий от anonymous

Он даже никаких усилий не прикладывает, чтобы их получить

Мне так не кажется. Но то, что человек невнимательно читает логи и не знает, где можно прочесть подробнее о работе portage - немного удручает, да

Вспомнил одного своего друга, который иногда просит помочь с выхлопом portage(обычно когда он превышает 2-3 страницы). Его извиняет только одна вещь - он не знает английский. Совсем. Он немецкий учил

А как ты понимаешь, самые полные и адекватные маны - явно не на немецком или русском :-)

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Мне кажется, человеку, который достаточно плотно общается с IT рано или поздно придётся выучить английский хотя бы на уровне «Могу понять вот этот ман».

Хотя, мне, как человеку, учившему английский, судить об этом, конечно, тяжелее, ибо я никогда не попаду в ту же ситуацию, что и твой друг.

anonymous ()
Ответ на: комментарий от anonymous

Ну мелкие текстики он при помощи Google translate сам осиливает - без английского в нашей профессии вообще никак, тут я согласен

Но если простыня ну очень большая и специфичная, а выхлоп portage мягко говоря иногда вводит в ступор даже англоязычных пользователей, - то проще потыкать палочкой в человека, который подобные выхлопы читает почаще в силу своих обязанностей :-)

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)

Есть же веб версия скайпа на web.skype.com, мне для чатиков хватает

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.