LINUX.ORG.RU

Не могу понять что он от меня хочет в зависимостях?

 , , ,


0

1
merge -av1 x11-libs/libXdmcp

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies ... done!                           
[ebuild   R    ] x11-libs/libXdmcp-1.1.1-r1  USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[blocks B      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking x11-libs/libXdmcp-1.1.1-r1)
[blocks B      ] x11-libs/libXdmcp[abi_x86_32(-)] ("x11-libs/libXdmcp[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20140508)

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/libXdmcp-1.1.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libXdmcp-1.0.2 required by (x11-base/xorg-server-1.17.1:0/1.17.1::gentoo, installed)
    x11-libs/libXdmcp
    >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/libXdmcp-1.1.1-r1[abi_x86_64(-)]) required by (x11-libs/libxcb-1.11-r1:0/1.11::gentoo, installed)
    x11-libs/libXdmcp required by (kde-base/kdm-4.11.16:4/4.11::kde, installed)
    x11-libs/libXdmcp required by (kde-base/kdelibs-4.14.5:4/4.14::kde, installed)

  (app-emulation/emul-linux-x86-xlibs-20140508:0/0::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20140508 required by (app-emulation/emul-linux-x86-medialibs-20140508-r6:0/0::gentoo, installed)
    app-emulation/emul-linux-x86-xlibs required by (x11-drivers/nvidia-drivers-346.35:0/0::gentoo, installed)
    >=app-emulation/emul-linux-x86-xlibs-20121028[-abi_x86_32(-)] required by (games-util/steam-launcher-1.0.0.49-r3:0/0::steam-overlay, installed)
    >=app-emulation/emul-linux-x86-xlibs-20100611 required by (app-emulation/emul-linux-x86-opengl-20140508-r1:0/0::gentoo, installed)
    >=app-emulation/emul-linux-x86-xlibs-2.1[development,-abi_x86_32(-)] required by (app-emulation/wine-1.7.33:0/0::gentoo, installed)
    app-emulation/emul-linux-x86-xlibs[development,-abi_x86_32(-)] required by (app-emulation/wine-1.7.33:0/0::gentoo, installed)

Что бы я поставил abi_x86_32 и на emulation/emul-linux-x86-xlibs?

★★★★★

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

Какая именно буква в этом сообщении тебе не понятна?
Я обычно в таких случаях удаляю оба пакета, потом обновляю мир, оно само поставит из этих двух самый нужный. Более сложный случай включает использование ключа -t и игры с USE-флагами.

Kroz ★★★★★ ()

app-emulation/emul-linux-x86* быть не должно вовсе. Не скажу насчёт скайпа и флеша, но остальной софт работает без картонного мультилиба.

Наверное, намекает на удалить x86-xlibs x86-medialibs x86-opengl wine steam-launcher.

wakuwaku ★★★★ ()

USE="-abi_x86_32" emerge -vp x11-libs/libXdmcp
как уже сказали, надо использовать либо emul-linux-* либо multilib

arrecck ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.