LINUX.ORG.RU

[gentoo] Проблемы с зависимостями


0

0

размаскировал autounmask gnome-2.28 установил и теперь:

sys-apps/parted:0

('ebuild', '/', 'sys-apps/parted-1.9.0', 'merge') pulled in by >=sys-apps/parted-1.7.1 required by ('ebuild', '/', 'sys-block/gparted-0.4.5', 'merge') sys-apps/parted required by world

('installed', '/', 'sys-apps/parted-1.9.0', 'nomerge') pulled in by >=sys-apps/parted-1.8.8[device-mapper] required by ('installed', '/', 'sys-apps/devicekit-disks-009', 'nomerge') (and 2 more)

Explanation:

New USE for 'sys-apps/parted:0' are incorrectly set. In order to solve this, adjust USE to satisfy '>=sys-apps/parted-1.8.8[device-mapper]'.

gnome-base/gnome-panel:0

('ebuild', '/', 'gnome-base/gnome-panel-2.26.3', 'merge') pulled in by >=gnome-base/gnome-panel-2 required by ('ebuild', '/', 'gnome-extra/gnome-power-manager-2.22.1', 'merge') >=gnome-base/gnome-panel-2 required by ('installed', '/', 'gnome-extra/gnome-power-manager-2.28.3', 'nomerge') >=gnome-base/gnome-panel-2.0 required by ('ebuild', '/', 'gnome-base/gnome-control-center-2.26.0-r1', 'merge') (and 6 more)

('installed', '/', 'gnome-base/gnome-panel-2.28.0', 'nomerge') pulled in by >=gnome-base/gnome-panel-2.28.0 required by ('ebuild', '/', 'gnome-base/gnome-2.28.2', 'merge') (and 9 more)

x11-base/xorg-server:0

('installed', '/', 'x11-base/xorg-server-1.6.5-r1', 'nomerge') pulled in by x11-base/xorg-server[kdrive] required by ('installed', '/', 'app-admin/sabayon-2.28.1', 'nomerge') (and 5 more)

('ebuild', '/', 'x11-base/xorg-server-1.6.5-r1', 'merge') pulled in by >=x11-base/xorg-server-1.5.3-r7 required by ('ebuild', '/', 'x11-drivers/ati-drivers-9.11', 'merge') x11-base/xorg-server[-minimal] required by ('ebuild', '/', 'x11-base/xorg-x11-7.4-r1', 'merge') >=x11-base/xorg-server-1.6.3 required by ('ebuild', '/', 'x11-drivers/xf86-input-evdev-2.3.2', 'merge') (and 2 more)

Explanation:

New USE for 'x11-base/xorg-server:0' are incorrectly set. In order to solve this, adjust USE to satisfy 'x11-base/xorg-server[kdrive]'.

x11-libs/libwnck:0

('ebuild', '/', 'x11-libs/libwnck-2.26.2-r2', 'merge') pulled in by >=x11-libs/libwnck-2.19.5 required by ('ebuild', '/', 'gnome-base/gnome-panel-2.26.3', 'merge') >=x11-libs/libwnck-2.10.0 required by ('ebuild', '/', 'gnome-extra/gnome-power-manager-2.22.1', 'merge') >=x11-libs/libwnck-2.10.0 required by ('installed', '/', 'gnome-extra/gnome-power-manager-2.28.3', 'nomerge') (and 7 more)

('installed', '/', 'x11-libs/libwnck-2.28.0', 'nomerge') pulled in by >=x11-libs/libwnck-2.28.0 required by ('ebuild', '/', 'gnome-base/gnome-2.28.2', 'merge') (and 10 more)

x11-wm/metacity:0

('installed', '/', 'x11-wm/metacity-2.28.1', 'nomerge') pulled in by >=x11-wm/metacity-2.28.1 required by ('ebuild', '/', 'gnome-base/gnome-2.28.2', 'merge') (and 3 more)

подобного на 3-4 страницы

Что делать?


Проблемы

<GN> Слово «проблема» пишется с одним «м»! </GN>

akk ★★★★★ ()

adjust USE to +device-mapper

adjust USE to satisfy 'x11-base/xorg-server +kdrive

Sylvia ★★★★★ ()

IMHO, сообщение указывает на дополнительные установки пакетов, а именно:
   gnome-panel-2.26.3
   gnome-power-manager-2.22.1
   gnome-control-center-2.26.0-r1
   xorg-server-1.6.5-r1
   ati-drivers-9.11
   xorg-x11-7.4-r1 и т.д.

   Если же я ошибаюсь(а это в большей вероятности, т.к. сам нуждаюсь в помощи), то следует использовать репозиторий, например у ASPLinux, эта утилита называется yum, благодаря которой можно выяснить нужные зависимости, или установить тот или иной пакет без затруднений.
   Почитай вот тут:
http://www.linux.org.ru/forum/linux-install/4652226?lastmod=1270196744062
так лучше поймешь о чем я говорю=)

FA70H ()
Ответ на: комментарий от FA70H

И зачем ты сюда это всё написал? Неужели нельзя отращивать скоре без флуда в дженерал?



PS: топикстартеру: ты столкнулся с тем, что теперь некоторые пакеты хотят другие пакеты по зависимостям, собранные с определёнными флагами. Например:

('installed', '/', 'sys-apps/parted-1.9.0', 'nomerge') pulled in by >=sys-apps/parted-1.8.8[device-mapper] required by ('installed', '/', 'sys-apps/devicekit-disks-009', 'nomerge') (and 2 more)


Пакет sys-apps/devicekit-disks-009 хочет, чтобы >=sys-apps/parted-1.8.8 был собран с флагом device-mapper

Либо добавляй нужные флаги в /etc/make.conf
Либо прописывай флаги индивидуально пакетам в /etc/portage/package.use
Либо перекрывай и исправляй на предмет зависимостей нужные ебилды в локальном оверлее
Либо перестань смешивать стейбл и ~ ;)

Lumi ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.