LINUX.ORG.RU

[gentoo][gnome-2.30.2][туплю] Проблемы с зависимостями.


0

0
media-libs/gst-plugins-base:0.10

  ('ebuild', '/', 'media-libs/gst-plugins-base-0.10.29', 'merge') pulled in by
    >=media-libs/gst-plugins-base-0.10.29 required by ('ebuild', '/', 'gnome-base/gnome-2.30.2', 'merge')
    >=media-libs/gst-plugins-base-0.10.29 required by ('ebuild', '/', 'media-libs/gst-plugins-good-0.10.22', 'merge')
    (and 50 more)

  ('ebuild', '/', 'media-libs/gst-plugins-base-0.10.28', 'merge') pulled in by
    ~media-libs/gst-plugins-base-0.10.28 required by ('ebuild', '/', 'media-plugins/gst-plugins-alsa-0.10.28', 'merge')
    ~media-libs/gst-plugins-base-0.10.28 required by ('ebuild', '/', 'media-plugins/gst-plugins-cdparanoia-0.10.28', 'merge')
    ~media-libs/gst-plugins-base-0.10.28 required by ('ebuild', '/', 'media-plugins/gst-plugins-gio-0.10.28', 'merge')
    (and 56 more)

Размаскировываю gst-plugins-base-0.10.29 и ничего не меняется. Что я делаю не так?


Это значит, что у тебя gnome-base/gnome-2.30.2 и др. хотят media-libs/gst-plugins-base-0.10.29

Но media-plugins/gst-plugins-alsa-0.10.28 и компания - хотят media-libs/gst-plugins-base-0.10.28

Соответственно, видимо, нужно размаскировать кого-то постарше, чем media-plugins/gst-plugins-alsa-0.10.28 или переустановить, если зависимость идёт только от того, что оно установлено с более старой версией.

Я в таком случае обычно тупо маскирую <media-libs/gst-plugins-base-0.10.29 и смотрю, кто начнёт ругаться на это маскирование. И дальше уже по обстоятельствам поступаю.

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.