LINUX.ORG.RU

[gentoo][ati]Mesa 7.7


0

0

Сегодня решил обновиться, а обновление блокируется из-за mesa-7.7
Сейчас стоит 7.5

Как-то на лоре была тема, где Сильви мне предложила замаскировать пакеты:
Не работали иксы. Драйверы catalyst 9.12.
pasha@pashazz ~ % cat /etc/portage/package.mask/x11 [0:07:41]

=x11-apps/xinput-1.5.0

=x11-base/xorg-drivers-1.7

=x11-base/xorg-server-1.7.0

=x11-libs/libdmx-1.0.99.0

=x11-libs/libX11-1.2.99.0

=x11-libs/libXext-1.0.99.0

=x11-libs/libXi-1.2.99.0

=x11-libs/libXinerama-1.0.99.0

=x11-libs/libXScrnSaver-1.2.0

=x11-libs/libXtst-1.0.99.0

=x11-libs/libXxf86dga-1.1

=x11-libs/libXxf86vm-1.0.99.0

=x11-proto/bigreqsproto-1.1

=x11-proto/dmxproto-2.2.99

=x11-proto/fixesproto-4.1

=x11-proto/inputproto-1.9.99

=x11-proto/recordproto-1.13.99.0

=x11-proto/scrnsaverproto-1.2.0

=x11-proto/xcmiscproto-1.2.0

=x11-proto/xextproto-7.1.1

=x11-proto/xf86bigfontproto-1.2.0

=x11-proto/xf86dgaproto-2.1

=x11-proto/xf86driproto-2.1.0

=x11-proto/xf86vidmodeproto-2.3

=x11-proto/xineramaproto-1.2

pasha@pashazz ~ %

Сейчас все работает, но обновление блокируется из-за этих замаскированных пакетов. Поэтому вопрос? работает ли mesa 7.7, Catalyst 9.12 под гентой? P.S.

media-libs/mesa Available versions: 7.5.1 7.5.2 (~)7.6.1 (~)7.7-r1

Installed versions: 7.5.2(18:57:22 01.01.2010)(nptl xcb -debug

x11-base/xorg-server Available versions: 1.5.3-r6 1.6.3.901-r2 1.6.5-r1 1.6.5-r2[1] [m](~)1.7.4 Installed versions: 1.6.5-r2[?](18:57:47 01.01.2010)(hal nptl sdl xorg -debug -dmx -ipv6 -kdrive -minimal -tslib) Homepage: http://xorg.freedesktop.org/ Description: X.Org X servers

Кастую сильви в тред. Сорри за многабукаф.

★★★★

Временное решение - маскировка mesa. Не подходит.
Ох уж эта гента...

pashazz ★★★★ ()
Ответ на: комментарий от unixway

для сборки, если собирается что-либо в чьих зависимостях стоит GL, то эмерж автоматом делает eselect opengl set xorg-x11 и собирает с мезой,
после делается opengl set nvidia назад

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

Погоди-ка... Неужели чему-либо использующему libGL важна реализация самой libGL (mesa или нет).Для сборки нужны только заголовки? И зачем переключать?

unixway ()
Ответ на: комментарий от unixway

вот заголовки и переключает, а заодно и libGL.so на всякий случай, runtime API конечно стандартный, но есть вещи , которые не собираются с заголовками
<GL/*> от нвидии, у ATI - не в курсе.
Mesa - открытая реализация, поэтому собирать с ней вполне естественно.

Sylvia ★★★★★ ()

Посмотрите, кто требует месу:
equery d media-libs/mesa
Снесите лишнее (можно предварительно сделать бинарный пакет - quickpkg ИМЯ_ПАКЕТА). Обновите систему. Установите снесенные пакеты.

andreyu ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.