LINUX.ORG.RU

Плавность анимации интерфейса arch & gentoo


0

1

Проблема в следующем - анимация, например всплывающих плазма-уведомлений в арче более плавная чем в генте, «smooth scroll» в браузерах тоже не тормозит. Ставил одинаковые версии иксов и нвидиа-дров - не помогло.
Что я делаю не так?

media-libs/mesa-7.11  USE="classic egl llvm nptl shared-glapi -bindist -debug -gallium -gbm -gles -motif -openvg -pax_kernel -pic (-selinux) -shared-dricore" VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0

x11-base/xorg-server-1.11.2  USE="nptl udev xorg -dmx -doc -ipv6 -kdrive -minimal -static-libs -tslib -xnest -xvfb"
x11-drivers/nvidia-drivers-290.06  USE="gtk (multilib) -acpi -custom-cflags"

// версии nvidia-drivers и xorg-server пробовал самые разные.

И да, если отключить эффекты прокрутка в браузере не тормозит, но в арче она и с ними нормально работает.

★★★★★

Попробуй удалить нуово из mesa, и, что было уже сказано, на кой хрен в ней дрова на все случаи ?

SergMarkov ()

У меня меса собрана с такими юзами:
media-libs/mesa-7.11 USE=«classic nptl»
не тормозит.

А почему nvidia-drivers без acpi собрано??

Делал после установки драйвера eselect opengl list и выбрать nvidia??

ymuv ★★★★ ()
Ответ на: комментарий от vitruss

> А зачем столько дров на видео в месе?

Там вообще то минусы стоят.

А ты смотрел как оно собрано в Арче?


Что именно смотреть?

bsdfun ★★★★★ ()
Ответ на: комментарий от ymuv

А почему nvidia-drivers без acpi собрано??

acpi : Adds support for Advanced Configuration and Power Interface

Мне энергосбережение на десктопе не нужно.

bsdfun ★★★★★ ()
Ответ на: комментарий от ymuv

> Делал после установки драйвера eselect opengl list и выбрать nvidia??

Да, игрушки например нормально работают.

bsdfun ★★★★★ ()
Ответ на: комментарий от vitruss

Посмотрел. Я конечно попробую собрать с shared-dricore, но сомневаюсь что это поможет.

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

eselect mesa list

64bit i915 (Intel 915, 945)
64bit i965 (Intel 965, G/Q3x, G/Q4x)
64bit r300 (Radeon R300-R500)
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
64bit sw (Software renderer)
  [1]   classic *
  [2]   gallium
32bit i915 (Intel 915, 945)
  [1]   classic *
  [2]   gallium
32bit i965 (Intel 965, G/Q3x, G/Q4x)
  [1]   classic *
  [2]   gallium
32bit r300 (Radeon R300-R500)
  [1]   classic *
  [2]   gallium
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   classic *
  [2]   gallium
32bit sw (Software renderer)
  [1]   classic *
  [2]   gallium
bsdfun ★★★★★ ()
Ответ на: комментарий от bsdfun

твоюж....ты себя ненавидишь!

[ root@desktop ] megabaks # eselect mesa list
i915 (Intel 915, 945)
i965 (Intel 965, G/Q3x, G/Q4x)
r300 (Radeon R300-R500)
r600 (Radeon R600-R700, Evergreen, Northern Islands)
sw (Software renderer)
[1] classic *
[ root@desktop ] megabaks #

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

> ты убунтушнег

4.2
Ладно, как их оттуда выпилить?

mesa собрана с VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" же

bsdfun ★★★★★ ()

Пересобрал mesa с выпиливанием почти всех юзов кроме classic - не помогло. :(

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> какие движки/темы используются там и там?

Везде QtCurve - одинаковой версии, одинаковые темы, пробовал даже одинаковые папки ~/.kde4 и чистые профили. На генте тормозит, на арче - нет. :(

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> и ядра

Конфиги ядра разные - в арче дистрибутивный + включенное PAE, в генте - свой конфиг. И да, arch - i686 а gentoo amd64.

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> пора Xrender включить

Там нет vsync'a и не все эффекты работают. :(

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

Было выставлено 1000, попробую с 300 собрать (в арче так).

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> ну значит кушай свои 64
раз других отличий нет

Хотя не, собралось вроде дефолтное генкернелское. Пытаюсь собрать с арчевым конфигом. >_<

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> ну значит кушай свои 64

Кстати, если включить «график производительности» и с ним прокручивать страничку в браузере то ничего не тормозит.

bsdfun ★★★★★ ()
Ответ на: комментарий от bsdfun

Апну, мало ли кто нибудь знает что я делаю не так.

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

> ну значит кушай свои 64

Чисто для интереса собрал в чруте x86 - результат такое же. Включаю плагин «Show FPS» в квине/выставляю XRender/выключаю эффекты - прокрутка плавная.

bsdfun ★★★★★ ()
22 декабря 2011 г.
Ответ на: комментарий от bsdfun

Возможно проблема как раз и в Энергосбережении видюхи, надо смотреть на каких частотах работает, если на минимальных то интерфйс будет тупить....а то так можно компилять то потери пульса мир))))

valek2282 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.