LINUX.ORG.RU

после запуска Х не реагирует

 , ,


0

1

Ноутбук АСЕR, nvidia 630m. После startx запускается xfce, но тачпад и мышь не работают. Файла xorg.conf нет и папка xorg.conf.d пустая. C конфигом от nvidia-xconfig вообще не стартует из-за ошибки No screens found. xorg.log здесь // lspci здесь

[I] x11-base/xorg-drivers
     Available versions:  1.19 (~)1.20 **9999 {INPUT_DEVICES="elographics evdev joystick keyboard libinput mouse synaptics tslib vmmouse void wacom" VIDEO_CARDS="amdgpu ast dummy fbdev freedreno geode glint i915 i965 intel mga newport nouveau nv nvidia omap qxl r128 radeon radeonsi siliconmotion tdfx tegra vc4 vesa via virtualbox vmware voodoo"}
     Installed versions:  1.20(07:25:37 PM 07/03/2018)(INPUT_DEVICES="evdev -elographics -joystick -keyboard -libinput -mouse -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="i915 intel nvidia -amdgpu -ast -dummy -fbdev -freedreno -geode -glint -i965 -mga -nouveau -nv -omap -qxl -r128 -radeon -radeonsi -siliconmotion -tdfx -tegra -vc4 -vesa -via -virtualbox -vmware -voodoo")
     Homepage:            https://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers

[I] x11-base/xorg-server
     Available versions:  1.19.5-r2(0/1.19.5) (~)1.20.0(0/1.20.0) **9999(0/9999) {debug dmx doc +glamor ipv6 kdrive libressl minimal selinux static-libs +suid systemd tslib +udev unwind wayland xcsecurity xephyr xnest xorg xvfb}
     Installed versions:  1.20.0(0/1.20.0)(08:15:00 PM 07/03/2018)(udev xorg -debug -dmx -doc -glamor -ipv6 -kdrive -libressl -minimal -selinux -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb)
     Homepage:            https://www.x.org/wiki/ https://cgit.freedesktop.org/
     Description:         X.Org X servers
 


Ответ на: комментарий от kostik87

libinput и synaptics были до этого, с соответствующей пересборкой. но лог был такой

[     5.557] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (EE) No input driver matching `libinput'
[     5.558] (II) Falling back to input driver `libinput'
[     5.558] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event10)
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "libinput touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "libinput touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     5.558] (II) LoadModule: "synaptics"
[     5.558] (WW) Warning, couldn't open module synaptics
[     5.558] (EE) Failed to load module "synaptics" (module does not exist, 0)
[     5.558] (EE) No input driver matching `synaptics'
[     5.558] (II) Falling back to input driver `libinput'
[     5.558] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
[     5.559] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[     6.016] (II) modeset(0): EDID vendor "LGD", prod id 732
[     6.016] (II) modeset(0): Printing DDC gathered Modelines:
[     6.016] (II) modeset(0): Modeline "1366x768"x0.0   70.00  1366 1402 1450 1492  768 771 776 782 -hsync -vsync (46.9 kHz eP)
[   103.797] (II) Server terminated successfully (0). Closing log file. 

parar ()

Для начала я бы пересобрал:

x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-libinput
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-synaptics

vvn_black ★★★★★ ()
Ответ на: комментарий от parar

Ну значит не установлены пакеты с драйверами.

Посмотри что есть здесь:/usr/lib64/xorg/modules и в поддиректории.

А так же посмотри что в

emerge eix
eix-update
eix -i input

kostik87 ★★★★★ ()

Я бы воткнул одну мышь в COM1, другую в PS/2, третью в USB, ну и клавиатур несколько докучи, и посмотрел бы, кто из них работает.

Bass ★★★★★ ()

Попробуй создать файлы /etc/X11/xorg.conf.d/keyboard.conf:

# Keyboard settings
Section "InputClass"
  Identifier  "keyboard"
  Driver  "evdev"
  Option  "Protocol" "event"
  MatchIsKeyboard "1"
  Option "XkbLayout" "us,ru"
  Option "XkbOptions" "grp:caps_toggle,grp_led:scroll,compose:ralt"
EndSection

/etc/X11/xorg.conf.d/touchpad.conf:

# touchpad
Section "InputClass"
  Identifier  "Synaptics"
  Driver  "synaptics"
  MatchIsTouchpad "1"
  Option  "Protocol" "event"
  Option  "TapButton1" "1"
  Option  "TapButton2" "2"
  Option  "TapButton3" "3"
  Option  "CircularScrolling" "1"
EndSection

/etc/portage/make.conf или где там у тебя:

INPUT_DEVICES="evdev synaptics"

Пересобери x11-base/xorg-drivers:

emerge -av1 x11-base/xorg-drivers

kickass ()
Ответ на: комментарий от kickass

Если мышь usb, то в ядре нужно включить:

CONFIG_HID=m
CONFIG_HID_GENERIC=m
CONFIG_USB_HID=m

А также для evdev, ps/2 и usb:

CONFIG_INPUT=y
CONFIG_INPUT_MOUSEDEV=y
CONFIG_INPUT_EVDEV=y
CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
CONFIG_INPUT_MOUSE=y
CONFIG_MOUSE_PS2=y

kickass ()

У меня так было в Fedora 9, в которой X-Server 1.7 собран с поддержкой HAL, если перед стартом «иксов» сделать так:

# /etc/init.d/hal stop

Но сейчас же «иксы» переведены на udev, и такого не должно быть.

> папка xorg.conf.d пустая

Где-то в /usr/share тоже должны быть файлы.

equery f xorg-server | grep conf
equery f xorg-drivers | grep conf

Я присоединяюсь к версии, что USE-флаг libinput тоже надо разрешить - возможно что в Gentoo «переезжают» с libudev на него. Хотя стоп! На Опеннете же была новость о том, что драйвер synaptics начиная с какой-то версии перестанет поддерживать libudev, а только libinput! Тогда почему не работает клавиатура... Может, evdev тоже? Посмотри ChangeLog-и, и если это так, то укажи конкретную. версию ебилда при установке:

emerge -av =x11-drivers/xf86-input-evdev-9.87.65

Кстати, у тебя же Optimus? Ты настроил через Bumblebee, или через NVIDIA PRIME? Если через второе, то вот тебе моя инструкция по настройке: NVIDIA Prime на не-Ubuntu

Там нужно создавать xorg.conf и вносить изменение в GDM (или в то, что у тебя вместо него). А также собрать xorg-server с поддержкой glamor:

Если у вас Source-based дистрибутив Linux, вы обязаны собрать X-Server с поддержкой Glamor, но не использовать эту технологию от Intel. Лично для меня это стало подводным камнем: компилируя систему, я выключил USE-флаг «glamor». Слишком умный: знал что это такое, знал что NVIDIA это не поддерживает - ну и зачем тогда это собирать? А потом не понимал, почему ничего не работает.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от vvn_black

Все input драйвера были собраны, пересобрал, вроде как помогло. А я-то думал, что раз они установлены, то и нефиг их трогать. Всем спасибо за ответы, вот бы моей системе такую отзывчивость. На всякий случай

/usr/lib64/xorg/modules/:
drivers
extensions
libexa.so
libfbdevhw.so
libfb.so
libint10.so
libshadowfb.so
libshadow.so
libvbe.so
libvgahw.so
libwfb.so
/usr/lib64/xorg/modules/drivers:
modesetting_drv.so
/usr/lib64/xorg/modules/extensions:
libglx.so 
Клаву и тачпад настрою, а обязательно INPUT_DEVICES=«evdev synaptics»? Можно обойтись evdev или libinput?

Из /usr/share/ я убрал *.conf из-за проблем (лог в моем 2м посте)

Через Bumblebee или NVIDIA PRIME не настраивал, сейчас даже не представляю что это и нужно ли мне

А эта проблема наверное не связана с темой

# glxinfo 
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig 

parar ()
Ответ на: комментарий от parar

а обязательно INPUT_DEVICES=«evdev synaptics»?

Если touchpad без synaptics работает, то только:

INPUT_DEVICES="evdev"
достаточно. libinput не нужен.

kickass ()
Ответ на: комментарий от parar

пересобрал, вроде как помогло

Потому что это был твой случай.

Как подсказка, чтоб не вспоминать, что из иксовых драйверов пересобирать:

# qlist -IC x11-drivers

vvn_black ★★★★★ ()
Ответ на: комментарий от parar

Ты видимо в начале собрал xorg-server-1.19.5-r2 и драйверы к нему. А потом установил xorg-server-1.20.0, а драйверы не пересобрал.

Вот и проблема.

kostik87 ★★★★★ ()
Ответ на: комментарий от Bass

Я бы воткнул одну мышь в COM1

Отсыпь мне таких мышей, а? У меня есть одна, но то ли сдохла она, то ли порт, а других девайсов, чтобы это проверить, у меня нет.

r3lgar ★★★★★ ()
Ответ на: комментарий от Bass

С шариком.

Я других serial-мышей и не встречал.

r3lgar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.