LINUX.ORG.RU

RX 480 + AMDGPU + Ubuntu 16.04 = Нет OpenGL

 , , , ,


0

1

Купил я значит таки свою первую карту от AMD, как вы наверное уже могли догадаться по заголовку... Ладно, это все лирика, к делу. В дефолтном ядре 4.4 не было поддержки карт Polaris, поэтому я поставил ядро 4.8 из 16.10, после чего amdgpu завелась. А вот OpenGL нет. Вот что говорит glxinfo:

0$ glxinfo | grep OpenGL
pci id for fd 4: 1002:67df, driver (null)
pci id for fd 5: 1002:67df, driver (null)
libGL error: failed to create dri screen
libGL error: failed to load driver: radeonsi
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.2.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Буду благодарен за подсказку куда копать.

★★★

cast r3lgar.
Можешь что-то подсказать на этот счет?

Andrew ★★★ ()
Ответ на: комментарий от Andrew

cast r3lgar.

Я подписан на теги amdgpu и radeonsi.

Можешь что-то подсказать на этот счет?

С amdgpu я только теоретик, так как поддержку GCN 1.0 в ядро ещё не завезли — моя катрочка не работает с.

Novell-ch должен в этом разбираться лучше. Ещё можно позвать slon. А возможно они оба подписаны на теги и придут сами.

r3lgar ★★★★★ ()

для начала надо глянуть на логи xorg

x4DA ★★★★★ ()

поэтому я поставил ядро 4.8 из 16.10

Практика показывает, что с убунтой так делать не надо... Лично моя практика. Отваливаются вещи.

targitaj ★★★★★ ()
Ответ на: комментарий от targitaj

Ну тащемта это официальная фича. Да и выхода другого не было.

Andrew ★★★ ()

Однозначно обновлять Xorg и Mesa до последних релизов, у тебя всё слишком старое.

anonymous ()

Для поляриса Mesa 13 н-н-нада... Сам убунту не пользуюсь, но насколько знаю, вам в oibaf или в padoka ppa за свежими пакетами идти нужно. Ну накатывать amdgpu-pro, или ждать n месяцев, пока свежую мезу официально портируют.

Khnazile ★★★★ ()

lspci -k на карте покажи.

И сразу со старта пробуй 4.9 ядро, меса 13+ и самые свежие linux-firmware и libdrm.

Но я бы тебе посоветовал поставить amdgpu-pro — и не знать проблем, в том числе с opencl, а не только opengl.

slon ()
Последнее исправление: slon (всего исправлений: 1)

Обновил Mesa до 13.0, OpenGL заработал. Пробовал также поставить AMDGPU-PRO, но при попытке собрать модуль под ядро 4.8 dkms валился с ошибкой (гугл говорит, что он поддерживает до 4.7 включительно или надо трахаться с патчами, пересбором либ и прочей фигней). Rocket League при попытке запуститься артефачит мне весь экран и приходится убивать процесс (на невидии оно тоже хреново шло, лагало, но хотя бы запускалась). Надо проверить еще несколько игр.

Andrew ★★★ ()
Ответ на: комментарий от Andrew

игр

Понина, юзай дуалбут. На линуксе игорь тонет.

Deleted ()
Ответ на: комментарий от Behem0th
~$ glxinfo | grep Open
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD POLARIS10 (DRM 3.3.0 / 4.8.0-32-generic, LLVM 3.9.0)
OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.2 - padoka PPA
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 13.0.2 - padoka PPA
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.2 - padoka PPA
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

У меня не гитовская версия месы, а последняя стабильная. Может там появилась поддержка OpenGL 4?

Andrew ★★★ ()
Ответ на: комментарий от Andrew

В мезе не осилили (и не собираются осиливать) compatibility profile выше 3.0

Khnazile ★★★★ ()
Ответ на: комментарий от Andrew

Может там появилась поддержка OpenGL 4?

У тебя уже OpenGL core profile version string: 4.3

В следующей версии месы будет 4.5. Компатибилити профиль для даунов.

Behem0th ★★★★★ ()
Последнее исправление: Behem0th (всего исправлений: 1)
Ответ на: комментарий от Khnazile

не осилили

Разумно рассудили что это говно ненужно.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Еще как нужно для кучи ынтерпрайз-программ, а так же для wine и прочих непотребств.

Khnazile ★★★★ ()
Ответ на: комментарий от Andrew

Купил я значит таки свою первую карту от AMD

Ну, как вам ощущения?

alexferman ()
Ответ на: комментарий от Khnazile

непотребств

Ты сам же ответ даешь. В вине уже 1000 лет хотят перейти на кор профиль.

Behem0th ★★★★★ ()
Ответ на: комментарий от Khnazile

В мезе не осилили (и не собираются осиливать) compatibility profile выше 3.0

$ MESA_GL_VERSION_OVERRIDE=4.3COMPAT glxinfo
...
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD BONAIRE (DRM 2.48.0 / 4.9.0-gentoo, LLVM 3.9.1)
OpenGL core profile version string: 4.3 Mesa 13.0.2
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: compatibility profile
...
OpenGL version string: 4.3 Mesa 13.0.2
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
anonymous ()
Ответ на: комментарий от anonymous

Эта штука заставляет мезу притвориться что поддержка есть, а по факту возможна куча негативных последствий, от неправильного рендеринга до вылета сразу после запуска.

Khnazile ★★★★ ()
Ответ на: комментарий от Behem0th

Они много чего хотят уже 1000 лет, но в суровой реальности все это до сих пор не готово.

Khnazile ★★★★ ()
Ответ на: комментарий от Khnazile

Эта штука заставляет мезу притвориться что поддержка есть, а по факту возможна куча негативных последствий, от неправильного рендеринга до вылета сразу после запуска.

Не сталкивался с подобным.

anonymous ()
Ответ на: комментарий от anonymous

А не все программы, которые требуют compatibility profile по факту его создают. Некоторые сначала при инициализации проверяют, доступен ли compat, а потом создают, внезапно, core profile. Быдлокодерство оно очень многогранно. Этот хак предназначен именно для такого софта.
Кстати, бывает и на оборот: проверяют версию core, а по факту пытаются создать и работать в compat.

Khnazile ★★★★ ()
Ответ на: комментарий от Andrew

32-битные версии пакетов-то установил? Еще может понадобиться libtxc-dxtn, или как его там зовут в убунте, без него половина текстур будут черными.

Khnazile ★★★★ ()
Ответ на: комментарий от Andrew

А я телепат? Ты хоть по приколу информации какой подкинь. Как не работает, что в консоль пишет.

Behem0th ★★★★★ ()
Ответ на: комментарий от Andrew

Rocket League при попытке запуститься артефачит мне весь экран

Если ты про статичный экран, разбитый на квадратики с мусором, то надо ждать. Долго. Шейдеры компилируются очень неторопливо, и так будет при каждом запуске игры, потому что кэша на диске все еще не завезли.

Khnazile ★★★★ ()
Ответ на: комментарий от Andrew

ETS2 не работают?

С ним кстати что? ЕМНИ он еще на 3.3 нормально игрался.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

УМВР, но на 3.3 он игрался гораздо быстрее и веселее. Правда я не уверен, где производительность поломали, в мезе или в самой игре.

Khnazile ★★★★ ()
Ответ на: комментарий от Khnazile

У меня (7950) практически с самого выхода производительность постепенно увеличивалась. В самом начала на минималках было неиграбельно.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

В самом начале там даже на fglrx был адовый ад, потом исправили апдейтами. Но лично у меня сейчас 13-15 фпс если смотреть «из кабины», и от 28 до 45 если с видом над крышей. Преломление света на стеклах как-то дико бьет по производительности. По уму, надо писать баг-репорт, но мне лень проверять, проблема ли это только мезы, или на других драйверах тоже самое.

Khnazile ★★★★ ()
Ответ на: комментарий от Khnazile

У меня раньше были какие различия в производительности при разных видах. Потом помню поправили и сейчас разница есть но не так заметна. Но я не знаю что именно помогло в тот период пока я не проверял были и апдейты месы и игры.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

У меня процессор довольно слабый, phenom II 3.2ГГц, это сильно сказывается на минимальном фпс во всех играх. У меня и в cs:go просадки ниже 40фпс на минимальных настройках, хотя в win7 эта же машина тащит больше сотни. Такие дела.

Khnazile ★★★★ ()
Ответ на: комментарий от Khnazile

Да ктож спорит что линукс гейминг печальнее чем на офтопике.

Behem0th ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.