LINUX.ORG.RU
ФорумTalks

Встречаем OpenGL 3.1 на открытых дровах amd

 , , ,


0

4

Ну вот и запилили, прогресс как говорится идет, пусть и с опозданием почти в 4 года, но с приходом валве и стима на линукс, ждем и надеемся на лучшее.

glxinfo |grep OpenGL
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
OpenGL version string: 3.0 Mesa 9.1-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1-devel
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
★★★★★

Раз ускорились в Mesa и в драйверах, значит есть надежда на то, что лет через 5 можно будет обходться воообще без блобов во всём.

Quasar ★★★★★ ()

Какая там производительность по сранению с закрытыми на windows драйверами?

GanGSISoft ★★ ()
Ответ на: комментарий от GanGSISoft

от игры зависит, в общем почти все линуксовое тянет нормально на картре 6770, HoN так вообще на максимуме в 1920 выдает уже стабильно 50-60 фпс, месяца 4-5 назад было от силы 35. Пилят по тихому, то ту плюшку добавят то эту.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

а кто их пилит? только сообщество из случайных людей?, или amd помогает?

GanGSISoft ★★ ()
Ответ на: комментарий от GanGSISoft

вроде 4 человека на фуллтайме за деньги амд, и всякие энтузиасты.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

всякие энтузиасты.

Не смей Марека всяким называть! :)

Behem0th ★★★★★ ()

Что-то я не понял. Вроде как всю жизнь версию OpenGL смотрели по этой строке:

OpenGL version string: 3.0 Mesa 9.1-devel
Да и, тем более, что-то не верится, что реализация для карт AMD вышла раньше, чем для карт Intel.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Да и, тем более, что-то не верится, что реализация для карт AMD вышла раньше, чем для карт Intel.

Почему? Они ж совсем разные, интел классический драйвер пилит, а амд в галлиуме. Могли и обогнать.

risenshnobel ★★★ ()
Ответ на: комментарий от risenshnobel

Почему? Они ж совсем разные, интел классический драйвер пилит, а амд в галлиуме. Могли и обогнать.

Всё смешалось...

Галлиум / классика — это особого отношения к 3D не имеет, ибо реализация 3D — это Mesa.

carasin ★★★★★ ()

Это как-нибудь повлияет на тим фортресс и сериус сэма из стима?

bender ★★★★★ ()
Ответ на: комментарий от bender

а что там влиять? ТФ2 уже более 20 часов наиграно, именно на открытых дровах

Novell-ch ★★★★★ ()
Ответ на: комментарий от carasin

так для интела вышло в 9, только для ивиков же вроде, ну или glxinfo не показывает, его нужно патчить, что бы Core Profile ловил.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

Sandy Bridge умеет OpenGL 4.X, но на Mesa 9.0 показывается только 3.0. А т.к. Ivy Bridge мало чем отличается от Sandy Bridge, то, думаю, в Intel'е не стали бы реализовывать OpenGL 3.1 только для Ivy. А вообще, помнится, что Mesa 9.1 должна привнести OpenGL 3.1, в первую очередь, именно для карточек Intel, а в последующих версиях — даже 4.X, ибо OpenGL 3.3 мало в чём отличается от того же 4.0 (дескать, нехрен выпускать отдельную версию Mesa с реализацией 3.3, если можно сразу 4.X).

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Это из-за glxinfo и спецификаций, 3.1 давно уже готов, как и 3.3. Только несколько необходимых для 3.2 пунктов остались.

Вот тебе release notes от 9.0.

Lighting ★★★★★ ()
Последнее исправление: Lighting (всего исправлений: 1)
Ответ на: комментарий от Lighting

Дык в том-то и дело, что всего из-за пары функций нельзя сказать, что OpenGL версии 3.X готово.

А по поводу именно 3.1: оно готово в рамках Mesa 9.1 или всё же ещё в 9.0? ЕМНИП, в 9.0 полностью реализовано только 3.0.

carasin ★★★★★ ()
Ответ на: комментарий от Lighting

Mesa 9.0 implements the OpenGL 3.1 API, but the version reported by glGetString(GL_VERSION) or glGetIntegerv(GL_MAJOR_VERSION) / glGetIntegerv(GL_MINOR_VERSION) depends on the particular driver being used. Some drivers don't support all the features required in OpenGL 3.1. OpenGL 3.1 is only available if requested at context creation because GL_ARB_compatibility is not supported.

Суть примерно ясна.

carasin ★★★★★ ()
Ответ на: комментарий от Quasar

уже в 15 году. а в лучшем случае с приходом хд9000 будут достаточно мелкие недочёты.

Thero ★★★★★ ()
Ответ на: комментарий от Quasar

есть надежда на то, что лет через 5 можно будет обходться воообще без блобов во всём

I_want_to_believe.tga

x0r ★★★★★ ()
Ответ на: комментарий от bender

да, но в немного по другим причинам, которые правда полнценно будут только в ядре 3.9 и мезе 9.1\10

Thero ★★★★★ ()

Ну вот, глядь через годик переползу на открытые дрова.

Dron ★★★★★ ()
Ответ на: комментарий от carasin

Впервые такое слышу. О том что в следующем релизе месы будет скорей всего поддержка 3.3, так как между 3,2 и 3,3 уже почти все готово. А вот для 4.0 не так уж и много сделано.

Behem0th ★★★★★ ()

В убунте уже есть? Сегодня ноутбук обновлял, вроде не прилетели.

olibjerd ★★★★★ ()
Ответ на: комментарий от carasin

Галлиум / классика — это особого отношения к 3D не имеет, ибо реализация 3D — это Mesa.

gallium - новая архитертура драйверов в Mesa, наряду с «классической», т.е. к 3D имеет отношение чуть более, чем полностью

frame ★★★ ()
Ответ на: комментарий от frame

Да, признаю — сфейлил. Теперь уже восполнил пробел.

carasin ★★★★★ ()
Ответ на: комментарий от Thero

Вам просто повезло с картой. У меня только на проприентарщине взлетало.

whiskydotjar ()
Ответ на: комментарий от whiskydotjar

ну да я специально брал 6670 с которой всё хорошо.

Thero ★★★★★ ()

Ну глядишь когда GCN выкинут на помойку истории вместе с поддержкой блоба, VLIW4/5 смогут в свою полную силу на открытых дровах крутиться :D

erfea ★★★★★ ()
Ответ на: комментарий от erfea

Ну глядишь когда GCN выкинут на помойку

Слишком оптимистично, скорее через пару лет после выкидывания.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Ну мы же надеемся на лучшее ;) ЗЫ сделали бы уже KMS в блобе или занялись бы вплотную открытым драйвер (мне второй вариант нравится больше, но он не особо реалистичен), распыляют силы только.

erfea ★★★★★ ()

А пробовал кто-нибудь интеловский glamor на r600g?

feofan ★★★★★ ()
Ответ на: комментарий от Behem0th

Жаль. На форониксе пишут, что работает, но медленно. Видимо, код еще сырой. Потыкаю, если время появится.

feofan ★★★★★ ()
Ответ на: комментарий от feofan

[code]
[ 123.629] (II) Module «dri2» already built-in
[ 123.629] (II) Loading sub module «glamoregl»
[ 123.629] (II) LoadModule: «glamoregl»
[ 123.629] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[ 123.629] (II) Module glamoregl: vendor=«X.Org Foundation»
[ 123.629] compiled for 1.13.1, module version = 0.5.0
[ 123.629] ABI class: X.Org ANSI C Emulation, version 0.4
[ 123.629] (II) glamor: OpenGL accelerated X.org driver based.
[ 123.834] (II) glamor: EGL version 1.4 (DRI2):
[ 123.932] (II) RADEON(0): glamor detected, initialising EGL layer.
[/code]
завелся с пол пинка, хотя раньше не работал, вечно жаловался на llvm и прочее.
прогнал qtperf4 0.2233 против 0.2187 в пользу еха.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

Здорово, как я писал выше у меня вообще не заводилось, радует что есть прогресс.

0.2233 против 0.2187 в пользу еха.

Считаю различие незначительным. С X.Org стей трекером у меня разница была в несколько раз + глюки. Может у меня и radeonsi заведется когда соберусь проверить.

Behem0th ★★★★★ ()
Ответ на: комментарий от Novell-ch

И, да, на профиле low жить можно(именно с гламуром)? Или всё будет тормозить? Просто, у меня бук...

feofan ★★★★★ ()
Ответ на: комментарий от feofan

А чем стандартный вариант не устраивает? Ищешь приключения? Тогда пробуй сам отпишись а не спрашивай на форумах.

Behem0th ★★★★★ ()

А температура ноутбука с ними до сих пор как в аду?

emissar ★★ ()
Ответ на: комментарий от Behem0th

А вдруг я не первый такой? Время будет - попробую. По результатам отпишусь

feofan ★★★★★ ()
Ответ на: комментарий от emissar

Ставишь профиль low и температура как на блобе. Но для игр нужен high, да

feofan ★★★★★ ()
Ответ на: комментарий от feofan

Ставишь профиль low и температура как на блобе. Но для игр нужен high, да

Я не знаю, какая версия драйвера в убунте из коробки, но позавчера пробовал low этот, температура на 7-10 градусов выше, чем с проприетарным. Или в этой версии хоть как-то это оптимизировали?

emissar ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.