LINUX.ORG.RU

Mesa и OpenGL - Radeon R9 290

 , ,


0

2

Моя видеокарта поддерживает opengl 4.x,но в mesa только 3 opengl и даже не 3.3

OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD HAWAII OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.3 OpenGL core profile shading language version string: 3.30 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 10.5.3 OpenGL shading language version string: 1.30 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.3 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00 OpenGL ES profile extensions:

Что можно с этим сделать(как включить 3.3 opengl в mesa)

OpenGL core profile version string: 3.3 (Core Profile)

нужна меса посвежее и llvm 3.7+

Novell-ch ★★★★★ ()
Ответ на: комментарий от Nemial

Тем более у меня и на 11 mesa такая же байда 3 opengl, хотя mesa поддерживает 4

Nemial ()

...хоть бы дистр озвучил

вангую, что debian

Google_Play ()
Ответ на: комментарий от Nemial

mesa 10.5.3 и llvm 3.5

Тебе уже сказали что обновлять.

anonymous ()
Ответ на: комментарий от anonymous

И еще уточнение, когда я обновляю все это дело, то у меня все равно opengl 3(а не 4) и значит мне надо применять команду MESA_GL_VERSION_OVERRIDE=4.1COMPAT

Nemial ()
Ответ на: комментарий от Nemial

COMPAT

А он больше 3.0 в месе никогда и не будет. Только кор профиль, который для твоей видюхи 4.1. И зачем тебе версия опенгла?

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Фишка в том, что у меня в mesa 11, видеокарта поддерживает все тот же 3 opengl, но не 4(который в mesa есть). Да, и что значит сама команда MESA_GL_VERSION_OVERRIDE и какие у неё возможности(можете просвятить). А обновлять буду до mesa 11.0.6 и llvm 3.7

Nemial ()
Ответ на: комментарий от Nemial

MESA_GL_VERSION_OVERRIDE просто заставляет драйвер врать о поддержке указанной версии opengl, иногда работает, если программа использует новые фичи только частично.

anonymous ()
Ответ на: комментарий от Nemial

Фишка в том,

вывод glxinfo | grep Open выложи с 11 месой

Да, и что значит сама команда

Как я понимаю просто меняет циферки в выводе.

Behem0th ★★★★★ ()
Ответ на: комментарий от Nemial

Ну и в чем проблема?

OpenGL core profile version string: 4.1 (Core Profile)

OpenGL 4.1 (Core Profile)

Как я говорил выше, компатибилите профиль в месе не будет выше 3.0.

OpenGL version string: 3.0

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

А можно по-русски и чуть чуть по проще получается эта строчка OpenGL version string: 3.0 - это версия компатибилите профиль а вот эта строчка - OpenGL core profile version string: 4.1 (Core Profile) показывает какой opengl поддерживает моя карта, или я не правильно все понял?

Nemial ()
Ответ на: комментарий от Nemial

Я не программист и ситуацию вижу так. В OpenGL 3.0 часть функций объявили устаревшими и сказали что в следующей версии их выкинут. В 3.1 так и сделали но дали возможность использовать эти функции в компатибилити профиле. Меса разработчики сказали что компатибилити профиле максимальная верси OpenGL останется 3.0 и выше развивать не будут. Так что для твоя видюха с меса драйвером поддерживает на данный момент OpenGL 4.1(кор профиль) и в компатибилити профиле OpenGL 3.0/

Проще говоря смотри на кор профиль, он будет меняться когда в месе реализуют новые версии.

Behem0th ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.