LINUX.ORG.RU

Установка двух одинаковых библиотек, собранных с разными флагами

 ,


0

1

Доброго времени суток!

Каким образом в gentoo можно установить две версии одной и той же библиотеки, собранные с разными флагами? Пробовал в разные слоты запихнуть, но у меня это получилось только с разными версиями программ.

Во время установки root.cern 6.00.02 обнаружились следующие проблемы:

dev-haskell/resourcet:0

  (dev-haskell/resourcet-1.1.2.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-haskell/resourcet-1.1:=[profile?] required by (dev-haskell/conduit-1.1.6::gentoo, ebuild scheduled for merge)

  (dev-haskell/resourcet-0.4.9::gentoo, ebuild scheduled for merge) pulled in by
    <dev-haskell/resourcet-0.5:=[profile?] required by (dev-haskell/http-conduit-1.9.5.1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.1-r5::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.5::gentoo, ebuild scheduled for merge)

  (dev-libs/libxml2-2.9.1-r4::gentoo, installed) pulled in by
    dev-libs/libxml2:=[icu] required by (www-client/chromium-37.0.2062.94::gentoo, installed)
    dev-libs/libxml2:2/2=[icu] required by (www-client/chromium-37.0.2062.94::gentoo, installed)

Или с таким лучше сразу в bugzilla?

★★

Есть ли способ это сделать без маскировки пакетов? Грубо говоря, нужные версии нужных библиотек установить в отдельные папки, а потом в флагах к emerge указать откуда брать нужные версии (какие флаги за это отвечают?).

Есть еще вариант - насильно сказать emerge, чтобы использовала уже установленные библиотеки. Только опять же - как?

aido ★★ ()

Это возможно, только если сама библиотека поддерживает такое, в общем случае.

Олсо, поставь тег gentoo.

devsdc ★★ ()

А у тебя, вообще говоря, решение проблемы другое (если проблема только в том, что ты выложил в стартовом посте).

Насколько я помню, по идеологическим причинам chromium и qtwebkit вечно спорят друг с другом на тему icu. Решение этой проблемы я, вроде, читал на каких-то релейтед вики, советую погуглить.

А хаскель нужно просто нормально обновить.

devsdc ★★ ()

Установка двух одинаковых библиотек, собранных с разными флагами

Да есть отдельные компоненты которые поддерживают сабж и им плевать. То чего ты хочешь в общем и целом ненормально… Но а вообще то тебе никто не запрещает делать ROOT=${НУ_ТЫ_ПОНИЛ} emerge <пяпяка> если этого ну уж так тебе хочется.

init_6 ★★★★★ ()
Ответ на: комментарий от kostik87

О! здорово, вроде помогло! Компиляция началась.

aido ★★ ()
Ответ на: комментарий от aido

У меня эта переменная из-за хаскеля в 50 прописалась :)

А до r-studio вообще не знал такой опции :)

Stil ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.