LINUX.ORG.RU

kde5 chromium qtwebkit конфликт зависимостей

 , , ,


2

2

при попытки установить chromium произошел конфликт зависимостей в системе:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.2-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:=[icu] required by (www-client/chromium-46.0.2490.71:0/0::gentoo, ebuild scheduled for merge)
                       ^^^                                                                                                                            

  (dev-libs/libxml2-2.9.2-r1:2/2::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,
abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] 
required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
                       ^^^^^                                                   

система предлагает решить проблему с помощью package.mask, т.е. мне нужно замаскировать dev-qt/qtwebkit-4.8.6-r1:4/4 ?


А если установить libxml2 с включенным icu, не исчезнет ли конфликт?

annulen ★★★★★ ()

chromium требует dev-libs/libxml2 с флагом icu.

Но dev-qt/qtwebkit-4.8.6-r1 требует dev-libs/libxml2 с выключенным флагом icu из-за багов.

# libxml2[!icu?] is needed for bugs 407315 and 411091

Вроде, в qtwebkit-4.10.4 пофиксили.

На первый взгляд всё так.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

а что если установить версию 5.4.2, у меня kde5 это как-то связано?

~ $ eix -l qtwebkit
[I] dev-qt/qtwebkit
     Available versions:  
     (4)
            4.8.5       [aqua debug +exceptions +gstreamer icu +jit pch]
            4.8.6-r1    [aqua debug +exceptions +gstreamer icu +jit pch ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"]
       ~    4.8.7       [aqua debug +exceptions +gstreamer icu +jit pch ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"]
       [M]~ 4.10.4      [debug +gstreamer ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"] Davide Pesavento <pesa@gentoo.org> (23 Jul 2015) Standalone version of qtwebkit from the 2.3 upstream branch. Needs revdep testing. Bug #388207.
     (5)
            5.4.2     ^mt       [debug gstreamer gstreamer010 multimedia opengl printsupport qml test udev webp]
     Installed versions:  4.8.6-r1(4)(00:00:50 13.10.2015)(exceptions gstreamer jit -aqua -debug -icu -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
                          5.4.2(5)^mt(23:51:30 24.10.2015)(opengl qml udev -debug -gstreamer -gstreamer010 -multimedia -printsupport -test -webp)
     Homepage:            https://www.qt.io/
     Description:         WebKit rendering library for the Qt5 framework
lukman ()
Ответ на: комментарий от lukman

Они не зависят друг от друга. Скорее всего, какой-то другой пакет тянет qtwebkit:4 (ты же не ставил его вручную?).

Посмотри:

equery d qtwebkit:4

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

не ставил :)

~ $ equery d qtwebkit:4
 * These packages depend on qtwebkit:4:

ну попробую поставить замаскированный пакет [M]~ 4.10.4

lukman ()
Ответ на: комментарий от lukman

Похоже, что у тебя нет пакетов, которые зависят от qtwebkit:4. Удали его :)

emerge -av --depclean qtwebkit:4
Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от lukman

И похоже, что ты не делаешь периодически чистку системы от ненужных пакетов, которые автоматически ставились, как зависимости.

emerge -av --depclean

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

ох ничего не вышло :(

emerge -av --depclean qtwebkit:4
не захотел удалять этот пакет

emerge -av --depclean

утащил за собой кучу софта кде4, но это не страшно

решил жестко снести

emerge -C qtwebkit:4

теперь начались проблемы с другими пакетами, а chromium так и не хочет ставиться

lukman ()
Ответ на: комментарий от lukman

//_- Как ты до сих пор пользовался гентой?

Начнём с того, что решение снести пакет принудительно было неверным, ведь ты не понимаешь, зачем это делать и какие последствия. Иначе бы ты не снёс.

не захотел удалять этот пакет

Хорошим тоном будет приложить полный текст ошибки.

а chromium так и не хочет ставиться

Опять же, это ни о чём не говорит, нужен полный выхлоп. Телепаты в отпуске.

P.S. Ставь опять qtwebkit:4 и попробуем разобраться, что происходит.

Chaser_Andrey ★★★★★ ()
Последнее исправление: Chaser_Andrey (всего исправлений: 1)
Ответ на: комментарий от Chaser_Andrey

К сожалению лог затерся :( Да, признаю это было радикальное решение. У меня мало опыта работы с гентой. Как-то можно сейчас достать логи?

lukman ()
Ответ на: комментарий от lukman

Тут дело еще в том, что я решил мигрировать на kde5 и понеслась...

lukman ()
Ответ на: комментарий от lukman

Как-то можно сейчас достать логи?

Если не осталось в открытом терминале, то просто переустанови qtwebkit:4 и повтори те же действия (кроме принудительного сноса), и тогда ты получишь логи.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от lukman

Наберись терпения и не спеши. Я знаю, что сборка вебкита медленная. Не успеешь сегодня - сделаем завтра.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от lukman

Оказывается, equery не умеет работать с слотами?..

Вот так должно было показать зависящие пакеты:

equery d =dev-qt/qtwebkit-4.8.6-r1

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

Согласен. Сегодня уже поздно. Результатом жесткого удаления пакета qtwebkit:4 стало то, что я сейчас вообще ни один пакет не могу поставить!:(

например emerge -av =qtwebkit-4.8.6

>>> Failed to emerge dev-qt/qtwebkit-4.8.6-r1, Log file:

>>>  '/var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/temp/build.log'

 * Messages for package dev-qt/qtwebkit-4.8.6-r1:

 * 
 * Using a GCC version lower than 4.4 is not supported.
 * 
 * ERROR: dev-qt/qtwebkit-4.8.6-r1::gentoo failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3205:  Called multilib-minimal_src_configure
 *   environment, line 1988:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2195:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1919:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1917:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  442:  Called multilib-minimal_abi_src_configure
 *   environment, line 1982:  Called multilib_src_configure
 *   environment, line 2412:  Called qt4_multilib_src_configure
 *   environment, line 2921:  Called die
 * The specific snippet of code:
 *       "${S}"/configure "${conf[@]}" || die "configure failed";
 * 
 * If you need support, post the output of `emerge --info '=dev-qt/qtwebkit-4.8.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtwebkit-4.8.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6-abi_x86_64.amd64'
 * S: '/var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.

Вообще какой-то ужас в системе нет ни одного редактора кроме emacs. nano, kwrite похоже слились а переустановить не получается. Ошибки выкидывает примерно такие же что и с qtwebkit.

lukman ()
Ответ на: комментарий от Chaser_Andrey

Да наверное он мне просто ничего не выдал, а я по незнанию подумал, что у этого пакета нет зависимостей и жестко удалил :)

lukman ()
Ответ на: комментарий от Chaser_Andrey

Ух похоже я что-то серьезное сломал, раз пакеты не могут собраться.

lukman ()
Ответ на: комментарий от Chaser_Andrey
~ $ gcc-config -l
 * gcc-config: Active gcc profile is invalid!

 [1] x86_64-pc-linux-gnu-4.9.3

хмммм... профиль поломался :(

lukman ()
Ответ на: комментарий от lukman

Установи

gcc-config 1
Проверь ещё раз.

Если выбралась версия gcc, то попробуй поставить qtwebkit.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от lukman

И ради интереса я бы посмотрел твой /var/log/emerge.log

Только он большой, закинь на какой-то pastebin

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

процесс сборки пошел! так значит все дело было в кривом симлинке, а я и не обращал на это внимание :) спасибо за участие и дельные советы!) пока qtwebkit будет собираться я пожалуй спать.

lukman ()
Ответ на: комментарий от lukman

А, ну вот, 25 числа (вчера) ты снёс gcc-4.8.5. Профиль на новый gcc не переключил (а должен ли он автоматически переключаться, если осталась только одна версия gcc? cast Pinkbyte)

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

Должен. Но я уже сталкивался с случаями когда не переключает, там на этот счёт было какое-то условие хитрое, об этом в логе пишется при удалении старой версии gcc.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от lukman

Я думаю, у тебя есть два варианта:

1. Посмотреть зависящие пакеты от qtwebkit:4 и попытаться их удалить и перепозлти на qt5-версии.

2. Пересобрать qtwebkit:4 и libxml2 с включенными флагами icu.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

Я установил замаскированную версию пакета {M}(~) 4.10.4, после этого chromium собрался без проблем.

Интересно, но зависимостей все равно нет %)

$ equery d =dev-qt/qtwebkit:4.10.4
 * These packages depend on =dev-qt/qtwebkit:4.10.4:
lukman ()
Ответ на: комментарий от Chaser_Andrey

Как то так :)

~ $ equery d =dev-qt/qtwebkit-4.8.6-r1
 * These packages depend on dev-qt/qtwebkit-4.8.6-r1:
app-office/libreoffice-4.4.5.2 (kde ? >=dev-qt/qtwebkit-4.7.4:4)
dev-qt/designer-4.8.6-r1 (webkit ? ~dev-qt/qtwebkit-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-qt/qtdeclarative-4.8.6-r1 (webkit ? ~dev-qt/qtwebkit-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
kde-apps/ark-4.14.3-r1 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/baloo-widgets-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/dolphin-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/gwenview-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kcalc-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-colorschemes-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-desktopthemes-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-emoticons-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-iconthemes-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-kscreensaver-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-wallpapers-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdeartwork-weatherwallpapers-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdebase-kioslaves-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kdialog-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kfind-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kioclient-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kmix-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/ksnapshot-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/kwrite-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/libkdcraw-4.14.3-r1 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/libkexiv2-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/libkipi-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/libkonq-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-apps/okular-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/baloo-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kactivities-4.13.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/katepart-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kcheckpass-4.11.19 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kdelibs-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kdepim-common-libs-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kdepim-icons-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kdepim-runtime-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kdepimlibs-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kfilemetadata-4.14.3 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/knotes-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kontact-4.14.8 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/kscreensaver-4.11.19 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/libkworkspace-4.11.19 (>=dev-qt/qtwebkit-4.8.5:4)
kde-base/qguiplatformplugin_kde-4.11.19 (>=dev-qt/qtwebkit-4.8.5:4)
kde-frameworks/kdewebkit-5.14.0 (dev-qt/qtwebkit:5)
kde-plasma/libksysguard-5.4.2 (processui ? dev-qt/qtwebkit:5)
kde-plasma/plasma-workspace-5.4.2 (drkonqi ? dev-qt/qtwebkit:5)

Вопрос насчет USE kde. В четверке этот юз был в файле настройки make.conf. Когда упгрейдился в пятерку, где-то в хэндбуке было написно убрать этот флаг из make.conf. Так ли это?

lukman ()
Ответ на: комментарий от Chaser_Andrey

А вообще есть что-то почитать про миграцию на kde5, желательно на русском?

lukman ()

Можно как временный костыль убрать требование icu для libxml2 в ебилде хрома, должно работать.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.