LINUX.ORG.RU

С какой целью интересуешься?

cinyflo ★★★★★ ()

Т.е обертки с вином.

Не похрен, если работает нормально?

crowbar ()
Ответ на: комментарий от Valkeru

Почему толсто? До его появления такой проблемы вообще не существовало.

aplay ★★★★★ ()
Ответ на: комментарий от aplay

Вообще-то существовала. Просто реже встречалась, т.к. игр, в принципе, меньше было (точнее даже сказать, не было единого места, где все бы они разом были доступны). Навскидку, помню как xenonauts продавался в комплекте с wine под видом Linux-версии, под видом якобы Linux-версий Blood и Fallout продавались комплекты игра + dosbox и т.д.

Кстати, GOG подбавит еще масла в огонь, когда начнет поддержку Linux. У них на страничке с вакансией для Linux-специалиста (когда такая была, сейчас уже убрали) так и было написано «Knowledge of what Dosbox and Wine is.».

xxblx ★★★ ()
Ответ на: комментарий от equeim

Точнее все не инди-игры из этого списка.

Т.е. цивилизация, х-сом, серьезный сэм и вальвовские поделки у нас теперь «инди»?
Ну допустим M&B:Warband - вырос из инди (отличная производительность у порта, кстати).
Проще перечислить обертки: Ведьмак, Эадор, да Ксенонавты, больше не было.

siphonops ★★★ ()

Меня бесит, когда пытаюсь поставить в KDE очередную игру из хамбл бандла, а мне в консоль высерается простыня про отсутствие каких-то библиотек GTK, и на этом все заканчивается. Шикарные порты, просто офигительные.

anonymous ()

Пацаны, давайте закатим петицию за нативного Ведьмака 2 и 3? И еще петицию за 1го!

anonymous ()
Ответ на: комментарий от siphonops

System Shock 2, писали, что там Wine. Но я сам не смотрел.

NotecX ()
Ответ на: комментарий от anonymous

меня бесит, что куте требует и что?

anonymous ()
Ответ на: комментарий от equeim

все не инди-игры из этого списка

Наркоман? Тут одна индюшатина заставила взбелениться немало народу

Valkeru ★★★★ ()

А вот тебе не пофигу. У меня стим в вайне с одной установленной игрой: Skyrim. А ждать когда его с .Net портируют на mono бесполезно. Надо понимать, многие игры уже написаны. А выходка Стима показало одну очень важную вещь: Выбор «движка» и библиотек должен быть более осознанным и ориентироваться на кросплатформенность. Что и повлияло на многие новые игры.

И если сейчас кто-то вынужден оборачивать свои игры вайном, что бы они были доступны под Linux, то это не из-за нежелания переписать игру, а по причине сложности и дороговизне. За то можно надеяться, что наступив однажды на грабли вендер-лока, они повторно на них не наступят.

Поэтому я буду покупать те игры, в которые хочу поиграть.

З.Ы.: Вот только зачем мне все те остальные 100, что числятся купленными.

AlexVR ★★★★★ ()
Ответ на: комментарий от siphonops

В цивилизации обертка над Direct3D. Про X-COM не знаю, но они точно не стали бы ради 1% переписывать весь движок на OpenGL. С вероятность 99.9% там какой-нибудь транслятор типа валвовского ToGL.

equeim ★★ ()
Ответ на: комментарий от anonymous

Меня бесит, когда пытаюсь поставить в KDE ... про отсутствие каких-то библиотек GTK...

Чистое GTK/KDE окружение, ты можешь сделать на каком-нибудь терминале по оплате сотовых телефонов. В жизни забудь об этом.

AlexVR ★★★★★ ()

Итого:

The Witcher 2

Xenonauts

System Shock 2

Eador

Что ещё?

Можно на LOR-wiki создать страничку и вывесить на главную ЛОРа ссылку.

Quasar ★★★★★ ()
Ответ на: комментарий от AlexVR

у. У меня стим в вайне с одной установленной игрой: Skyrim. А ждать когда его с .Net портируют на mono бесполезно.

Оно и без стима в вайне идет, равно как и Witcher 2, а с CSMT производительность такая же как и в винде. Т.е. с моей GT 630 и там и тут в Witcher 2 можно поиграть на низких.

Поэтому я буду покупать те игры, в которые хочу поиграть.

+1 и не только покупать, но и заворачивать их в вайн.

Deleted ()
Ответ на: комментарий от crowbar

Не похрен. Нахера такое поощрять? И без них можно просто пустить вендоигру в вайне.

Тем более что вайн и нормально в одном предложении писать должно быть стыдно.

anonymous ()
Ответ на: комментарий от anonymous

Меня бесит, когда пытаюсь поставить в KDE очередную игру из хамбл бандла, а мне в консоль высерается простыня про отсутствие каких-то библиотек GTK...

Gnome ты можешь не любить, но GTK установить обязан!

GTK+ является системной библиотекой пользовательского интерфейса на равне с Qt. Отрицать её — всё равно что отрицать gdi32.dll под оффтопиком. Заметь, тебя никто не заставляет ставить Gnome, а все вменяемые приложения его не требуют. Так что тут всё в порядке.

anonymous ()
Ответ на: комментарий от anonymous

меня бесит, что куте требует и что?

Ок, давай хотя-бы 10 коммерческих игр, которые потребовали Qt и не запустились на обычной Ubuntu (GTK) «изкоробки».

anonymous ()

В вики оформите кто нибудь.

anonymous ()
Ответ на: комментарий от equeim

В цивилизации обертка над Direct3D.

Нет, там нормальный порт от той же компашки, что делала мак-версию.

С вероятность 99.9% там какой-нибудь транслятор типа валвовского ToGL.

Гадание на кофейной гуще, опровергнутое выше.

siphonops ★★★ ()
Ответ на: комментарий от anonymous

В вики оформите кто нибудь.

Возьми, да и оформи сам.

siphonops ★★★ ()
Ответ на: комментарий от anonymous

GTK+ является системной библиотекой пользовательского интерфейса на равне с Qt. Отрицать её — всё равно что отрицать gdi32.dll под оффтопиком.

Норкоман.

anonymous ()
Ответ на: комментарий от redgremlin

Подсовывание обертки с вайном или транслятора под видом нативного порта.

aplay ★★★★★ ()
Ответ на: комментарий от equeim

В цивилизации обертка над Direct3D.

Понимаешь ли, есть очень большая разница между трансляторов вызов для графического API где-то на уровне исходного кода, и завернутым в вайн виндовым бинарником.

Про X-COM не знаю, но они точно не стали бы ради 1% переписывать весь движок на OpenGL.

X-COM использует Unreal Engine 3, там тыщу лет есть OpenGL рендер.

qiomi ()
Ответ на: комментарий от aplay

И в чём суть проблемы-то? Оно не запускается и не работает или что?

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

В случае с Ведьмаком работает, но некисло завышает требования к железу. В случае с Эадором - запускается, но не работает. Что немногим лучше, чем «не запускается». Про остальное не в курсе

Myau ★★★★ ()
Ответ на: комментарий от Myau

В случае с Ведьмаком он как и в виндоус использует только одно ядро (по крайней мере на двухъядерных процессорах, даже с 4 «потоками») и, похоже, патчей меняющих ситуацию они до сих пор выпускать не планируют.

grem ★★★★★ ()

А как насчёт Metro:Last Light - может быть и не обёртка с вином, но настройки графики там выглядят так же уныло как и в версии для макоси - просто один ползунок, по сравнению с версией для виндоус, где полноценный перечень; требования к видеокартам также завышены.

grem ★★★★★ ()
Ответ на: комментарий от grem

SSAA и фильтрация настраиваются в системе, а последние два пункта скорее всего просто были выброшены в результате портирования на OpenGL. Один хрен у половины линуксойдов нормальных дров на видеокарту нет.

Gary ★★★★★ ()
Ответ на: комментарий от Gary

SSAA и фильтрация настраиваются в системе

В Windows они тоже настраиваются в параметрах драйвера и ничего, их не выкинули. Тесселяция в OpenGL поддерживается с 4-й версии (в Linux в драйверах с весны 2010 г.), вот только в MacOS его поддержка появилась в версии 10.9, вышедшей в конце октября 2013 г., так что проблема явно не с драйверами у линуксоидов.

grem ★★★★★ ()
Ответ на: комментарий от anonymous

Тем более что вайн и нормально в одном предложении писать должно быть стыдно.

У меня к системшоку абсолютно ноль претензий. А у нативного Gemini Rue нет анимации дождя (а это огромная часть атмосферы). А ещё пришлось разбираться, почему звука нет, и ставить какой-то костыль, который эмулирует /dev/dsp. Нативную Cat Lady невозможно запустить в фулскрин через меню, только специальным ключом к бинарнику. И библиотеку стимапи пришлось качать новой версии и вручную добавлять, чтобы игра не падала после первой главы.

Порт системшока находится просто на запредельном, нечеловеческом, недосягаемом уровне качества по меркам «честных» портов.

prischeyadro ★★★☆☆ ()
Последнее исправление: prischeyadro (всего исправлений: 1)
Ответ на: комментарий от Gary

у половины линуксойдов нормальных дров на видеокарту нет.

Скорее треть. (треть линуксоидов используют видеокарты AMD)

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Скорее треть. (треть линуксоидов используют видеокарты AMD)

Назвать АМД видеокартой-могут только суровые линуксоиды,даже самые суровые из.

anonymous ()
Ответ на: комментарий от aplay

Подсовывание обертки с вайном или транслятора под видом нативного порта.

Было.

overmind88 ★★★★★ ()
Ответ на: комментарий от Myau

Запускатор запускается... А если по теме, то Эадор (впринципе) работает, но с таким гребаным шаманством каждый запуск, что играть после этого уже не хочется.

PeaceDuke ()
Ответ на: комментарий от anonymous

тебя удивляет, что у программы есть зависимости?

cvs-255 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.