LINUX.ORG.RU

[леннарт] ищется консервативный дистрибутив


0

0

Леннарт добрался и до opensuse. Собственно, радость по поводу переноса всего в /usr можно уже наблюдать здесь http://thread.gmane.org/gmane.linux.suse.opensuse.devel/38837/focus=38874 Очевидно, следующие на очереди бинарные логи, необходимые для новой версии systemd.

Отсюда возникает вопрос, а есть ли в природе бинарный дистрибутив менее зависимый от гениев редхата? Пока сходу вспомнился slackware. Но там софт, мягко говоря, не первой свежести, ну и сомневаюсь я, что Патрик сможет сопротивляться всему этому. Может я ошибаюсь?

На всякий случай, дистры с rolling-release и FreeBSD по ряду причин меня не интересуют.

В дебиане пока только /run появился из новомодных трендов. Даже пульса все еще опциональна.

leave ★★★★★ ()
Ответ на: комментарий от truetester

Вот везде читаю - протухает. Каждый раз теряюсь - что конкретно из НЕОХОДИМОГО софта протухает? Текстовый редактор, почтовый клиент, офисный пакет, нетворк манагер?

shish ()

И да забыл спросить - вы тестировшик новейшего непртухшего софта? Вам платят за бесконечную смену дистрибутивов и версий программ?

shish ()
Ответ на: комментарий от truetester

stable не катит, ибо через пару лет имеет особенность сильно протухать.

я пользуюсь им прямо сейчас, подключил бекпорты, полуофициальную репу с мозиллой и debian multimedia.

ядро 2.6.39
mesa 7.10.3
libreoffice 3.4.3
mplayer 1.0 rc4
virtualbox 4.0.10
xserver 1.10
firefox 10 alpha 2

sniper21 ★★★★★ ()
Ответ на: комментарий от shish

Вот везде читаю - протухает. Каждый раз теряюсь - что конкретно из НЕОХОДИМОГО софта протухает? Текстовый редактор, почтовый клиент, офисный пакет, нетворк манагер?

Задайте вопрос отдельным топиком. Мне не хочется говорить на эту избитую тему.

truetester ()
Ответ на: комментарий от shish

Вот везде читаю - протухает. Каждый раз теряюсь - что конкретно из НЕОХОДИМОГО софта протухает?

1. Mesa
2. Open/LibreOffice
3. Firefox
4. WINE

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

я пользуюсь им прямо сейчас, подключил бекпорты, полуофициальную репу с мозиллой и debian multimedia.

Это всё не то. Для разработки оно не годится.

truetester ()
Ответ на: комментарий от sniper21

Подо всё из этого есть репы для олдстейбл убунты. Правда в ней кроме всего прочего весьма протухший пульс, который гораздо глюкавее нынешнего.

PolarFox ★★★★★ ()
Ответ на: комментарий от leave

В дебиане пока только /run появился из новомодных трендов. Даже пульса все еще опциональна.

Ключевое слово «пока». Я был бы рад, если бы разработчики расписали свои планы хотя бы на пару лет. А то сидеть и гадать, что там через месяц появится, у меня нет желания.

truetester ()
Ответ на: комментарий от truetester

1. Мастурбация на новые версии софта с возрастом проходит.

2. Firefox в Debian нет в принципе.

3. Mesa. Зачем для гоняния игрушек консервативный дистрибутив?

4. LibreOffice спокойно ставится из бэкпортов, он там всегда свежий.

5. Wine - см. п.3.

Вывод - 1. Зачем школьнику консервативный дистрибутив? 2. Вас не интересует мнение форума о консервативности дистрибутивов, вы ищете психологической поддержки в неспособности разобраться с нововведениями. Это обычно больше характерно для девочек.

Ваш выбор - убунту, он выходит два раза в год.

shish ()
Ответ на: комментарий от truetester

Я был бы рад, если бы разработчики расписали свои планы хотя бы на пару лет. А то сидеть и гадать, что там через месяц появится, у меня нет желания.

Можно быть абсолютно уверенным, что до конца 2012 года в Debian Stable не появится ничего принципиально нового, только багфиксы. А про Wheezy тоже информация постепенно появляется:

http://release.debian.org/wheezy/goals.txt

eugeno ★★★★★ ()
Ответ на: комментарий от nyash

для меня главное чтобы с красивыми обоями и без лишних панелек.

BolgenOS, там красивые обои являются ключевой целью разработки.

eugeno ★★★★★ ()

Сомневаешься в Патрике, маловер? Всё у нас классно, хотя КЕДы старые, да.

KblCb ★★★★★ ()

ну и сомневаюсь я, что Патрик сможет сопротивляться всему этому

Зачем сопротивляться, если можно просто не осилить? :-)

Cancellor ★★★★☆ ()
Ответ на: комментарий от splinter

обновляйся до current, подключи sbopkg и все будет супер

А не придётся ли пересобирать СБошные пакеты на каждый чих? Никогда не сидел на карренте.

Cancellor ★★★★☆ ()
Ответ на: комментарий от Cancellor

для обновления до current я использую slackpkg, sbopkg у меня для установки софта отличного от входящего в дистрибутив.

splinter ★★★★★ ()
Ответ на: комментарий от GotF

1. у меня ATI и свободный драйвер, так как Mesa тоже была обновлена, а остальное они тоже не забывают поддерживать.

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

Везёт. Я бы не прочь избавиться от кактуса, но nouveau вроде как до сих пор не очень. Впрочем, на LiveCD Ubuntu 11.10 3D-ускорение работало без проблем, хотя едва ли открытый драйвер вытянет UT2004 на GT210 :)

GotF ★★★★★ ()

Ой, я не заметил, что тред не в Talks. Тогда по теме: Debian testing/sid. Я просто не верю, что люди, вложившие столько сил в доводку системы инициализации, так просто променяют её на неведомое чудо.

GotF ★★★★★ ()

Жалко, что PulseAudio и SystemD по-умолчанию. Хорошо, что они отключаются прямо во время установки одним нажатием кнопки. 12.1 не устанавливал, а в 11.4 PulseAudio хоть и включен по-умолчанию, но отключается в одном из шагов установки (Настройка оборудования).

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от truetester

Несмотря на то, что Патрик уже не один, врядли они вытянут Слаку против течение мейнстрима, если уж п(р)оделки Поттеринга им станут =\

GAMer ★★★★★ ()
Ответ на: комментарий от neocrust

Гном отдельно ставь, смысла его держать в дистрибутиве нет. Возьми слабилды от версии 2.30 исправь там VERSION=2.32 и попробуй собрать, есть вероятнось что получится. :-) А в 2.32 много вкусностей по сравнению с 2.30? А вот кстати твоя 2.32 для слаки от dropline.

splinter ★★★★★ ()
Ответ на: комментарий от neocrust

скорее всего да, я сам не пробовал, не любитель гнома.

splinter ★★★★★ ()
Ответ на: комментарий от GotF

mesa и xserver тоже обновили?
какая карта?
в glxinfo тоже всё в порядке(почему спрашиваю, после удаления блоба надо удалить из блеклиста nouveau)?

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

вот что надо удалить после удаления nvidia драйвера

/etc/modprobe.d/10-nvidia-blacklist.conf

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

mesa и xserver тоже обновили?

Да.

какая карта?

ASUS GT210.

в glxinfo тоже всё в порядке(почему спрашиваю, после удаления блоба надо удалить из блеклиста nouveau)?

Не додумался посмотреть. Но драйвер был загружен, поскольку работал KMS. nvidia-kernel-common, который содержит файл /etc/modprobe.d/nvidia-kernel-common.conf со строкой «blacklist nouveau», я, конечно же, удалил.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

ASUS GT210.

значит действительно драйвер не готов ещё. 9600GT, которая установлена в десктопе (ATI в ноутбуке - основной комп) с nouveau работает очень даже хорошо.

sniper21 ★★★★★ ()
Ответ на: комментарий от GreyDoom

ну, чего его френдить то было:-)правда сам на роллинге, но это чисто из-за любви к генте.

aptyp ★★★★ ()
Ответ на: комментарий от lazyklimm

а с чем там проблемы?

Из-за удаления smp_lock.h (BKL) и перемещения (?) autoconf.h не собирается дистрибутивный модуль nvidia (можно исправить костылями). Не собирается почему-то модуль Virtualbox, хотя можно поставить из тех же BPO. Вообще, я никогда от бэкпортов не получал ничего, кроме головной боли.

GotF ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.