LINUX.ORG.RU

отключение нативной клавиатуры eee pc


0

1

Глючит клавиатура eee pc - залипают кнопки без нажатия. Есть внешняя USB без глюков. Надо отключить встроенную клаву и оставить рабочей внешнюю USB.

xinput --list не в помощь - клавиатура там одна в независимости от количества реальных подключенных клавиатур.

куда копать? (я думаю что в сторону udev, но...)

дистриб: debian lenny


настоятельно рекомендую покапать всётаки в сторону xinput

мусье любит извращения? тогда пробем так: в опуцию загрузки ядра добавить i8042.nokbd или i8042.nokbd=1

Если стоит grub, то сделать это можно при загрузке(нажать -e и дописать, а потом если всё будит ок, то дописать в /boot/grub/menu.lst) пути для файлов не указываю, с дебиана под рукой нету

Lwulf ()

Просто прописать порт /dev/input eventX в xorg.conf и запретить хотплаг добавление
Section «InputDevice»
Identifier «Keyboard1»
Driver «evdev»
Option «Device» «/dev/input/event2»
Option «XkbModel» «evdev»
EndSection

#Разделение устройств ввода
Section «ServerFlags»
Option «AutoAddDevices» «off»
Option «AllowEmptyInput» «on»
EndSection

darkshvein ☆☆ ()
Ответ на: комментарий от visual

и не поспоришь :) Только это не очень правильно, а вдруг всётаки потребуется клава, мм? Снова разбирать бук и подключать..можноконечно, но не всегда удобно.

Lwulf ()

Всем спасибо.

отрубил из ядра - работает :D

asmer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.