LINUX.ORG.RU

Обновление @world после трёхмесячного перерыва

 , ,


0

1

Здравствуйте, товарищи гентоводы!

Мой ноутбук с Gentoo (Asus Eee PC, Intel Atom N450) долго лежал на работе без дела из-за перехода на удалёнку и прочего. В последний раз пересобирал мир ещё в марте. Теперь, забрав ноут, попробовал обновить систему и, понятно, получил конфликты. Кое-как поставил mesa-20.0.8 (записал -libglvnd в make.conf, иначе этот флаг «с минусом» брался из ебилда, как я понял, и всё равно конфликтовал с eselect-opengl). А вот с xorg-server труднее.

$ sudo emerge -a1 =x11-base/xorg-server-1.20.8
Password: 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] x11-base/xorg-server-1.20.8 [1.20.6]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.8:0/1.20.8::gentoo, ebuild scheduled for merge) USE="suid udev xorg -debug -dmx -doc -elogind -ipv6 -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" pulled in by
    =x11-base/xorg-server-1.20.8 (Argument)

  (x11-base/xorg-server-1.20.6:0/1.20.6::gentoo, installed) USE="suid udev xorg -debug -dmx -doc -elogind -ipv6 -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" pulled in by
    x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-video-intel-2.99.917_p20190301:0/0::gentoo, installed) USE="dri sna udev -debug -tools -uxa -xvmc"
                        ^^^^^^^^^^                                                                                                                                                                                                                                                                                                          
    x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-input-mouse-1.9.3:0/0::gentoo, installed) USE=""
                        ^^^^^^^^^^                                                                                                                   
    x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-input-libinput-0.29.0:0/0::gentoo, installed) USE=""
                        ^^^^^^^^^^                                                                                                                       
    (and 1 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (x11-drivers/xf86-input-libinput-0.29.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (x11-drivers/xf86-video-intel-2.99.917_p20190301:0/0::gentoo, installed): ebuild is masked or unavailable
  (x11-drivers/xf86-input-mouse-1.9.3:0/0::gentoo, installed): ebuild is masked or unavailable

То есть три драйвера из x11-drivers не признают моего апдейта. Где их ебилды, кто виноват и что делать в таких случаях?

Генту можно обновлять раз в год, говорили они. Обслуживание не занимает времени, говорили они. Генту не арч, она не ломается так часто, говорили они.

anonymous ()

То есть три драйвера из x11-drivers не признают моего апдейта

В апреле новость была, теперь x11-drivers/xf86-input-mouse и x11-drivers/xf86-input-keyboard удалены. Новость читал? Какие драйвера у тебя в make.conf прописаны?

otto ★★ ()
Ответ на: комментарий от otto

Во как. Проспал, даже в eselect news такого не помню.

Какие драйвера у тебя в make.conf прописаны?

VIDEO_CARDS="intel i915"
INPUT_DEVICES="libinput synaptics mouse"

Больше, вроде, ничего касающегося железа.

al_exquemelin ★★★ ()
Последнее исправление: al_exquemelin (всего исправлений: 1)
Ответ на: комментарий от al_exquemelin

Ты новости читал перед обновлением из списка eselect news list? Там же есть INPUT_DEVICES и libglvnd.

Не надо никакой флаг -libglvnd прописывать. Нужно просто удалить eselect-opengl и обновить @world

grem ★★★★★ ()
Ответ на: комментарий от al_exquemelin

попробуй

emerge --deselect x11-drivers/xf86-video-intel x11-drivers/xf86-video-intel x11-drivers/xf86-input-mouse
emerge -v1O x11-base/xorg-server

P.S.

(x11-base/xorg-server-1.20.8:0/1.20.8::gentoo, ebuild scheduled for merge) USE="suid

suid

можно отключить суид иксам и перейти на elogind

linxon ()
Ответ на: комментарий от grem

Я же говорю, mesa не хотела обновляться без этого флага. Хотя, может, при пересборке @world оно как-то сработало, не знаю.

Сейчас попробую сделать, как там по ссылке в новости.

al_exquemelin ★★★ ()
Последнее исправление: al_exquemelin (всего исправлений: 1)

Теперь вот так:

$ sudo emerge -aN @world
// пропущено

sys-apps/portage:0

  (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
    sys-apps/portage[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gentoolkit-0.4.8:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                

  (sys-apps/portage-2.3.89:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_6 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                    

app-portage/gemato:0

  (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) USE="gpg -test -tools" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
    >=app-portage/gemato-14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (app-portage/gemato-14.3:0/0::gentoo, installed) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
    >=app-portage/gemato-14[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.89:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"

Как тогда обновить portage?

al_exquemelin ★★★ ()
Последнее исправление: al_exquemelin (всего исправлений: 1)

ТС, ты уже удалил это барахло с диска, или всё таки пытаешься обновить мир ? У меня попкорн заканчивается, вот интересуюсь идти ещё за упаковкой, или хватит того, что остался со вчерашнего дня ?

anonymous ()

Твоя проблема не связана с 3 месяцами простоя. У меня тоже была такая, хотя я обновляю раз в неделю.

В моем случае я удалил nvidia-drivers, eselect-opengl, xorg-server и mesa, а потом снова запустил emerge -avuDN world (у меня не интел, а нвидиа). Нужные версии подтянулись, и конфликтовать не с кем. Ну и собственно, -libglvnd установлен для mesa и xorg-server.

Обычно я так и решаю конфликт версий: удаляю установленные версии, конфликтующие с теми, которые должны быть установлены.

Chord ()
Ответ на: комментарий от linxon

Да, это пожалуйста.

https://pastebin.com/3n5Ypq2F

https://pastebin.com/Cn2Ca7nF

@nebularia

Жесть… Мир несколько дней пересобирается?

Не так чтобы. У меня здесь dwm, нет ни офиса, ни огнелиса (vivaldi в качестве браузера). Ядро и драйвера могут долго собираться, это да. Много разной «перловки» - что-то там подтянуло Perl через зависимости. R, sqlite, texlive - вот практически и всё тяжёлое. При необходимости можно оставить сборку на ночь.

@Chord

Обычно я так и решаю конфликт версий: удаляю установленные версии, конфликтующие с теми, которые должны быть установлены.

«А что, так можно было?». Ладно, тоже учту.

al_exquemelin ★★★ ()
Ответ на: комментарий от al_exquemelin

«А что, так можно было?». Ладно, тоже учту.

ага.

замаскируй на время =dev-lang/ocaml-4.09.0 и попробуй удалить emerge -C x11-drivers/xf86-input-synaptics , а потом запустить обновление

linxon ()
Последнее исправление: linxon (всего исправлений: 1)

emerge пишет, что установленные пакеты привязались к определенной версию xorg и поребилдить их не получится, потому что ебилдов этих больше нет (они были объявлены устаревшими и удалены из дерева).

Всего лишь нужно `emerge -C x11-drivers/xf86-input-libinput x11-drivers/xf86-video-intel x11-drivers/xf86-input-mouse`

Если боишься остаться в результате с консолью один на один, предварительно сделай quickpkg на xorg-server и все пакеты драйверов, чтобы в случае чего откатиться.

мимо_обновляю_генту_реже_раза_в_год

kawaii_neko ★★★ ()
Ответ на: комментарий от linxon

замаскируй на время =dev-lang/ocaml-4.09.0 и попробуй удалить emerge -C x11-drivers/xf86-input-synaptics , а потом запустить обновление

Так пошло, спасибо. Правда, emerge всё равно упомянул про ocaml, что-то в духе «будет пропущено из-за конфликтов». Я думал, masked значит, что emerge вообще его не увидит.

162 из 268 пунктов за день, что касается скорости. gcc ещё долго собирается, оказывается, думал, быстрее отработает.

@LongLiveUbuntu

eselect-opengl удаляй, врубай флаг libglvnd

Как закончу эту сборку, попробую.

al_exquemelin ★★★ ()
Ответ на: комментарий от al_exquemelin

gcc, да долговато, по разному бывает, оставляю обычно на ночь, точно не засекал сколько по времени, насчёт libglvnd у парня похожее было в кальке: Calculate linux: не удается выполнить cl-update (комментарий) помогло удаление eselect-opengl

spawn_sp ()

абсолютно аналогичная история у меня была неделю назад. Удалил те самые проблемные пакеты, мир уже никогда не будет прежним...обновился :)

Sahas ★★★★★ ()

Тем временем вылезла новая беда. При сборке stone-soup Python ругнулся на отсутствие модуля 'portage.util.netlink', сборка остановилась. Теперь:

$ equery list stone-soup
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/equery", line 35, in <module>
    from gentoolkit import equery, errors
  File "/usr/lib/python3.6/site-packages/gentoolkit/equery/__init__.py", line 30, in <module>
    import portage
ModuleNotFoundError: No module named 'portage'

Почему 3.6, собственно, если в PYTHON_TARGETS только 3.7, как по дефолту положено?

$ python
Python 3.7.8 (default, Jul 18 2020, 03:11:29)

И здесь линк тоже уже обновился.

al_exquemelin ★★★ ()
Ответ на: комментарий от al_exquemelin

оставил бы пока 3.6 в PYTHON_TARGETS Calculating dependencies... done! [ebuild R ] sys-apps/portage-2.3.103::gentoo USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_6 python3_7 (-pypy3) -python3_8 (-python3_9)" 0 KiB

spawn_sp ()
Ответ на: комментарий от al_exquemelin

Если emerge работает, пробуйте обновить/переустановить gentoolkit. Может equery заработает.

зря версию 3.7 назначили дефолтной, что ли

Дефолтная версия используется только для скриптов, не знающих с каким питоном работать. А для системных скриптов версия питона задана заранее (python-exec).

У вас есть /usr/lib/python-exec/python3.7/equery ? Если есть и 3.6/equery и 3.7/equery, видимо у вас две версии gentoolkit...

mky ★★★★★ ()
Ответ на: комментарий от mky

Дефолтная версия используется только для скриптов, не знающих с каким питоном работать. А для системных скриптов версия питона задана заранее (python-exec).

А, вот оно как. Я поставил назад Python 3.6, потому что его, даже после удаления, тянул обратно некий ssh-ldap-pubkey. equery заработал, да.

Мир получилось дособирать, ура. Теперь надо врубить ocaml, который я убрал в masked. И ядро у меня, оказывается, старое, 4.14. Тоже обновить.

al_exquemelin ★★★ ()
Последнее исправление: al_exquemelin (всего исправлений: 1)