LINUX.ORG.RU

Устранить блокировки x11-drivers/xf86-video-virtualbox-5.1.14

 , , ,


0

2

Начало классическое: пытаюсь обновить Gentoo:

[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-1.19)

Total: 208 packages (172 upgrades, 28 new, 4 in new slots, 4 reinstalls, 1 uninstall), Size of downloads: 997 083 KiB
Conflict: 7 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.1-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Module-Metadata-1.0.31-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                    
    (and 32 more with the same problem)

  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/TermReadKey-2.330.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    (and 55 more with the same problem)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.19[glamor] required by (x11-base/xorg-drivers-1.19:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^ ^                                                                                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-base/xorg-drivers-1.19:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed)
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge)

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Помогите, что нужно замаскировать/размаскировать, чтобы эту блокировку устранить. VirtualBox, у меня кстати вообще не установлен. Хотя может был когда-то...

emerge -C xf86-video-virtualbox

Deleted ()

я так решал конфликт во время обновления perl

 emerge --ask --update --deep --newuse --with-bdeps=y --backtrack=200 @world  
cetjs2 ★★★★★ ()

Увеличенного --backtrack должно хватить, о чём прямо в выхлопе и написано. Подозреваю, что «обновить» подразумевает перепрыгнуть на ~arch.

VirtualBox, у меня кстати вообще не установлен.

Не сходится с

~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)

Если действительно нет и не нужен VirtualBox - вымести его и его остатки из системы.

Nirvandil ()
Ответ на: комментарий от Nirvandil

Спасибо за помощь. Удаление остатков VirtualBox и увеличенный backtrack спасли гиганта мысли. А если все на арч перескочат, кто будет про Gentoo на форумах гадить???

podovalov5 ()
Ответ на: комментарий от podovalov5

Он про нестабильную ветку ~arch(~x86, ~amd64, etc) в Gentoo. Как правило софт свежее, но и больше проблем.

a1batross ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.