LINUX.ORG.RU
решено ФорумAdmin

Прошу помощи обновить gentoo

 ,


0

1

Имеется сервер на джнте, давно не обновлялся. При обновлении ругается на perl. Заранее благодарен.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Getopt-Long-2.420.0-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                
    dev-lang/perl:0/5.20=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    (and 25 more with the same problems)

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-2.150.1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                            


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Getopt-Long-2.420.0-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                
    dev-lang/perl:0/5.20=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    (and 25 more with the same problems)

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-2.150.1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                            


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/perl-CPAN-Meta-2.150.1::gentoo
# required by dev-perl/Module-Build-0.420.500::gentoo
# required by app-text/po4a-0.45-r3::gentoo
# required by sys-apps/man-db-2.7.5::gentoo[nls]
# required by virtual/man-0-r1::gentoo
# required by sys-apps/man-pages-4.06::gentoo
# required by @system
# required by @world (argument)
=dev-lang/perl-5.22.2 ~x86


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/perl-CPAN-Meta-2.150.1::gentoo
# required by dev-perl/Module-Build-0.420.500::gentoo
# required by app-text/po4a-0.45-r3::gentoo
# required by sys-apps/man-db-2.7.5::gentoo[nls]
# required by virtual/man-0-r1::gentoo
# required by sys-apps/man-pages-4.06::gentoo
# required by @system
# required by @world (argument)
=dev-lang/perl-5.22.2 ~x86

★★★

Самое простое: удалить блокирующие и блокируемые пакеты, а потом поставить (обновить) обратно.

slon ()
Ответ на: комментарий от slon

Думал уже по этому поводу. Но хочется выслушать еще какие нибудь варианты.

xaTa ★★★ ()
Ответ на: комментарий от xaTa

а здесь нет решения кроме удаления перловых кишок --> обновления перла --> установки кишок обратно, возможно новых версий.

slon ()
Ответ на: комментарий от xaTa

Я бы рекомендовал сначала так сделать, а потом запустить perl-cleaner --all. Возможно, часть проблем порешает (но вряд ли все).

BattleCoder ★★★★★ ()
Ответ на: комментарий от xaTa

Стоп, я как-то упустил, почему у вас тянется perl-5.22, он же пока в тестовой ветке. Он вам точно нужен?

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

А в этого я незнаю. Стоит ACCEPT_KEYWORDS=«x86», Сам удивился.

xaTa ★★★ ()
Ответ на: комментарий от xaTa

Так что насчёт perl-cleaner? помог? У меня установлены все вышеозвученные пакеты, и только perl-5.20, никто 5.22 не тянет.

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

Не, perl-cleaner не помог.. ситуация таже. щас буду сносить те пакеты которые тянут нестабильный perl

xaTa ★★★ ()
Ответ на: комментарий от slon

Да все решилось удалением perl и зависимостей.

xaTa ★★★ ()
Ответ на: комментарий от xaTa

Да все решилось удалением perl и зависимостей.

Обычно такое решается, если зависимости явно указать в emerge
И - только с python'ом такое не делай

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

И - только с python'ом такое не делай

Ок. Учту на будущее.

xaTa ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.