LINUX.ORG.RU

очередная ошибка в emerge

 , ,


0

1

в общем хотел тут поставить layman:

tree_js Рабочий стол # emerge --ask app-portage/layman

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/PySocks-1.5.6  PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-python/backports-1.0  PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-python/py-1.4.31  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5" 
[ebuild  N     ] dev-python/backports-ssl-match-hostname-3.5.0.1-r1  PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-python/ndg-httpsclient-0.4.0  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5" 
[ebuild  N     ] dev-python/urllib3-1.14  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-python/requests-2.9.1-r2  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-python/ssl-fetch-0.4  PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 
[ebuild  N     ] dev-perl/GSSAPI-0.280.0-r1  USE="{-test}" 
[ebuild     U #] dev-lang/perl-5.24.0-r1 [5.20.2-r1]
[ebuild  N     ] dev-perl/Net-SMTP-SSL-1.30.0  USE="{-test}" 
[ebuild  N     ] virtual/perl-Digest-SHA-5.950.0-r1 
[ebuild  N     ] dev-perl/Digest-HMAC-1.30.0-r1 
[ebuild  N     ] dev-perl/Authen-SASL-2.160.0-r1  USE="kerberos" 
[ebuild  N     ] dev-perl/Error-0.170.240  USE="{-test}" 
[ebuild  NS    ] x11-libs/gtksourceview-2.10.5-r3 [3.18.2] USE="{-test}" 
[ebuild  N     ] dev-python/pygtksourceview-2.10.1-r1  USE="-doc" PYTHON_TARGETS="python2_7" 
[ebuild  N     ] dev-vcs/git-2.9.2  USE="blksha1 curl gnome-keyring gpg gtk iconv nls pcre perl python threads webdav -cgi -cvs -doc -emacs -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" LINGUAS="-bg -ca -de -fr -is -it -ko -pt_PT -ru -sv -vi -zh_CN" PYTHON_TARGETS="python2_7" 
[ebuild  N     ] app-portage/layman-2.4.1-r1  USE="git -bazaar -cvs -darcs -g-sorcery -gpg -mercurial -sqlite -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Compress-Raw-Zlib-2.65.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                  
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                      
    (and 51 more with the same problems)

  (dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-JSON-PP-2.273.0-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                            
    (and 2 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/perl-Time-Local-1.230.0-r3::gentoo
# required by dev-perl/HTTP-Date-6.20.0-r1::gentoo
# required by dev-perl/HTTP-Message-6.110.0::gentoo
# required by dev-perl/libwww-perl-6.150.0::gentoo
# required by x11-misc/xscreensaver-5.34::gentoo[perl]
# required by xfce-base/xfce4-session-4.12.1::gentoo[xscreensaver]
# required by xfce-base/xfce4-meta-4.12::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/perl:
=dev-lang/perl-5.24.0-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No] 

писанина в /etc/portage/package.mask/perl:

<dev-lang/perl-5.18.0  //это было уже
=dev-lang/perl-5.22*
=dev-lang/perl-5.24*

ничего не дала... как быть? возможно, что-то очевидное, но сам не могу врубиться

Ответ на: комментарий от xaTa

сделал perl-cleaner --all...

ну снова то же самое:

tree_js Рабочий стол # emerge --ask =dev-lang/perl-5.24.0

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.24.0 [5.20.2-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.0:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24.0 (Argument)
    =dev-lang/perl-5.24* required by (virtual/perl-Time-Local-1.230.0-r3:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                               

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    =dev-lang/perl-5.20* required by (virtual/perl-Compress-Raw-Bzip2-2.64.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                   
    (and 35 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

xperious ★★ ()
Ответ на: комментарий от xperious

Такое часто бывает при обновлениях перла и дополнительных пакетов к нему. Периодически пакеты совместимые с актуальной версией перла меняются с virtual/perl-packagename на dev-perl/packagename и наоборот. Как правило per-cleaner это разруливает, но в особо запущенных случаях, когда perl-cleaner ничего не может сделать, указанные пакеты удаляются по одному через emerge -C, а затем ставятся повторно ручками.

NightOperator ★★★ ()
Последнее исправление: NightOperator (всего исправлений: 2)
Ответ на: комментарий от xperious

equery d perl

а там смотри зависимости и удаляй их ручками, у меня ушло на это минут 5 максисмум. Пересобрал perl а потом поставил то что удалил. Ну как то так)

xaTa ★★★ ()
Ответ на: комментарий от xaTa

emerge -ave system дало

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2-r2:0/5= required by (sys-devel/gdb-7.11.1:0/0::gentoo, installed)
                             ^^^^^                                                                                              
    (and 8 more with the same problem)

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/ncurses:0/6[ada?,cxx?,gpm?,static-libs?,tinfo?,unicode?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ncurses-6.0:5/6::gentoo, ebuild scheduled for merge)
                    ^^^^                                                                                                                                                                                                                                                                                                                           

dev-lang/perl:0

  (dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-File-Spec-3.630.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                            
    (and 18 more with the same problem)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-IO-1.310.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                    
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    (and 28 more with the same problems)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.70:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.67[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/mesa-12.0.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                     

  (x11-libs/libdrm-2.4.65:0/0::gentoo, installed) pulled in by
    x11-libs/libdrm[video_cards_amdgpu] required by (x11-drivers/xf86-video-amdgpu-0.0.01_pre20150814:0/0::gentoo, installed)
                    ^^^^^^^^^^^^^^^^^^                                                                                                                           
    >=x11-libs/libdrm-2.4.58[video_cards_radeon] required by (x11-drivers/xf86-video-ati-7.5.0:0/0::gentoo, installed)
                             ^^^^^^^^^^^^^^^^^^                                                                                                           
    >=x11-libs/libdrm-2.4.29[video_cards_intel] required by (x11-drivers/xf86-video-intel-2.99.917-r2:0/0::gentoo, installed)
                             ^^^^^^^^^^^^^^^^^                                                                                                                   

net-libs/gnutls:0

  (net-libs/gnutls-3.4.14-r1:0/30::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnutls-3.3.24:0/0::gentoo, installed) pulled in by
    >=net-libs/gnutls-3:0/0=[abi_x86_64(-)] required by (net-libs/glib-networking-2.46.1:0/0::gentoo, installed)
                       ^^^^^                                                                                                                        

app-text/poppler:0

  (app-text/poppler-0.46.0-r1:0/63::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.45.0:0/62::gentoo, installed) pulled in by
    >=app-text/poppler-0.33:0/62=[cairo] required by (app-text/evince-3.20.1:0/evd3.4-evv3.3::gentoo, installed)
                           ^^^^^^                                                                                                                   

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    x11-libs/libxcb:0/1.11.1=[abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                                        
    (and 4 more with the same problem)

xperious ★★ ()
Ответ на: комментарий от xaTa
tree_js Рабочий стол # equery d perl
 * These packages depend on perl:
app-admin/perl-cleaner-2.20 (dev-lang/perl)
app-editors/mousepad-0.4.0 (dev-lang/perl)
app-editors/vim-7.4.769 (perl ? dev-lang/perl)
app-text/openjade-1.3.2-r6 (dev-lang/perl)
app-text/po4a-0.45-r3 (dev-lang/perl[-build(-)])
app-text/qpdf-5.1.1 (>=dev-lang/perl-5.8)
dev-lang/nasm-2.12.01 (dev-lang/perl)
dev-libs/atk-2.18.0 (>=dev-lang/perl-5)
dev-libs/libcdio-0.92 (test ? dev-lang/perl)
dev-libs/libcdio-paranoia-0.90_p1-r1 (test ? dev-lang/perl)
dev-libs/libical-1.0.1 (dev-lang/perl)
dev-libs/libtasn1-4.5 (>=dev-lang/perl-5.6)
dev-libs/openssl-1.0.2h-r2 (>=dev-lang/perl-5)
dev-perl/Encode-Locale-1.30.0-r1 (dev-lang/perl[-build(-)])
dev-perl/File-BaseDir-0.30.0-r1 (dev-lang/perl[-build(-)])
dev-perl/File-DesktopEntry-0.40.0-r1 (dev-lang/perl[-build(-)])
dev-perl/File-Listing-6.40.0-r1 (dev-lang/perl[-build(-)])
dev-perl/File-MimeInfo-0.270.0 (dev-lang/perl[-build(-)])
dev-perl/HTML-Parser-3.710.0-r1 (dev-lang/perl[-build(-)])
dev-perl/HTML-Tagset-3.200.0-r1 (dev-lang/perl[-build(-)])
dev-perl/HTTP-Cookies-6.10.0 (dev-lang/perl[-build(-)])
dev-perl/HTTP-Daemon-6.10.0-r1 (dev-lang/perl[-build(-)])
dev-perl/HTTP-Date-6.20.0-r1 (dev-lang/perl[-build(-)])
dev-perl/HTTP-Message-6.110.0 (dev-lang/perl)
dev-perl/HTTP-Negotiate-6.10.0 (dev-lang/perl[-build(-)])
dev-perl/IO-HTML-1.1.0 (dev-lang/perl[-build(-)])
dev-perl/IO-Socket-SSL-2.24.0 (dev-lang/perl[-build(-)])
dev-perl/JSON-2.900.0 (dev-lang/perl[-build(-)])
dev-perl/LWP-MediaTypes-6.20.0-r1 (dev-lang/perl[-build(-)])
dev-perl/LWP-Protocol-https-6.60.0 (dev-lang/perl[-build(-)])
dev-perl/Locale-gettext-1.50.0-r1 (dev-lang/perl[-build(-)])
dev-perl/Module-Build-0.421.600 (dev-lang/perl)
dev-perl/Net-HTTP-6.90.0 (dev-lang/perl)
dev-perl/Net-SSLeay-1.720.0-r1 (dev-lang/perl)
dev-perl/SGMLSpm-1.03-r7 (dev-lang/perl[-build(-)])
dev-perl/TermReadKey-2.330.0 (dev-lang/perl[-build(-)])
dev-perl/Text-CharWidth-0.40.0-r1 (dev-lang/perl[-build(-)])
dev-perl/Text-Unidecode-0.40.0-r1 (dev-lang/perl[-build(-)])
dev-perl/Text-WrapI18N-0.60.0-r1 (dev-lang/perl[-build(-)])
dev-perl/URI-1.710.0 (dev-lang/perl)
dev-perl/Unicode-EastAsianWidth-1.330.0-r1 (dev-lang/perl[-build(-)])
dev-perl/WWW-RobotRules-6.20.0 (dev-lang/perl[-build(-)])
dev-perl/XML-LibXML-2.12.100 (dev-lang/perl[-build(-)])
dev-perl/XML-NamespaceSupport-1.110.0-r1 (dev-lang/perl[-build(-)])
dev-perl/XML-Parser-2.410.0-r2 (dev-lang/perl[-build(-)])
dev-perl/XML-SAX-0.990.0-r1 (dev-lang/perl[-build(-)])
dev-perl/XML-SAX-Base-1.80.0-r1 (dev-lang/perl[-build(-)])
dev-perl/XML-Simple-2.200.0-r1 (dev-lang/perl[-build(-)])
dev-perl/libintl-perl-1.240.0 (dev-lang/perl[-build(-)])
dev-perl/libwww-perl-6.150.0 (dev-lang/perl[-build(-)])
dev-qt/qt3support-4.8.6-r1 (dev-lang/perl)
dev-qt/qtcore-4.8.6-r2 (dev-lang/perl)
dev-qt/qtgui-4.8.6-r4 (dev-lang/perl)
dev-qt/qtscript-4.8.6-r2 (dev-lang/perl)
dev-qt/qtsql-4.8.6-r1 (dev-lang/perl)
dev-qt/qttranslations-4.8.6-r1 (dev-lang/perl)
dev-util/gtk-doc-am-1.25 (>=dev-lang/perl-5.6)
dev-util/intltool-0.51.0-r1 (>=dev-lang/perl-5.8.1)
media-gfx/graphite2-1.3.8 (perl ? dev-lang/perl)
media-libs/x264-0.0.20140308 (opencl ? dev-lang/perl)
net-libs/libproxy-0.4.13-r1 (perl ? dev-lang/perl)
net-misc/curl-7.50.1 (test ? dev-lang/perl)
net-misc/wget-1.18 (dev-lang/perl)
net-nds/openldap-2.4.38-r2 (perl ? dev-lang/perl[-build(-)])
net-print/cups-filters-1.5.0 (perl ? dev-lang/perl)
perl-core/CPAN-Meta-2.150.1 (dev-lang/perl)
perl-core/Data-Dumper-2.154.0 (dev-lang/perl[-build(-)])
perl-core/File-Temp-0.230.400-r1 (dev-lang/perl[-build(-)])
perl-core/JSON-PP-2.273.0 (dev-lang/perl)
perl-core/Module-Metadata-1.0.26 (dev-lang/perl[-build(-)])
perl-core/libnet-1.270.0 (dev-lang/perl[-build(-)])
sys-apps/help2man-1.46.6 (dev-lang/perl)
sys-apps/hwids-20150717-r1 (udev ? dev-lang/perl)
sys-apps/openrc-0.19.1 (tools ? dev-lang/perl)
sys-apps/texinfo-6.1 (dev-lang/perl)
sys-devel/autoconf-2.13 (dev-lang/perl)
sys-devel/autoconf-2.69 (>=dev-lang/perl-5.6)
sys-devel/automake-1.14.1 (dev-lang/perl)
sys-devel/automake-1.15 (dev-lang/perl)
sys-devel/bison-3.0.4-r1 (examples ? dev-lang/perl)
                         (test ? dev-lang/perl)
sys-devel/llvm-3.7.1-r3 (static-analyzer ? dev-lang/perl)
                        (dev-lang/perl)
sys-fs/eudev-3.1.5 (test ? dev-lang/perl)
sys-kernel/gentoo-sources-4.4.6 (!build ? dev-lang/perl)
sys-kernel/linux-headers-4.3 (dev-lang/perl)
virtual/perl-CPAN-Meta-2.150.1 (=dev-lang/perl-5.22*)
virtual/perl-CPAN-Meta-Requirements-2.125.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-CPAN-Meta-YAML-0.12.0-r1 (=dev-lang/perl-5.22*)
                                      (=dev-lang/perl-5.20*)
virtual/perl-Carp-1.330.100 (=dev-lang/perl-5.20*)
virtual/perl-Compress-Raw-Bzip2-2.64.0 (=dev-lang/perl-5.20*)
virtual/perl-Compress-Raw-Zlib-2.65.0 (=dev-lang/perl-5.20*)
virtual/perl-Digest-MD5-2.530.0-r2 (=dev-lang/perl-5.20*)
virtual/perl-Encode-2.600.0 (=dev-lang/perl-5.20*)
virtual/perl-Exporter-5.710.0-r2 (=dev-lang/perl-5.20.2*)
virtual/perl-ExtUtils-CBuilder-0.280.217-r2 (=dev-lang/perl-5.20.2*)
virtual/perl-ExtUtils-Install-1.670.0 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-MakeMaker-6.980.0 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-Manifest-1.630.0-r2 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-ParseXS-3.240.0 (=dev-lang/perl-5.20*)
virtual/perl-File-Spec-3.480.100-r1 (=dev-lang/perl-5.20.2*)
virtual/perl-Getopt-Long-2.420.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-IO-1.310.0 (=dev-lang/perl-5.20*)
virtual/perl-IO-Compress-2.64.0 (=dev-lang/perl-5.20*)
virtual/perl-JSON-PP-2.273.0-r1 (=dev-lang/perl-5.24*)
                                (=dev-lang/perl-5.22*)
virtual/perl-MIME-Base64-3.140.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-Module-Metadata-1.0.26 (=dev-lang/perl-5.22*)
virtual/perl-Parse-CPAN-Meta-1.441.400-r1 (=dev-lang/perl-5.22*)
                                          (=dev-lang/perl-5.20*)
virtual/perl-Perl-OSType-1.7.0 (=dev-lang/perl-5.20*)
virtual/perl-Scalar-List-Utils-1.380.0 (=dev-lang/perl-5.20*)
virtual/perl-Storable-2.490.100-r1 (=dev-lang/perl-5.20.2*)
virtual/perl-Test-Harness-3.330.0 (=dev-lang/perl-5.20*)
virtual/perl-Text-ParseWords-3.290.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-Time-Local-1.230.0-r3 (=dev-lang/perl-5.24*)
                                   (=dev-lang/perl-5.22*)
                                   (=dev-lang/perl-5.20*)
virtual/perl-parent-0.228-r1 (=dev-lang/perl-5.20*)
virtual/perl-version-0.990.900-r2 (=dev-lang/perl-5.22*)
                                  (=dev-lang/perl-5.20.2*)
www-client/chromium-52.0.2743.116 (dev-lang/perl)
x11-libs/libX11-1.6.3 (test ? dev-lang/perl)
x11-misc/icon-naming-utils-0.8.90 (>=dev-lang/perl-5)
x11-misc/xscreensaver-5.34 (perl ? dev-lang/perl)
xfce-base/exo-0.10.6 (>=dev-lang/perl-5.6)
xfce-base/libxfce4ui-4.12.1-r2 (dev-lang/perl)
xfce-base/thunar-1.6.10 (>=dev-lang/perl-5.6)
xfce-base/xfce4-panel-4.12.0 (dev-lang/perl)
xfce-base/xfconf-4.12.0-r1 (perl ? dev-lang/perl[-build(-)])

честно говоря не врубаюсь что удалять в данном случае?

xperious ★★ ()
Ответ на: комментарий от xperious

emerge --ask perl

вместо продолжения выписываешь все конфликты в которых установлен virtual/perl-packagename вместо dev-perl/packagename и наоборот.

emerge -C тут все выписанные выше пакеты

emerge perl - перл должен обновиться

emerge тут список из virtual/perl-packagename вместо dev-perl/packagename и наоборот, только инвертированный (т.е. если удалял virtual/perl-packagename, то здесь ставить dev-perl/packagename)

Вот здесь они у тебя собственно:

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-IO-1.310.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                    
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    (and 28 more with the same problems)

NightOperator ★★★ ()
Последнее исправление: NightOperator (всего исправлений: 1)
Ответ на: комментарий от xperious
virtual/perl-CPAN-Meta-2.150.1 (=dev-lang/perl-5.22*)
virtual/perl-CPAN-Meta-Requirements-2.125.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-CPAN-Meta-YAML-0.12.0-r1 (=dev-lang/perl-5.22*)
                                      (=dev-lang/perl-5.20*)
virtual/perl-Carp-1.330.100 (=dev-lang/perl-5.20*)
virtual/perl-Compress-Raw-Bzip2-2.64.0 (=dev-lang/perl-5.20*)
virtual/perl-Compress-Raw-Zlib-2.65.0 (=dev-lang/perl-5.20*)
virtual/perl-Digest-MD5-2.530.0-r2 (=dev-lang/perl-5.20*)
virtual/perl-Encode-2.600.0 (=dev-lang/perl-5.20*)
virtual/perl-Exporter-5.710.0-r2 (=dev-lang/perl-5.20.2*)
virtual/perl-ExtUtils-CBuilder-0.280.217-r2 (=dev-lang/perl-5.20.2*)
virtual/perl-ExtUtils-Install-1.670.0 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-MakeMaker-6.980.0 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-Manifest-1.630.0-r2 (=dev-lang/perl-5.20*)
virtual/perl-ExtUtils-ParseXS-3.240.0 (=dev-lang/perl-5.20*)
virtual/perl-File-Spec-3.480.100-r1 (=dev-lang/perl-5.20.2*)
virtual/perl-Getopt-Long-2.420.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-IO-1.310.0 (=dev-lang/perl-5.20*)
virtual/perl-IO-Compress-2.64.0 (=dev-lang/perl-5.20*)
virtual/perl-JSON-PP-2.273.0-r1 (=dev-lang/perl-5.24*)
                                (=dev-lang/perl-5.22*)
virtual/perl-MIME-Base64-3.140.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-Module-Metadata-1.0.26 (=dev-lang/perl-5.22*)
virtual/perl-Parse-CPAN-Meta-1.441.400-r1 (=dev-lang/perl-5.22*)
                                          (=dev-lang/perl-5.20*)
virtual/perl-Perl-OSType-1.7.0 (=dev-lang/perl-5.20*)
virtual/perl-Scalar-List-Utils-1.380.0 (=dev-lang/perl-5.20*)
virtual/perl-Storable-2.490.100-r1 (=dev-lang/perl-5.20.2*)
virtual/perl-Test-Harness-3.330.0 (=dev-lang/perl-5.20*)
virtual/perl-Text-ParseWords-3.290.0-r1 (=dev-lang/perl-5.20*)
virtual/perl-Time-Local-1.230.0-r3 (=dev-lang/perl-5.24*)
                                   (=dev-lang/perl-5.22*)
                                   (=dev-lang/perl-5.20*)
virtual/perl-parent-0.228-r1 (=dev-lang/perl-5.20*)
virtual/perl-version-0.990.900-r2 (=dev-lang/perl-5.22*)

Зависимости

xaTa ★★★ ()
Ответ на: комментарий от NightOperator
tree_js Рабочий стол # emerge --ask perl

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 10 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.24.0-r1 [5.20.2-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Time-Local-1.230.0-r3:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                               
    dev-lang/perl (Argument)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                    
    =dev-lang/perl-5.20* required by (virtual/perl-IO-1.310.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                    
    (and 35 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

вот...как тут выписать конфликты в которых установлен virtual/perl-packagename вместо dev-perl/packagename?)

xperious ★★ ()
Ответ на: комментарий от xperious

(and 35 more with the same problems)

можешь их по одному сносить, только записывай где-нибудь, что сносишь и потом пытайся снова обновить перл, отображаемый конфликт при этом будет другой, потом все скопом обратно поставишь. Не на чем сейчас проверить - возможно emerge -av perl даст сразу полный список.

NightOperator ★★★ ()
Последнее исправление: NightOperator (всего исправлений: 2)
Ответ на: комментарий от NightOperator

ок, утром буду мурыжить... спасибо преогромное всем

xperious ★★ ()

emerge -C $(qlist -IC virtual/perl-)
emerge -1uD perl
perl-cleaner --all
emerge -uDN world --with-bdeps=y

Pinkbyte ★★★★★ ()

хотел тут поставить layman

Так и надо говорить, «хотел заняться некрофилией»
Гугли repos.conf

afterlanding ★★ ()

Добро пожаловать в квест с элементами хоррора под названием «обновление перла в генте»!

Снеси перломодули, обнови перл отдельно, обнови мир полностью, модули сами подтянутся.

r3lgar ★★★★★ ()
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

презираю таких.

slon ()

в общем пересобрал с перлом пакеты... дальше проблема была в ncurses... сделал так:

emerge -C sys-libs/ncurses
emerge -1 =sys-libs/ncurses-5.9-r4
emerge -1u =sys-libs/ncurses-6.0
прошло удачно, далее emerge --ask layman и в итоге вылетело на чем-то... сделал emerge @preserved-rebuild и вылетело следующее:
* ERROR: sys-apps/texinfo-6.1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-apps/texinfo-6.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/texinfo-6.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/texinfo-6.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/texinfo-6.1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1'
 * S: '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1'

>>> Failed to emerge sys-apps/texinfo-6.1, Log file:

>>>  '/var/tmp/portage/sys-apps/texinfo-6.1/temp/build.log'

 * Messages for package sys-apps/less-481:

 * lesspipe offers colorization options.  Run 'lesspipe -h' for info.

 * Messages for package sys-process/htop-1.0.3:

 * To use lsof features in htop(what processes are accessing
 * what files), you must have sys-process/lsof installed.

 * Messages for package sys-apps/texinfo-6.1:

 * ERROR: sys-apps/texinfo-6.1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-apps/texinfo-6.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/texinfo-6.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/texinfo-6.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/texinfo-6.1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1'
 * S: '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1'

 * Regenerating GNU info directory index...
 * Processed 134 info files.

!!! existing preserved libs:
>>> package: dev-lang/perl-5.24.0-r1
 *  - /usr/lib64/libperl.so.5.20
 *  - /usr/lib64/libperl.so.5.20.2
 *      used by /usr/lib64/texinfo/XSParagraph.so (sys-apps/texinfo-6.1)
>>> package: sys-libs/ncurses-6.0-r1
 *  - /usr/lib64/libform.so.5
 *  - /usr/lib64/libform.so.5.9
 *      used by /usr/bin/ccmake (dev-util/cmake-3.3.1-r1)
 *  - /lib64/libncursesw.so.5
 *  - /lib64/libncursesw.so.5.9
 *      used by /bin/more (sys-apps/util-linux-2.26.2)
 *      used by /bin/nano (app-editors/nano-2.5.3)
 *      used by /sbin/cfdisk (sys-apps/util-linux-2.26.2)
 *      used by 8 other files
 *  - /lib64/libncurses.so.5
 *  - /lib64/libncurses.so.5.9
 *      used by /lib64/libeinfo.so.1 (sys-apps/openrc-0.19.1)
 *      used by /lib64/libgpm.so.1.20.0 (sys-libs/gpm-1.20.7-r2)
 *      used by /usr/bin/ccmake (dev-util/cmake-3.3.1-r1)
 *      used by 8 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
в чем может быть трабл?

xperious ★★ ()
Ответ на: комментарий от xperious

а во кажись выше было в выхлопе:

BEGIN failed--compilation aborted at ../tp/texi2any line 109.
Can't locate Locale/Messages.pm in @INC (you may need to install the Locale::Messages module) (@INC contains: ../tp/Texinfo/Convert/XSParagraph ../tp/maintain ../tp ../tp ../tp /etc/perl /usr/local/lib64/perl5/5.24.0/x86_64-linux /usr/local/lib64/perl5/5.24.0 /usr/lib64/perl5/vendor_perl/5.24.0/x86_64-linux /usr/lib64/perl5/vendor_perl/5.24.0 /usr/lib64/perl5/5.24.0/x86_64-linux /usr/lib64/perl5/5.24.0 .) at ../tp/texi2any line 109.
BEGIN failed--compilation aborted at ../tp/texi2any line 109.
Makefile:1214: recipe for target 'texinfo.info' failed
make[3]: *** [texinfo.info] Error 2
make[3]: *** Waiting for unfinished jobs....
Makefile:1274: recipe for target 'info-stnd.info' failed
make[3]: *** [info-stnd.info] Error 2
make[3]: Leaving directory '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1/doc'
Makefile:1417: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1/doc'
Makefile:1174: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-apps/texinfo-6.1/work/texinfo-6.1'
Makefile:1113: recipe for target 'all' failed
make: *** [all] Error 2

походу с перлом проблемы какие-то

xperious ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.