LINUX.ORG.RU

Выбор дистрибутива для рабочего компьютера

 , , ,


0

1

Здравствуй, ЛОР!

Имеется рабочий офисный компьютер: AMD Athlon 64 x2 5200+ 2,69 ГГц; 1,37 ГБ ОЗУ; Ati X1200 Series. К нему подключен принтер Сanon LBP-810. На указанном железе жил и здравствовал Хubuntu 14.04 LTS. После последней поломки оного, в самый неподходящий момент, решил сменить дистрибутив на что-то более стабильное. Из требований стояло: относительная стабильность, какое-никакое комьюнити для чтения, изучения, решения проблем и поменьше красногласия. Из ПО используется офис, браузер, джабер клиент, музыкальный проигрыватель ну и все в общем.

Казалось бы, под такие требования взлетит любой дистрибутив... Но, в процессе поиска и установки я столкнулся с проблемой работы моего древнего принтера. Опробовал около пяти разных дистрибутивов и у меня не вышло НОРМАЛЬНО установить драйвера и настроить LBP-810. Либо он не печатал вообще, либо печатал через раз.

В Xubuntu принтер поднимался до безобразия просто. С убунтовский вики скачивал скрипт, который сам все делал.

Посоветуйте, пожалуйста, дистрибутив где есть готовый и рабочий рецепт приготовления Canon LBP-810.

PS. Гугл весь перечитан вдоль и поперек и рецепты которые есть, либо старые, либо не рабочие. Возможно кто-то сейчас пользуется таким принтером и может подсказать как его завести под конкретный дистрибутив.


ubuntu /OpenSUSE/ Fedora

=== CentOS7 / Scientific Linux7

Deleted ()
Последнее исправление: RTP (всего исправлений: 1)

Стабильнее Xubuntu может быть разве что Debian Stable с Xfce.

lampslave ★★ ()

Убунта.

Буду оригинален: убунта.

Так это та же Xubuntu же.

Seom ()

Дай ссылку на скрипт. Мне кажется его можно адаптировать под debian

sin-ok ()
Ответ на: комментарий от Seom

Ну так это замечательно же!

После последней поломки оного

А это к вопросу о кривизне рук при желании ковыряться в системе. Дистрибутив тут ни при чем.

winlook38 ★★ ()

https://wiki.archlinux.org/index.php/Canon_CAPT https://help.ubuntu.com/community/CanonCaptDrv190 RTP ★★ (15.04.2015 11:46:21)

Благодарю, но Убунта мне не подходит, она у меня падает почему-то и периодически отказывается годно работать. Поэтому и хочу уйти от Xubuntu.

Арч не пробовал, но здесь на ЛОРе пишут, что там со стабильностью не очень.

Компьютер рабочий, от него требуется только, что б он работал. Не больше и не меньше :)

Seom ()
Ответ на: комментарий от Seom

это инструкции по установке принтера, не?

Deleted ()

Debian Testing. За 5 месяцев ничего пока ничего не сломалось.

ck114 ()

А это к вопросу о кривизне рук при желании ковыряться в системе. Дистрибутив тут ни при чем.

Возможно.У меня пару дней назад на ровном месте завис ЛибреОфис и после завершения задачи унес с собой в небытие с hdd три открытых документа. Навсегда. Я не знаю, виноваты в этом мои руки, ЛибреОфис, или Хубунту. Но два фактора из трех я могу заменить :D

Seom ()
Ответ на: комментарий от Seom

Посмотрел, должно все работать. У меня сейчас на буке stable, ругнулось на libcairo2:i386

Но скорее всего можно разрешить apt-get install -f

Попробуй, у меня нет принтера просто.

sin-ok ()
Ответ на: комментарий от sin-ok

Спасибо. Я пробовал - не работает. Ругается на невозможность выполнения процесса, или запуска демона, точно не помню. Приду домой - посмотрю и напишу точно, на что ругается.

Seom ()

это инструкции по установке принтера, не?

Инструкции, да. Вот я и вопрошаю у тех, у кого есть опыт по этим инструкциям заставить работать LBP-810 вне *buntu

Seom ()

Linux Mint Debian Edition, очень понравился дистрибутив, готовый дебиан из коробки.

awesomenickname ★★★★★ ()
Ответ на: комментарий от Seom

Хорошо. Давай выхлоп посмотрим. И уже затем кастонем ЛОРовцев.

sin-ok ()

последний годный 12.04

14.04 шлак. подтверждаю...

anonymous ()
Ответ на: комментарий от sin-ok

Установка 32-битных библиотек необходимых для 64-разрядной версии драйвера принтера Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово : Не удалось найти пакет по регулярному выражению «libatk1.0-0» E: Не удалось найти пакет libcairo2 E: Не удалось найти пакет libgtk2.0-0 E: Не удалось найти пакет по регулярному выражению «libgtk2.0-0» E: Не удалось найти пакет libpango1.0-0 E: Не удалось найти пакет по регулярному выражению «libpango1.0-0» E: Не удалось найти пакет libstdc++6 E: Не удалось найти пакет по регулярному выражению «libstdc++6» E: Не удалось найти пакет libpopt0 E: Не удалось найти пакет libxml2 E: Не удалось найти пакет libc6

Ошибка при установке пакета Нажмите любую клавишу для выхода

Это то, что выдает в конце скрипта. Перечисленные пакеты установлены. Попробую поковырять скрипт.

Seom ()
Ответ на: комментарий от sin-ok

Кусок скрипта:

echo 'Установка 32-битных библиотек необходимых для'
echo '64-разрядной версии драйвера принтера'
if [ $ARCH == 'amd64' ]; then
apt-get -y install libatk1.0-0:i386 libcairo2:i386 >>libgtk2.0-0:i386 libpango1.0-0:i386 libstdc++6:i386 libpopt0:i386 >>libxml2:i386 libc6:i386
check_error PACKAGE $?

Пакетов *:i386 нет в репозитории и они не устанавливаются соответственно, но без *:i386 все пакеты стоят.

Seom ()
Ответ на: комментарий от Seom

Давай добавим пару строк в /etc/apt/sources.list

deb http://ftp.de.debian.org/debian/ wheezy-backports contrib non-free main
deb-src http://ftp.de.debian.org/debian/ wheezy-backports contrib non-free main

deb http://ftp.de.debian.org/debian/ wheezy contrib non-free main
deb-src http://ftp.de.debian.org/debian/ wheezy contrib non-free main
apt-get -y update && apt-get -y -f install && dpkg --add-architecture i386 && apt-get -y update 

и затем попробуем установить

apt-get install libatk1.0-0:i386 libcairo2:i386 libgtk2.0-0:i386 libpango1.0-0:i386 libstdc++6:i386 libpopt0:i386 libxml2:i386 libc6:i386 

При успешном исходе попробуем запусть еще раз скрипт.

sin-ok ()

Хubuntu 14.04 LTS. После последней поломки оного

Само сломалось?
Чини/ставь его же и больше не ломай.

amorpher ★★★★★ ()
Ответ на: комментарий от sin-ok

Да, помогло! Большое спасибо за помощь!

Добавил репозиторий, установил пакеты :i386. Запустил скрипт, он все сделал без ошибок. Пробую печатать - печатает.

Перезагрузил машину - не печатает.

capstatusui -P LBP-810

*** captstatusui Socket Error ***

Запустил скрипт опять, он все выполнил и принтер заработал с capstatusui, но опять до перезагрузки.

Рестарт сups и ссpd не помогает.

Seom ()
Ответ на: комментарий от amorpher

Само сломалось?
Чини/ставь его же и больше не ломай.

Мало того, что само сломалось, так само и починилось секунд через 30. Но куда-то физически пропало три документа с hdd, которые в это время были открыты в LibreOffice. Тогда-то я и понял истинное значение слова - ВНЕЗАПНО

Seom ()
Ответ на: комментарий от Deleted

=== CentOS7 / Scientific Linux7

Слишком рано, ещё плохо протестировано. Надо до 7.3 подождать.

А вот SL 6.6 - в самый раз!

mv ★★★★★ ()
Ответ на: комментарий от Seom

куда-то физически пропало три документа с hdd

сам догадаешься может?

поставь тот же gnome-disks и посмотри данные SMART

amorpher ★★★★★ ()
Ответ на: комментарий от Deleted

Спасибо, но там решения для 32-битного Debian. И как оказалось, разница есть.

Seom ()

Так. Дома есть Debian и принтер Canon LBP-6000. Драйвер тот же, система та же. Не думаю, что будут отличия.

Итак, во что сделал.

1. Включил репозиторий backports contrib non-free и -

apt-get -y update && apt-get -y -f install && dpkg --add-architecture i386 && apt-get -y update

2. Скачал и запустил скрипт https://googledrive.com/host/0Byemcyi98JRjUjJKMnlqSVVnVlk/canon_lbp_setup.sh

Скрипт что надо скачал, установил, похвалил и закрылся. Принтер начал печатать. Но мы то знаем, что это до первой перезагрузки :)

3. Во время установки скрипта и загрузки системы ругалось на то, что не хватает привелегий для изменения профилей AppArmor. Оке.

sudo nano /etc/default/grub

Добавил security=apparmor в поле GRUB_CMDLINE_LINUX_DEFAULT

sudo update-grub

Перестало ругаться.

4. Перезагружаюсь, с apparmor все хорошо, но:

captstatusui -P LBP6000

*** captstatusui Socket Error ***

Ну и естественно не печатает ничего.

5. Пишу в терминале:

sudo /etc/init.d/ccpd restart

sudo lpadmin -p LBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp://localhost:59687 -E

После этого запускается и работает captstatusui. cups и ссpd работают. Принтер печатает. Но опять же до перезагрузки, потом опять надо:

sudo /etc/init.d/ccpd restart

sudo lpadmin -p LBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp://localhost:59687 -E

Такие дела.

jun@Jun-pc:~$ uname -a
Linux Jun-pc 3.2.0-4-amd64 #1 SMP Debian 3.2.65-1+deb7u2 x86_64 GNU/Linux

Ориентировочно такого же результат добился на openSUSE 13.2. Как решать проблему дальше - пока не знаю.

Спасибо всем, кто откликнулся. Рад буду любому совету :)

Seom ()
Ответ на: комментарий от Seom

Можно через костыль сделать. Скрипт, его выполнение в /etc/rc.local

В .sh как ты понял

/etc/init.d/ccpd restart &&
lpadmin -p LBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp://localhost:59687 -E
При каждой перезагрузке будет выполнятся. В итоге более вмешательств не потребуется.

sin-ok ()
Ответ на: комментарий от Seom

там решения для 32-битного Debian.

А есть ли смысл упираться в x64, если

Из ПО используется офис, браузер, джабер клиент, музыкальный проигрыватель ну и все в общем.

?

Deleted ()
Ответ на: комментарий от sin-ok

Не дает результата:

sudo update-rc.d ccpd defaults

Видимо, надо ковырять конфиг ссpd.

Можно через костыль сделать. Скрипт, его выполнение в /etc/rc.local
В .sh как ты понял

Так и сделаю. Будет такой костыль, пока конфиг ссpd не исправлю. Не совсем правильно, но пока другого выхода нет :)

Seom ()

ТС, попробуй calculate, он заточен на офисы, да и вроде стабильно работает.

Noob_Linux ★★★ ()

Выкинь Canon, возьми HP.

И Убунта/ее варианты, конечно.

LongLiveUbuntu ★★★★★ ()

Хubuntu 14.04 LTS

решил сменить дистрибутив на что-то более стабильное.

В Xubuntu принтер поднимался до безобразия просто.

Xubuntu 14.04 LTS </thread>

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Это рабочий. Не могу выкинуть, при всем желании :) Что дали, на том и вынужден работать :)

И Убунта/ее варианты, конечно.

Только там дружат с Canon?

Seom ()

1. Arch Linux + LXDE - при наличии не много времени (на подготовку к обновлениям, первоначальную настройку).
2. Debian 7 + LXDE - вариант, если этого времени нет.

TheBear ()
Ответ на: комментарий от Seom

Только там дружат с Canon?

Только там дружат с конечным пользователем.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от Deleted

А есть ли смысл упираться в x64

Именно на этом компе возможно и нету смысла, но я пробовал его на 32 бит openSUSE подцепить, те же проблемы, на сколько я помню.

Seom ()
Ответ на: комментарий от TheBear

К Debian 7, например, у меня не выходит адекватно прикрутить Сanon LBP-810.

Seom ()
Ответ на: комментарий от sT331h0rs3

Xubuntu 14.04 LTS </thread>

У меня с ней не сложилось.

Пару дней назад на ровном месте завис ЛибреОфис и после >>завершения задачи унес с собой в небытие с hdd три открытых >>документа. Навсегда. Я не знаю, виноваты в этом мои руки, >>ЛибреОфис, или Хубунту. Но два фактора из трех я могу заменить :D

Seom ()
Ответ на: комментарий от Seom

Люди делятся на тех, кто ещё не делает бэкапы, и тех, кто уже делает.

sT331h0rs3 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.