LINUX.ORG.RU
ФорумAdmin

openWRT VPN через соседний роутер

 


0

1

Ребята кто может рассказать как должен быть настроен роутер с прошивкой openWRT, чтобы он получал интернет через соседний роутер и при этом подключался к VPN серверу pptp находящемуся в интернете и раздавал по вифи доступ именно через это впн соединение. В и тоге хочу получить роутер с простой заводской прошивкой (тплинк) - соединяется с интернетом - раздает интернет по кабелю ethernet и по wifi безо всяких VPN. К нему подключен роутер c openWRT - dlink dir320. dlink по pptp поднимает vpn соединение с внешним VPN сервером (купил vps и поднял там pptp) и по своему WIFI раздает интернет, которые должен проходить через VPN. я максимум до чего дошел - это dlink соединяется с интерентом и поднимает VPN. Но я не понимаю как заставить WIFI проходить через VPN. т.к. соединяясь с dlink по wifi почему-то соединение идет через tplink напрямую в интернет, а не через VPN. Я не могу заставить его маршрутизировать трафик через VPN. Подскажите какой должен быть конфиг. Может это и VPN сервак надо по другому настраивать. Я еще не мутил такие схемы и не понимаю как оно должно быть устроено. Заранее спасибо.

P.S> Конфиг, не графика. VPN я сломал на dlink. теперь его совсем нет. И я не понимаю как он вообще должен быть настроен на dlink.

Сейчас настроено так:

tplink:
DHCP enable
IP Address:192.168.1.1
Subnet Mask:255.255.255.0
Default Gateway: 192.168.1.1
DNS Server: 8.8.8.8
Dlink openWRT

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd52:a4f2:c772::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.10'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '2a:10:7b:55:a7:96'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '2a:10:7b:55:a7:97'

config interface 'wan6'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option hostname 'Dir_320'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
Пакеты на dlink для pptp соединения:
kmod-pptp   4.4.92-1    
ppp-mod-pptp   2.4.7-12

Кто распарсил ставим плюс.
ТС Схему нарисуйте.

anc ★★★★★ ()

Ставлю на то, что ты подключаешься в WiFi тплинка, а не openwrt

Deleted ()
Ответ на: комментарий от Deleted

:) не братюнь поднимая такое я не могу быть настолько бараном :) Я точно понимаю, что я делаю и куда соединяюсь, но вот с маршрутизацией у меня пробел в знаниях.

и да wifi тплинка и длинка это разные wifi специально, чтобы не было того, что ты сказал.

Shinma ()

Если у тебя vpn клиент на dir320, то можно объединить TUN и wi-fi в мост и на сервере настроить dhcp. А вообще скорость на dir320 будет печальная.

anonymous ()

Короче теперь VPN на модеме тоже пропал. Перепрошил. Не понимаю какой модуль нужен для правильной работы pptp в openwrt. wifi пока не настраиваю. Есть выход в интернет с dlink. но как теперь на нем поднять VPN и заставить трафик ходить по нему?

Сейчас настроено так:

tplink:
DHCP enable
IP Address:192.168.1.1
Subnet Mask:255.255.255.0
Default Gateway: 192.168.1.1
DNS Server: 8.8.8.8
Dlink openWRT

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd52:a4f2:c772::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.10'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '2a:10:7b:55:a7:96'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '2a:10:7b:55:a7:97'

config interface 'wan6'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option hostname 'Dir_320'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
Пакеты на dlink для pptp соединения:
kmod-pptp   4.4.92-1    
ppp-mod-pptp   2.4.7-12

Shinma ()
Ответ на: комментарий от Shinma

Вот это уже годно. Добавьте в топик.

anc ★★★★★ ()
Ответ на: комментарий от Shinma

Так они у вас в одной сети? Т.е. клиенты wifi с длинка получают defgw 192.168.1.1 ?

anc ★★★★★ ()
Ответ на: комментарий от anc

пока я не настроил толком dhcp поэтмоу клиенты подключенные к dlink вбивают адрес ручками и шлюз и днс. Но я же говор. я просто не понимаю как это сделать по правильному.

Shinma ()
Ответ на: комментарий от Shinma

Ну с точки зрения банального роутинга, у клиента должен быть defgw dlink. Ну а далее всякие nat и iproute2.

anc ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.