LINUX.ORG.RU
ФорумAdmin

Проблема с подключением 3G модема в OpenWrt

 , ,


0

2

Доброго всем времени суток! Есть роутер wr703n с OpenWrt Chaos Calmer 15.05.1 на борту. Модем huawei e3131 в режиме только модем.

Проблема залючается в том, что соединение поднимается примерно через 5-7 минут, до этого идут ошибки. В OpenWrt настроил лишь network, никаких других настроек не применял. Модем протестировал в ubuntu, работает отлично. Логи и конфиг прилагаются.

Ps. ещё заметил такой момент: если соединение установилось и сделать reboot, сам модем не перезагружается и соединение поднимается сразу.

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1e:c090:f83f::/48'

config interface 'lan'
	option ifname 'eth0'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
        option ifname 'ppp0'
        option proto '3g'
        option apn 'internet.mts.by'
        option device '/dev/ttyUSB0'
        option username 'mts'
        option password 'mts'
        option dialnumber '*99#'

/etc/ppp/options

debug
#logfile /dev/null
logfile /dev/ppp_log
noipdefault
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
lcp-echo-failure 5
lcp-echo-interval 1

/dev/ppp_log

http://pastebin.com/vzxKKbEE (успешное подключение в самом конце)

Решено. Включил пин-код на симкарте. Стало соединяться сразу. Может кому-то окажется полезным.

pavel_amp ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.